WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Backend OK, Frontend shows nothing (5 posts)

  1. chrissmit
    Member
    Posted 1 year ago #

    Hi all,

    This is a complete mystery for me!

    I had to restore my MySQLdatabase, 'cause it'd been hacked.

    I had a good DB backup that I restored.
    I then uploaded a complete clean Install from WP.
    Went to the backend and had to fill in some steps for the wp-config.php file.
    Alle went well.

    Now the backend is fully operational, but... the front end ONLY shows the Home page.

    All other pages, when clicked, return a 404 error.
    While all those pages are available and editable in the backend.

    One more thing: I'm using theme 2011, while the original site (the one that got hacked) used another theme.

    This is a complete mystery to me. Who can help?

    thx

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Have you tried resetting your permalinks? What version of WordPress were you running previously?

  3. chrissmit
    Member
    Posted 1 year ago #

    Hi,

    Previous version of WP was either 3.4.1 or 3.3

    I'm not sure how the permalinks were set (in the past).
    Currently they're set to %postname% (I didn't do that, with the clean install I just did it was set to this)

    the url is: http://kooruwel.be

  4. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Previous version of WP was either 3.4.1 or 3.3

    You need to find out which version via the.sql backup file as the daatbase structure changed a couple of times between 3.3 and 3.4.1. The database version number is stored in the wp-options table under the option name db_version.

    I'm not sure how the permalinks were set (in the past).

    Just reset them to the default via Settings -> Permalinks.

  5. chrissmit
    Member
    Posted 1 year ago #

    Hi,

    thanks for the help.
    got is solved now.
    Your first post did it:
    I had set my .htaccess chmod to 444, which caused WP not to be able to change the permalinks.
    I changed it to 644 and it worked.

    thx!

Topic Closed

This topic has been closed to new replies.

About this Topic