WordPress.org

Ready to get started?Download WordPress

Forums

Backend content does not display on site (10 posts)

  1. giackio
    Member
    Posted 1 year ago #

    Hello.

    Every page of my website (with the exception of the blog) displays the wrong content. As of today, one of my blog posts now comes in place of the correct content on every single page ("Services," "Clients," "Contact," "About").

    For reference: http://www.therealitytest.com

    On the backend, in the dashboard, all the correct content is still there. And the problem does not seem to be with the FTP.

    In hopes of fixing it, I just updated to WP 3.5, along with updates to theme and plugins. Also, just attempted to restore the site to the content from a few days ago. Waiting on that. In the meantime, everything seems stuck.

    Thanks in advance,
    Jacqueline

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. giackio
    Member
    Posted 1 year ago #

    Hey Esmi,

    Thanks for the tip. I apologize cause I'm fairly slow on the technology front.

    I deactivated all five of the plugins and reactivated them. Nothing seemed to change. Would that likely be the cause, since the problem started before I touched them at all?

    And any changes I'm making to backend are not registering. For example, I deleted the entire page "Grants + Applications" from the dashboard and it still shows up on the website.

    I'm worried about losing all my content, since it's not backed up. If I try to backup now, will it make a copy of the backend (i.e. what's on my dashboard) or the frontend (what is displayed on the web)?

    Sorry this is such laymen's terms. I'm really bad at this stuff.

    Thanks.

  4. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    I apologize cause I'm fairly slow on the technology front.

    No problem. We all started with zero knowledge at some time. :-)

    Would that likely be the cause

    It's possible - especially if you upgraded WordPress in the meantime.

    I deleted the entire page "Grants + Applications" from the dashboard and it still shows up on the website.

    Do you know if you are running any caching plugins on your site? If "no", ask your hosts and your ISP if they are running web caches. I've known such caches cause confusion before - especially if they are slow and not updated frequently.

    If I try to backup now, will it make a copy of the backend

    If you backup your database at any time, it will back up all of your site's content along with your theme's and plugins' settings. We do recommend that you do make regular backups of your site's database and there is are plugins that can help with this.

    Providing you do not touch the wp-content folder on your site, a re-upload of WordPress core files will not affect any of your site's content or settings. Nothing specific to your site is stored in these files.

  5. giackio
    Member
    Posted 1 year ago #

    THanks so much for your help (and patience!)

    Ok, so now, here's what's happening. I'm just totally re-doing each page. And it seems to be working....at least, it seems to be translating from backend to front end.

    I deleted the old menu and redid one, which seemed to help. But now, when I redo the About page, the permalink is: http://www.therealitytest.com/about-2/ and when I try to get in there and change it to /about/, it insists on adding the -2, like it senses that there's another About page out there somewhere and so won't let me use that permalink. I don't mind redoing some of the site and rebuilding those pages, I just want to make sure that I can get the right permalinks in there. Any suggestions on how to root out that first About page and get rid of it?

    You're my hero! Thanks. :)

  6. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    it insists on adding the -2, like it senses that there's another About page out there somewhere

    There is. It's sitting in your Page Trash. Try removing that old page from the Trash and then re-creating it.

  7. giackio
    Member
    Posted 1 year ago #

    it must be hacked, it had my new about page up for a second, but it's already reverted back to my blog post. ughhh. can a site get hacked like this?!?!

    why is this happening!

    so frustrated!

  8. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    I very much doubt that this is a hack but without a site url, we cannot say for sure.

  9. giackio
    Member
    Posted 1 year ago #

    Hey Esmi,

    You're right. It wasn't a hack. I played around with templates for each page, and found that when I took the widget sidebar away, the problem went away. It turned out to be a faulty widget...one that was supposed to display my latest blog posts, but instead turned the entire identity of the page into the last blog post included in that widget. Very strange.

    Anyway, thank you for trying to help. I really appreciate it.

    Best,
    Jacqueline

  10. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    No problem :-)

Topic Closed

This topic has been closed to new replies.

About this Topic