WordPress.org

Ready to get started?Download WordPress

Forums

All In One Schema.org Rich Snippets
[resolved] Average rating is not working (6 posts)

  1. TheCrazyBastard
    Member
    Posted 10 months ago #

    Hi,
    Thank for that plugin, it's cool but I've a problem maybe with it.
    I use Recipe snipet for my blog and when I check the post with google richsnippet tool, the stars rating not apear, only picture is apear.
    Warning: Rating could not be normalized.
    Warning: Please provide best and worst.

    When some post is rate by anyone, rates are counted.. I have rates, but stars are 0..
    Average rating not working for me.

    <span itemprop="rating" class="rating-value">0</span>

    , but
    <span itemprop="count">6

    What to do, or have to waiting some days..?

    View this screenshot: http://oi43.tinypic.com/jzd082.jpg

    http://wordpress.org/extend/plugins/all-in-one-schemaorg-rich-snippets/

  2. TheCrazyBastard
    Member
    Posted 10 months ago #

    After some hour of reading and testing, I found the problem.
    It's in plugin Simple Facebook Connect.. http://wordpress.org/plugins/simple-facebook-connect/
    While it's deactivated and I check new raiting to post, the yellow stars apear.
    SFC plugin is very usefull for me and I won't to stop it.
    Why conflict and is has some way to repair to work correctly together?
    Thanks!

  3. Nitin Yawalkar
    Member
    Plugin Author

    Posted 10 months ago #

    Hello TheCrazyBastard,

    Thanks for using our plugin.

    The problem you are facing is because of jQuery conflict.

    There is one way to get the problem resolved. Try to rename all the .js files in the plugin directory and from the source also.

    Do let me know what happens.

    Thanks.

  4. TheCrazyBastard
    Member
    Posted 10 months ago #

    Hi, I renamed all .js files and their path from the source, but it conflicts yet. The plugin works correctly while SFC is deactivated, but not together.

    I could not find jquery.js path nowhere to change it to new jquery.tcb.js. Maybe I am missing something and not delevoper :)

    I have to rename all standart names too sure:
    wp_enqueue_script( 'jquery' ); to wp_enqueue_script( 'jquery.tcb' );
    and so on.. ?

    Thank you for help!

  5. Nitin Yawalkar
    Member
    Plugin Author

    Posted 10 months ago #

    Hello again,

    Well, I told you to rename all *.js files only. Since our plugin uses the jQuery file provided by WordPress itself, so you don't need to rename the wp_enqueue_script('jquery') and wp_enqueue_script('jquery-ui').

    If the problem is not with our plugin, please uninstall and re-install the plugin and try to get help from the SFC author. They might help you, as I don't know which js files are they using and why it is being conflicted with the jQuery files provided by WordPress with their plugin.

    Thanks !

  6. TheCrazyBastard
    Member
    Posted 10 months ago #

    Ok, I'll try to get help from the SFC author. :)

    Link to related topic: http://wordpress.org/support/topic/conflict-with-rich-snippets

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.