WordPress.org

Ready to get started?Download WordPress

Forums

Avatars not showing (6 posts)

  1. Optimus
    Member
    Posted 5 years ago #

    hey guys,

    why my user's avatars arent showing when they post comments ... even i can see the avatars in admin panel in Comments section ...

    but publically avatars arent showing ... what i need to do ????

  2. RecycleCindy
    Member
    Posted 5 years ago #

    I also have this problem. Anyone know why the public comments don't show the avatars? I'll bump this in hopes of hearing from someone.

  3. bottleneck
    Member
    Posted 5 years ago #

    Are you guys both using WP 2.6, right?

    Your current theme won't support showing avatars. See comments.php file in the default theme ( wp-content/themes folder ) for details.

    Technically speaking you need to put

    <?php echo get_avatar( $comment, 32 ); ?>

    below

    <?php foreach ($comments as $comment) : ?>
    
    		<li <?php echo $oddcomment; ?>id="comment-<?php comment_ID() ?>">

    in your comments.php file

    Some additional tweaking might be needed.

  4. buddha trance
    Member
    Posted 5 years ago #

    Assuming that you made sure avatars were enabled from the admin dashboard, maybe the theme you are using is not calling the avatars.

    Go to comments.php and see if there is a statement similar to this, just before the comment author

    <?php if(function_exists('get_avatar')) { ?><?php echo get_avatar( $comment, 40, '' ); ?><?php } ?>

  5. bottleneck
    Member
    Posted 5 years ago #

  6. RecycleCindy
    Member
    Posted 5 years ago #

    Thanks for the responses. I found out it's a theme issue. I have just purchased a new WP theme so it won't be an issue with my new template. Thanks everyone for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic