WordPress.org

Ready to get started?Download WordPress

Forums

Avatar sizing (11 posts)

  1. ranger
    Member
    Posted 2 years ago #

    For the life of me cannot figure out how to change the avatar size on my blogs...

    I'm using the Typograph theme and Peter Sterling's Avatar plugin.

    The avatars on my site show up at 30px x 30px.
    I set the size to 80px in the plugin—no change.
    I've looked in the functions.php, style.php, and comments.php within the theme folder, and cannot find anything specifying 30px that I can change.

    Help would be greatly appreciated!

  2. doc4
    Member
    Posted 2 years ago #

    ranger,

    Post a link to the site and I'll bet we can get to the bottom of this quickly.

  3. Big Bagel
    Member
    Posted 2 years ago #

    I'm not familiar with the theme, but check for this function in your comments.php file (or in related files): wp_list_comments(). You want to add/change the avatar_size argument. For example:

    wp_list_comments( array( 'avatar_size' => 80 ) );

    http://codex.wordpress.org/Function_Reference/wp_list_comments

  4. ranger
    Member
    Posted 2 years ago #

    hey there-

    my comments.php file doesn't have any mention of 'avatar'
    nor does the functions.php file.
    in fact, the only mention i can find of avatars is in the style.css

    }
    ul.commentlist li.comment div.vcard img.avatar-64 {}

    the site is viewable here.

    thanks for any help!

  5. chadrew
    Member
    Posted 2 years ago #

    Your avatars are scaled to 32 x 32 using width and height attributes on every img tag, so whatever changes you make in the CSS won't help. Your theme does not seem to set an avatar size, so I guess the culprit is that plugin you're using.

  6. ranger
    Member
    Posted 2 years ago #

    from Big Bagel's comment above, it looks like WP's default avatar size is 32...which I'd guess is the actual size of the avatars at my link?

    i set the Avatars plugin size to 80, but it makes no difference.
    and when i disable the plugin, the avatars on the site stay the same size. wouldn't that mean the plugin isn't the issue?

    there are some installation notes on my Add Local Avatar plugin here, but i'll be darned if i can understand 'em.

  7. Big Bagel
    Member
    Posted 2 years ago #

    Having actually downloaded and looked at the code for that theme...

    In comments.php, you have a function that looks like this on line 27:

    <?php wp_list_comments('type=comment'); ?>

    Change it to:

    <?php wp_list_comments( 'type=comment&avatar_size=80' ); ?>

    or

    <?php wp_list_comments( array( 'type' => 'comment', 'avatar_size' => 80 ) ); ?>

  8. ranger
    Member
    Posted 2 years ago #

    Big Bagel, I used the 2nd option you provided, and it worked like a charm! This is awesome.
    BUT
    The comment replies are still at 32px. Any ideas on how to fix that?

  9. Big Bagel
    Member
    Posted 2 years ago #

    That should change them all. I noticed some of the avatars are being served from gravatar and some are being served locally; if your still using a plugin for local avatars it might be causing the different sizes.

  10. ranger
    Member
    Posted 2 years ago #

    No dice...I disabled the avatar plugin and the issue is still the same— reply avatars are still 32px

  11. Big Bagel
    Member
    Posted 2 years ago #

    With the default typograph theme and no plugins that should change all of the avatars. Except for something that plugin did, I don't really know what could be causing it to show different sizes.

    If you plan on using the plugin it would probably be better not to do this, but did you actually uninstall it after deactivating it? If it was properly coded, uninstalling through the plugin page would remove all stored settings that might still be interfering. If you still want to use the plugin, try poking at it's settings.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.