WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Autosave not working after upgrade to 2.2 (11 posts)

  1. Cavalary
    Member
    Posted 7 years ago #

    What happened to the autosave? I see the function call there, so wasn't removed, but it's not working anymore... Checked to see if there's an option to enable it (seeing that some complained about it in 2.1), didn't see any there either, so what happened?
    Did log out, clean files and cookies and log back in too, still nothing.

  2. MichaelH
    Member
    Posted 7 years ago #

    It's working for me. How do know it is not working?

  3. Cavalary
    Member
    Posted 7 years ago #

    Um, because it's not saying "Last saved at <time>" anymore and because I got used to the autosave so happen to navigate away from the edit page without hitting save first and when I did it now I lost what I was writing...

  4. MichaelH
    Member
    Posted 7 years ago #

    I do see the "Saved at" text to the left of the Save and Continue Editing button and it does warn with the "Are you sure you want to navigate away" message. I'm working on a 2.2 site upgraded from 2.1.3 using FireFox 1.5.0.11

    Got another computer you can test that on?

  5. Cavalary
    Member
    Posted 7 years ago #

    Sorry for the delay, wanted to get to another computer before replying again since you suggested that. Won't work. Won't work in FireFox (latest version) either. I think I figured out why though. It's telling me that realTinyMCE is not defined in /wp-includes/js/tinymce/tiny_mce_gzip.php and from that it goes on to say that tinyMCE.getInstanceById is not a function in /wp-includes/js/autosave.js
    So that seems to be the issue, just wondering why. Everything seems uploaded properly...

  6. Cavalary
    Member
    Posted 7 years ago #

    *bump*

  7. poorcookie
    Member
    Posted 7 years ago #

    I upgraded to 2.2 just yesterday and noticed that the autosave was not working either. But today it seemed to work just before I was about to publish the entry. Although this may be unrelated, I left the title blank until right before I published, and after I filled in the title it autosaved.

  8. Cavalary
    Member
    Posted 7 years ago #

    So I guess nobody can figure this out... :/

  9. MichaelH
    Member
    Posted 7 years ago #

    There was this post yesterday on the hacker email list but there've been no responses. Maybe it is related:

    http://comox.textdrive.com/pipermail/wp-testers/2007-May/004688.html

  10. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    a) Make sure that you uploaded *all* of the 2.2 files.
    b) On Options->Reading, try turning off "WordPress should compress articles (gzip) if browsers ask for them" and see if that helps.
    c) Various plugins and other things have been known to cause this issue in the past. Disable your plugins and reenable them one by one until you find the culprit.
    d) Various Firefox extensions have also caused this error in the past. Upgrade all your extensions. Failing that, disable them and reenable them one by one.

    Until you find the cause of the problem, it will not be fixed.

    Because the short of it is that we don't have this problem. It works fine for me, for example. So I cannot tell you what's wrong. You have to tell us what's wrong, so that we can tell you a workaround or maybe even make a fix for it for the next version of WordPress. Just saying "it don't work" is less than helpful.

  11. Cavalary
    Member
    Posted 7 years ago #

    That helped, thanks. My recent comments plugin was blocking things apparently. The interesting thing is that it still works after I reactivated it, guess it was just a glitch. (Unfortunately, the editor also works now. Disabled visual of course, but I'd still want to have just a simple text box with no buttons above it again.)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags