WordPress.org

Ready to get started?Download WordPress

Forums

Autoptimize
[resolved] Autoptimize With W3 Total Cache (10 posts)

  1. gooma2
    Member
    Posted 10 months ago #

    I checked through the forum to make sure it hadn't been asked before, but I wanted to see how Autoptimize would work with W3 Total Cache.

    As most know, W3TC can be very very moody, especially with minify, so I wanted to see if these two would be able to work together well, especially to handle those minify options without being so complicated?

    Thanks

    http://wordpress.org/plugins/autoptimize/

  2. futtta
    Member
    Plugin Author

    Posted 10 months ago #

    I haven't tested with W3TC, as that comes with minify-options of its own, but I would expect that, if all minify inside W3TC is turned off, Autoptimize should be able to take that part over. Give it a shot and keep us posted on your findings :-)

  3. gooma2
    Member
    Posted 10 months ago #

    http://bestmoviesevernews.com/

    I just did and man does it load very quickly, but without out ads. I know this is the fun JS part and I've tried ticking both the Force JS in Had and try-catch wrapping, but nothing has changed yet.

    It's just when you untick JS that the site goes back to normal. I know there's a way to make this work without having to go through that W3 Total Cache Minify nightmare.

  4. gooma2
    Member
    Posted 10 months ago #

    so I ticked off all of these:

    Look for scripts only in <head>? Disabled by default. If the cache gets big, you might want to enable this.

    Force JavaScript in <head>? Disabled by default. For performance reasons JavaScript is best put at the end of the HTML, but in some circumstances this breaks things. You can in that case check this option to add JavaScript to the <head> section.

    Add try-catch wrapping? Disabled by default. If your scripts break because of an script error, you might want to try this.

    And the ads come back perfectly. The only issue is my homepage is broken slightly. I'm not sure if that would be a CSS style issue or not.

  5. futtta
    Member
    Plugin Author

    Posted 10 months ago #

    Well, if the homepage remains broken if you disable javascript optimization altogether, then it's a CSS-issue, otherwise it's js-related.

  6. gooma2
    Member
    Posted 10 months ago #

    That's interesting. When I did untick the Optimize JS Code, the site looked normal again.

    I kept the Optimize CSS code ticked too.

    I noticed in forums you had mentioned your development version (1.6.6) of this plugin and I just uploaded it. I'm not seeing anything different though.

    I'm just determined to get this working tonight. Our ad code is what keeps slowing our site down so I'm trying to figure out how to work with it. Without the ads it loads in 1.4 seconds, but with it, it shoots up to 8 - 9 seconds but they pay the server and our employees.

  7. gooma2
    Member
    Posted 10 months ago #

    I was able to locate and figure out that it was the flexslider and tabs that are getting broken, but when I put those js names into the 'Exclude scripts' section, it seems to be ignoring them.

    I did both ways putting the .js with them and without to see if that made a difference.

  8. futtta
    Member
    Plugin Author

    Posted 10 months ago #

    the reason might be a dependancy, like jquery. in that case you'll have to exlcude that as well.

  9. gooma2
    Member
    Posted 10 months ago #

    I'll try that next today. Thanks!

  10. VenturaVan
    Member
    Posted 9 months ago #

    Hey gooma2, Did that work?

Reply

You must log in to post.

About this Plugin

About this Topic