WordPress.org

Ready to get started?Download WordPress

Forums

Autoptimize
autoptimize 1.8.x: problems and how to solve them (28 posts)

  1. Frank Goossens
    Member
    Plugin Author

    Posted 6 months ago #

    If you are running into problems with Autoptimize;

    If you did all this and you're still having problems, you can file this as a new topic (i.e. do not reply to this post) in the support forum.

  2. Frank Goossens
    Member
    Plugin Author

    Posted 6 months ago #

    There is a bug in 1.8 which results in CSS in conditional comments ("iehacks") not being excluded, more info here.

    If the fix is confirmed, I'll push out 1.8.1 in the following hours. Sorry for the inconvenience!

  3. Frank Goossens
    Member
    Plugin Author

    Posted 6 months ago #

    update; 1.8.1 was released just now, conditional comments are excluded from autoptimization again.

  4. Frank Goossens
    Member
    Plugin Author

    Posted 5 months ago #

    In some cases (e.g. when using Dynamic to Top) a conflict of CSS minfiers causes "white screens of death". Disabling CSS optimization in Autoptimize or disabling the plugin that has the conflicting CSS minifier will fix this. 1.8.2 (due 2nd half of february) will have a fix for this.

  5. sata2z
    Member
    Posted 5 months ago #

    Hi, I got 500 internal server error after using this plugin. Please give me a solution.

  6. Frank Goossens
    Member
    Plugin Author

    Posted 5 months ago #

    Hi Sata2z;
    Do you have the 500 on the backend (/wp-admin/... but that is unlikely) or on the frontend of the blog? If on the frontend: disable all optimization (HTML, CSS and JS) and then try them one by one to identify the one which is causing the error. Once you have that, you should be able to activate the other ones.

    The rootcause most probably is another plugin which is also doing CSS and or JS optimization (e.g. "dynamic to top" as mentoined earlier or W3 Total Cache CSS/JS optimization). Disabling other plugins while having Autoptimize fully active (for HTML/ CSS/ JS) could help you identify which plugin is not compatible. If you have that, I can look into what is going wrong and if I can solve this.

    Hope this helps,
    frank

  7. sata2z
    Member
    Posted 5 months ago #

    Hi Frank thanks for your quick response. I deleted W3 Total Cache in my plugin list. And i disable css and js check box, now running page correctly. But page speed is still same.

  8. Frank Goossens
    Member
    Plugin Author

    Posted 5 months ago #

    Well, you don't have to delete W3TC, just make sure it doesn't do CSS/JS optimization. Do you have the white screen when enabling just CSS and also when enabling just JS?

  9. sata2z
    Member
    Posted 5 months ago #

    Yes, if i enable CSS the white screen with error displaying. And if i enable JS my website other popup's are not working.

  10. Frank Goossens
    Member
    Plugin Author

    Posted 5 months ago #

    For the JS-part; you need to configure it, I advise you to read the FAQ for that.

    For the CSS-part; what other plugins are you using? What theme? What do you see in your PHP-error-log?

  11. sata2z
    Member
    Posted 5 months ago #

    ********plugins list********
    Appointy - Appointment Scheduler, Automatic Sign Out For Inactivity, Contact Form 7, Email Log, Email newsletter, Events Manager Pro, JE Alert, JE Coupon, JE Custom Fields, JE LinkedIn, JE Paypal Express, jQuery Mega Menu, Widget Logic, Widgets on Pages, WordPress Ad Widget, WP News Bulletin

    *****Theme name****
    http://demo.enginethemes.com/jobengine-preview/

    where i can find PHP-error-log, please advice?

  12. Frank Goossens
    Member
    Plugin Author

    Posted 5 months ago #

    For the location of your PHP-error-log you should check with your hoster. The info in there will probably be very relevant, so it is probably very worth while to look into it.

    Regarding the plugins; if possible it would help to briefly disable all plugins but Autoptimize and see if CSS optimization still triggers the white page. If not, the problem is with a plugin, if yes the problem is with the theme (which you can also confirm by briefly switching themes).

  13. Frank Goossens
    Member
    Plugin Author

    Posted 4 months ago #

    For those who encounter problems, a first version of what will become 1.8.2 has just been pushed to http://downloads.wordpress.org/plugin/autoptimize.zip.

    Some of the improvements/ fixes included;

    • deferred CSS added in noscript-tags
    • check for availability of method on minifier class before invoking it (yet another white screen of death being offed)
    • improvements in CSS import code

    Feel free to download and provide feedback here!

  14. LuxDelux
    Member
    Posted 4 months ago #

    Just downloaded the dev version, trying to make deferred css work with

    <!--noptimize-->
    <style>body { background: #eaeaea; }
    </style>
    <!--/noptimize-->

    the above part is not loaded... Did I miss how this is supposed to work? As I figured it, the point would be to load the essential css inline like above and deferr the rest. So I included that and enabled the deferr css option.

    Is it supposed to be done differently? Thanks for all your work :)

  15. Frank Goossens
    Member
    Plugin Author

    Posted 4 months ago #

    Evening LuxDelux;

    body { background-color: #eaeaea; }

    might be better? if you put that in between the noptimize-tags as shown in your example (and style-tags, off course) that indeed should work (i.e. the CSS should be inline instead of aggregated in the autoptimize_*.css file).

    hope that helps,
    frank

  16. LuxDelux
    Member
    Posted 4 months ago #

    Sorry, I didn't explain my problem clear enough:

    - the inline css is in the head with noptimize-tags
    - the "Defer CSS loading?" option is checked

    the css files are deferred but the inline part is not loaded by the browser. I can see it in the code but the styles aren't applied to the elements. It loads when "Defer CSS loading?" is not checked but that doesn't bring much load improvement (per your website post I had the idea to deferr everything except critical parts)

    I tried switching the inline part around (before and after wp_head()) but nothing seems to make a difference.

    Any ideas? Or is this functionality not yet implemented?

    Cheers

  17. LuxDelux
    Member
    Posted 4 months ago #

    Ah ok I figured it out, for some reason some of the values, like for example

    font-family

    was not being applied unless I added !important

    Even though there's no other font-family in the css files. Weird

  18. Frank Goossens
    Member
    Plugin Author

    Posted 4 months ago #

    I was about to setup a test-blog for you, so I'm glad you got it sorted out :-)

  19. healthable
    Member
    Posted 3 months ago #

    Well this is the only plugin that worked for me in minifying my files but unfortunately it stops Adsense from displaying, Maxblogpress subscribers magnet pop up from working

  20. Frank Goossens
    Member
    Plugin Author

    Posted 3 months ago #

    Well, it's all about configuration Healthable, as you found out in the mean time (for the adsense part) :-)

  21. Frank Goossens
    Member
    Plugin Author

    Posted 2 months ago #

    Quick update; I just committed a test-build of AO 1.8.5 to the trunk-build with multiple small improvements and bugfixes (still have to write the changelog). It would be great if you could download & test to confirm this does work?

  22. andyburton
    Member
    Posted 2 months ago #

    Your plugin screwed up our site. We tried deleting it, we tried deleting super cache...but nothing works. How can you release such a stupid plugin which screws up everyone's work.

    i have sent you an email with details.. please FIX urgently.

    This is crazy.

    Andy

  23. andyburton
    Member
    Posted 2 months ago #

    It was not autoptimize that screwed up the site. It was some sort of cache issue that arose after we installed autoptimize. Our developers fixed it. Sorry for the confusion.

    Andy

  24. Frank Goossens
    Member
    Plugin Author

    Posted 2 months ago #

    Thanks for clarifying Andy!

  25. blau
    Member
    Posted 1 month ago #

    hello futtta,

    just for your information I ran into issues after a mass upgrade to:

    autoptimize 1.8.5
    wordpress 3.9.1
    Pagelines Framework 2.4.5

    - top navbar dropdown menus no longer there;
    - feature slider css broken, shows all feature images instead of transition effect.

    Solution: Simply disabling html optimization fixes the issue. The other setting
    is just css optimiziation, no js.

    If you like, you can see the site here (in fixed state):
    http://alfabeta2.bamaulion.net/
    Just tell me if you need me to reproduce the error.

  26. Frank Goossens
    Member
    Plugin Author

    Posted 1 month ago #

    interesting Blau. what version of AO were you on before? changes in the last few version were pretty minor. my bet would be on the pagelines framework. do you have any idea what exactly breaks (or rather, why it does) when enabling HTML optimization?

    frank

  27. blau
    Member
    Posted 1 month ago #

    Hi frank, I can't remember the original AO version, my guess is a Pagelines Framework snafu, but can't be sure because I didn't notice it immediately when I did my step by step upgrades.

    blau

  28. Frank Goossens
    Member
    Plugin Author

    Posted 1 month ago #

    No hands-on experience with Pagelines I'm afraid. Looked at the website and I'm somewhat confused; is this a plugin (and/or theme) I can install in a default WP, or is this a WP-distro which I have to install from scratch? Or do you have a test-install which I could play around with to see what is going on?

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.