WordPress.org

Ready to get started?Download WordPress

Forums

Autop, first line (12 posts)

  1. superultra
    Member
    Posted 9 years ago #

    In reference to: http://popularstranger.com/
    I want the comments, and the post, not to have the standard p line break at first. As you can see from the blog, the comments and post show directly follow the preceding text without a line break. However, commenting out the autop in template-functions-post.php and template-functions-comment.php results in absolutely no line breaks at all, even when they are intended.
    Workaround anyone?
    Thanks - jwb

  2. Beel
    Member
    Posted 9 years ago #

    As I recall you site is done with tables? Can you select the p in the css and display:inline?

  3. superultra
    Member
    Posted 9 years ago #

    Beel, Kafka. thanks for the help.
    Beel: I have just one table that contains all the text, so as I understand it display:inline wouldn't work?
    Kafka.: I think you did, but thanks anyway.
    What happens when I have autop enabled is this:
    -----------------------------------
    Tonya said:
    Inspired by S*, I am taking a closer look at my choices for the US House this year. Offhand, I like Julia because she’s ballsy (well, as
    Then John said:
    This is the start of the comment and it'd be nice if it were right at the top. this is a new paragraph. this is as well
    -------------------------
    What I would like to have happen is this:
    --------------------------
    Tonya said: Inspired by S*, I am taking a closer look at my choices for the US House this year. Offhand, I like Julia because she’s ballsy (well, as
    Then John aid: This is the start of the comment and it'd be nice if it were right at the top.
    this is a new paragraph
    this is as well

  4. Beel
    Member
    Posted 9 years ago #

    Since you are the one with tables, you would be the one to test it. Try something like:
    table p {display:inline} or just
    p {display:inline}
    I suspect you will then have to use

    to get a clear separation where you want the p tags to display normally, eh?

  5. superultra
    Member
    Posted 9 years ago #

    Doesn't change anything, unfortunately. I still get this when enabling autop but have the display:inline:
    ---------------------------------------
    Dh whispered "
    ...after i looked it up…
    I am very sad right now.
    "
    CPH mumbled "
    Dh, you are so not l337.
    "
    Someone opened their mouth to speak, but CPH said "
    But I love you for it.
    "
    eric said "
    i always understood it to be an expression of excitement. evidently, though, it’s also a way of life (see number nine)? i just can’t keep up with kids these days.
    "
    -------------------------
    Would this be easier if I were using a CSS layout instead of tables Beel? (again, much obliged)

  6. Beel
    Member
    Posted 9 years ago #

    To be honest, I do not know if this particular problem would be easier to fix without tables. I am aware, however, that tables are not really called for with your current layout and may cause additional restrictions.
    I tried the p {display:inline} on your site using the Web Developer extension in FF and it seemed to work (perhaps not in IE and that is what you are using?)
    Short of removing the auto generation of the p tag I see no other way, using css, to have the post *not* appear as a new paragraph and abut "So and so mumbled:"
    I'll leave that up to the CSS gurus.

  7. superultra
    Member
    Posted 9 years ago #

    Hmm. Using firefox here, but maybe I'm just CSS-ignorant. I'm just adding p {display:inline} to the css stylesheet right?

  8. Beel
    Member
    Posted 9 years ago #

    Yeah, is this not what you wanted:
    She said: line 1
    line 2

  9. superultra
    Member
    Posted 9 years ago #

    Yeah, the post works fine but the comments don't at all. I've added a test post so you can see what's happening.

  10. Beel
    Member
    Posted 9 years ago #

    Well, I am not sure what you want with the comments. If you mean you want them on their own line you'd have to edit below "You can start editing here" and add a couple of
    s I suspect.

  11. superultra
    Member
    Posted 9 years ago #

    I would like to have the comments have line breaks. As you can see here:
    http://popularstranger.com/index.php?p=248
    with autop turned off, there are no line breaks whatsoever. If they are turned on, I get:
    ---------------------------
    eric said "
    i always understood it to be an expression of excitement. evidently, though, it’s also a way of life (see number nine)? i just can’t keep up with kids these days.
    "
    ------------------------------
    Strange, that it would work in the post and not in the comments.

  12. superultra
    Member
    Posted 9 years ago #

    Well, actually I guess it doesn't does it. The post has a line break between the said: and the following html.
    So, how do I make the post not line break the first line so that it lines up with the previous text, but line break every time the user line breaks? Why does wordpress insist on p-ing everything? =)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.