WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Automatically park domains? (16 posts)

  1. JHouse
    Member
    Posted 2 years ago #

    Hi,

    Is it possible to park domains automatically as opposed to adding them manually, one by one, via cpanel? I'm using WordPress MU Domain Mapping and HostGator's Business Plan cpanel, if that makes any difference.

    Thanks.

  2. If you have a vps and access to Apache, yes. You can put in a named wildcard to skip the parking part. This bypasses cpanel.

  3. JHouse
    Member
    Posted 2 years ago #

    Great, a VPS is my next step. Thanks Andrea. I'm actually about to buy one of your plugins/ebooks 'cause it's perfect for my ultimate plan. Muhahaha.

    On another note, while I can get the sub sites to launch, each with their own domain, the homepage comes up fine, but none of the pages I create, nor the sample page. Instead, I get a 404 error. I can add and edit them via the dashboard, but can't view them publicly. Any ideers?

    Thanks again!

  4. It's the htaccess file or the server is just not reading it. common issue.

    http://wpmututorials.com/installation2/subfolder-blog-have-no-theme-styles/

    And one of those ebooks has the techie hard bits on how to do that server setup. ;)

  5. JHouse
    Member
    Posted 2 years ago #

    Okay, hosting tech support says the server can read the htaccess file fine and that it might be an issue with my entry. Here's what I copied (from Network Setup htaccess settings:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
  6. JHouse
    Member
    Posted 2 years ago #

    Whoops, hit "Post" a little too prematurely. Doh.

    Anyways, if you have any other ideas, I'm open.

    BTW, I just got your Replicator plugin about an hour ago -- I'm looking forward to implementing it.

    Take care.

  7. Ask your host what 'AllowOverride' is set to in your httpd.conf, if you can't look yourself.

    Your .htaccess is just fine. The more complex patterns aren't being read. That means your server's not parsing the .htaccess correctly which means your host? Is incorrect :)

  8. JHouse
    Member
    Posted 2 years ago #

    Thanks for your help Ipstenu.

    They, tech support, says this file is on by default. They also said that the domain mapping plugin is in the wrong plugins' folder and that it needs to be in the mu-plugins folder instead.

    I'm using WordPress MU Domain Mapping and according to their instructions, http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/installation/ it's supposed to go in the regular plugins' folder, but according to Otto's instructions, http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/ it's supposed to go into mu-plugins' folder. Oh my, which one?

    Thanks again.

  9. either one will work. if you put it in the plugins folder *network* activate it.

    They do the *same thing*.

    But that has nothing to do with the sub sites not working. test the original subsite urls before mapping please. they HAVE TO work before you map domains.

  10. JHouse
    Member
    Posted 2 years ago #

    Okay, cool, thanks for the clarification Andrea.

    Per your advice, I created a new subsite "test" and while the homepage comes up, test.xxxxxx.com/sample-page does not. It's worth noting that I didn't map this domain yet, just the others.

    Thanks!

  11. JHouse
    Member
    Posted 2 years ago #

    It's worth noting that I changed my primary site's permalinks from /blog/xxxxxxxxxx/xxxxxxx to /listings/%postname%/ shortly after setting up Multisite. Since then though, I've tried changing it back, but I forgot the original path, so I reverted to /listings/%postname%/. Before doing so though I tried setting it to WP's default ugly links, thus xxxx.com/?p=123, but to no avail. So, I'm back to using /listings/%postname%/ for the time being. I should have mentioned this earlier. Sorry.

  12. It's worth noting that I changed my primary site's permalinks from /blog/xxxxxxxxxx/xxxxxxx to /listings/%postname%/ shortly after setting up Multisite.

    And how did you do this? Because in subfolder installs, you cannot change the /blog/ part on the main site.

  13. JHouse
    Member
    Posted 2 years ago #

    To be honest, I've been asking myself the same question. I was surprised that I could change it and the primary site would still work, as well as the subsite homepages, so I thought I was good to go. I'm trying to get it back to the defaults for permalinks now, but as mentioned I forgot the path for the Custom Structure (for Multisite) and/or if I am supposed to add a category base back.

    Here's a screen shot of what I currently have for the main/primary site's permalinks:

    http://wp4re.com/images/PBI_Permalinks_8.30.11.jpg

    Thanks again for your help.

  14. that looks like what you get out of the box.

    and make sure you've got the right htaccess stuff in there - the rule you were given on the network setup screen.

  15. JHouse
    Member
    Posted 2 years ago #

    Thanks for the input.

    Yeah, I copied and pasted the rule from Network Setup screen to my htaccess file (it's the only code there), but no luck. Here's what I have for my wp-config file, per the Network Setup instructions, if it makes any difference:

    define('WP_ALLOW_MULTISITE', true);
    
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'propertybyinfo.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    define( 'SUNRISE', 'on' );
    
    define('WP_DEFAULT_THEME', 'D23_v1');
    
    /* That's all, stop editing! Happy blogging. */

    Thanks again to both of you for your efforts.

  16. JHouse
    Member
    Posted 2 years ago #

    Total rookie mistake...it was a plugin conflict. I betcha that's one of the first things I was suppose to check if I had read the Multisite Forum stickys. That's what I get...haha, damn...

    Thanks again for your help.

    Now on to the next step...this stuff is exciting...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.