WordPress.org

Ready to get started?Download WordPress

Forums

Automatic Upgrade Reminder - Already Using 2.7.1 (14 posts)

  1. savagemike
    Member
    Posted 5 years ago #

    OK so here's the deal. I have a blog hosted with GoDaddy, and I updated to 2.7.1 the first day it was available. All was good for a while, but lately everytime I visit the dashboard I get that yellow reminder at the top to upgrade to 2.7.1. So I dutifully click on it only to have it tell me I'm already using the latest version (which I already knew anyways!).
    Today I decided to let it automatically reinstall 2.7.1 but something happened and it never finished. My blog was stuck in maintenance mode! So I reinstalled it manually and deleted the .lock file and now it works.
    So I guess my issue is how do I get it to stop asking me to upgrade to the version it already is? Because now it keeps telling me "An automated WordPress update has failed to complete - please attempt the update again now." Annoying,
    site is located at http://blog.asavagebydesign.com

  2. omgitztrey
    Member
    Posted 5 years ago #

    Oh god, please let me know when you find a solution. That is annoying the hell out of me too!

  3. t31os
    Member
    Posted 5 years ago #

    Check the database reflects the latest version.

    Run this SQL in PHPMYADMIN on your WP database (just click SQL in phpmyadmin)..

    SELECT option_value
    FROM wp_options
    WHERE option_name = 'update_core'
    LIMIT 0 , 2

    NOTE: The above should have backticks on either side of option_value, wp_options, and option_name ... You'll need to add them into the query for it to work (forum removed them when posting).

    You should have 1 result, click on edit (pen icon usually).

    You should see something like this...

    O:8:"stdClass":3:{s:7:"updates";a:1:{i:0;O:8:"stdClass":5:{s:8:"response";s:6:"latest";s:3:"url";s:30:"http://wordpress.org/download/";s:7:"package";s:40:"http://wordpress.org/wordpress-2.7.1.zip";s:7:"current";s:5:"2.7.1";s:6:"locale";s:5:"en_US";}}s:12:"last_checked";i:1239707874;s:15:"version_checked";s:5:"2.7.1";}

    Notice the 2 lines relating to latest version and current, the above is an example from my local install.

    Now i'd not suggest touching them just yet, but see if yours looks the same as the above..

    If they differ i can test modifying the above to make sure it doesn't break anything before you guys do so... ;)

  4. savagemike
    Member
    Posted 5 years ago #

    Sorry for the delay on my response...
    OK So I attempted to run the SQL query & this is what I get back:

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '\option_value\
    FROM \wp_options\
    WHERE \option_name\ = 'update_core'
    LIMIT 0 ' at line 1

    Don't want to sound like a n00b here, but maybe I misunderstand what a backtick is? I assumed it was a back slash (not too good with SQL as you can see...)

  5. savagemike
    Member
    Posted 5 years ago #

    bump

  6. shokk
    Member
    Posted 5 years ago #

    Another annoying bug, but it only affects one blog.

  7. t31os
    Member
    Posted 5 years ago #

    Savagemike, the reason the query fails is because of the missing backticks, as i mentioned before (NOTE: bit in bold), they need to be present either side of the values... option_value , wp_options, and option_name

    I ran the query before posting it.

    If you can confirm the above we might just find that it missed the update to the database table, in which case that may not be the fault of WP (there's many other possible reasons).

    You can always browse to the table in PHPMYADMIN if you're comfortable in doing so... The query was simply to get the data quickly and easily without the need to write a step by step..

  8. Mark / t31os
    Moderator
    Posted 5 years ago #

    Tell you what, to make it easier, just place this into your theme's header.php somewhere...

    <?php if (current_user_can('level_10')) print_r( get_option('update_core')); ?>

    Only an admin with level 10 authorisation will see the output (so not your visitors)...

    You can switch that to a lower level if need be...

    ..you'll get an output on the page, it should contain the info i mentioned before...

    Check and make sure the versions match up...

  9. savagemike
    Member
    Posted 5 years ago #

    t31os_: I will try that code snippet in the head, but my original point was I don't know what a "backtick" is. Please re-read my reply and let me know exactly what a backtick is, as I assumed it was a backslash when apparently it is not.

  10. savagemike
    Member
    Posted 5 years ago #

    t31os_: Here is the output from your last advice:

    stdClass Object ( [updates] => Array ( [0] => stdClass Object ( [response] => upgrade [url] => http://wordpress.org/download/ [package] => http://wordpress.org/wordpress-2.7.1.zip [current] => 2.7.1 [locale] => en_US ) ) [last_checked] => 1242000038 [version_checked] => abc )

    As far as I can tell, the versions match up. I upgraded to 2.7.1 as soon as it was available.

  11. t31os
    Member
    Posted 5 years ago #

    As indicated in the reply box, see the example text below where you reply here..

    Following the text "Put code in between"

    The header method is easier anyway, so just stick with that... :)

  12. Mark / t31os
    Moderator
    Posted 5 years ago #

    Looks like the versions do match up...

    Ok how about if you run a search in PHPMYADMIN...

    Check for..
    2.7

    Of course it'll match the records where it finds 2.7.1 also, but i'm curious to see if any others turn up...

    If the tables are correct then i really can't see any reason why it would still be getting picked up as 2.7 and not 2.7.1 ... (pretty sure it's not been hard-coded)..

    I've upgraded twice from 2.7 to 2.7.1 and not had this problem myself...

  13. savagemike
    Member
    Posted 5 years ago #

    Ok I ran the search for 2.7 on all tables & it came back with 12 results:

    2 matches in wp_ak_twitter
    2 matches in wp_comments
    8 matches in wp_options

    I browsed the results, & decided the ones in wp_ak_twitter & wp_comments were unimportant. However I found a result in wp_options whose option name is "update core" & it's set to autoload. Could this be the cause of my problem?

    Here is what is listed under option_value:

    O:8:"stdClass":3:{s:7:"updates";a:1:{i:0;O:8:"stdClass":5:{s:8:"response";s:7:"upgrade";s:3:"url";s:30:"http://wordpress.org/download/";s:7:"package";s:40:"http://wordpress.org/wordpress-2.7.1.zip";s:7:"current";s:5:"2.7.1";s:6:"locale";s:5:"en_US";}}s:12:"last_checked";i:1243286546;s:15:"version_checked";s:3:"abc";}

  14. Mvd
    Member
    Posted 4 years ago #

    Hi, I have this problem on a 2.9.1. installation that was a fresh install (no upgrade on that yet) it keeps asking me to upgrade to the current versioon wich I'm already running. I have this on another installation too which was upgraded from 2.8.4 all the way to 2.9.1. the problem started with the 2.9 upgrade.
    Has anyone found the answer?

    P.s. on this first installation it happened after I installed a (up to date) plugin.

Topic Closed

This topic has been closed to new replies.

About this Topic