WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Automatic Upgrade of plugins and wordpress problems? (12 posts)

  1. greencode
    Member
    Posted 5 years ago #

    I always experience this and so end up doing everything manually - I thought it would be about time to ask.

    I've created a new FTP account in my cPanel and have attempted to update a plugin to the latest version but I get a message "Username/Password incorrect for username@mydomain.co.uk"

    I have the following settings:

    Server: http://ftp.mydomain.co.uk
    User: username@mydomain.co.uk
    Password: XXXXXX
    Connection Type: FTP (I've also tried FTPS)

    I just can't think what the problem could be? Any help would be very much appreciated.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Try these settings:

    Host: http://ftp.mydomain.co.uk
    Username: username
    Password: XXXXXX

  3. greencode
    Member
    Posted 5 years ago #

    Unfortunately, still the same error message?!

  4. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    You are using the user name that you signed into your c-panel (host) site and not your WP user name, correct?

  5. greencode
    Member
    Posted 5 years ago #

    Yes, correct. To be honest I've never been able to get this to work with any of the 3 different hosting companies I've ever used... I always just give up and go down the manual route but I'd like to go automatic!

  6. Saurus
    Member
    Posted 5 years ago #

    You username and password for your host account is rarely if ever the same as the FTP account username and password. Check your panels FTP account setup and verify what you should be using. The fact that you have not been able to use FTP on 3 different hosts indicates you are doing something wrong - this is not a difficult procedure. All else fails ... contact your host and ask them.

  7. isohelpline
    Member
    Posted 5 years ago #

    I also had problem of automatic update; it was giving permission related error.
    From my Plesk control panel I gave full permission to wordpress folder and subfolder for WP user.
    The automatic upgrade feature worked perfectly.
    You can use appropriate option in C-Panel
    Remember to reset the permission (for security reasons)
    I hope this helps.

  8. greencode
    Member
    Posted 5 years ago #

    Umm, I really don't know why this won't work. I've uploaded files and such like to my site hundreds of times in the past but this, supposed simple task, is causing me so many problems.

    I'm using exactly the same ftp details as what I use for my ftp client and I also decided to set up a new ftp user and that didn't work either?!

    I've been in touch with my webhosts and they have only told me exactly what I already know.

  9. greencode
    Member
    Posted 5 years ago #

    Umm, I must have been doing something wrong - or maybe when i copy and pasted the ftp details there was something incorrect with that because I've just gone through and managed to update everything!

  10. isohelpline
    Member
    Posted 5 years ago #

    some times when you copy by double click, it takes an extra character.

    I have faced this many times and hence avoid double click to select for copy paste sensitive data

  11. Ryan
    Member
    Posted 5 years ago #

    I just wanted to add that after banging my head against my desk for the last hour and reading about 20 other threads with no resolve, this thread made me reconsider my process as possibly being the problem and ... it was.

    For anyone else having this problem, be sure to physically type each line if FTP information. This is particularly relevant to the password field - as I imagine most of us are copying and pasting long nonsensical password strings provided by our hosts in e-mails.

    As soon as I typed it in letter-by-letter it worked beautifully.

    Thanks for the simple reminder guys!

  12. robballan
    Member
    Posted 4 years ago #

    Same problem here. This was a bear to figure out, since the log files are rather cryptic.

    I knew that my username and password were in fact correct, and that permissions were also correct on the appropriate directories. I confirmed that a command line ftp login worked. The forums on WordPress were filled with complaints with answers that all focused on these two issues, so I knew this wasn’t the path to the answer.

    I noticed that the command line ftp login process took a fair amount of time. So I began to suspect a timeout problem. But I couldn’t find a timeout setting for WordPress – at least until I came across wp-admin/includes/class-wp-filesystem-ftpext.php, which contains a variable var $timeout = 5 near the top of the file. Changing this to 20 eliminated the login problem.

Topic Closed

This topic has been closed to new replies.

About this Topic