WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Automatic Upgrade from 2.7 to 2.7.1 - You do not have sufficient permissions (5 posts)

  1. netbloke
    Member
    Posted 5 years ago #

    I have searched everywhere for a fix for this.

    I have a couple of 2.7 installs that I am trying to use the automatic upgrade for. I always get the message:

    "You do not have sufficient permissions to access this page."

    I have tried numerous things, such as deactivating all my plugins. No luck. I have no idea what to do!

    Any help would be appreciated.

  2. stvwlf
    Member
    Posted 5 years ago #

    Did you by any chance change $table_prefix in wp-config.php as part of the upgrade? If so there are SQL updates within the options table in the database that need to be made.

  3. kansir
    Member
    Posted 5 years ago #

    I get this error message :

    ******************************
    Downloading update from http://wordpress.org/wordpress-2.7.1.zip

    Unpacking the core update

    Verifying the unpacked files

    Installing the latest version

    Warning: copy(/home/kansirneta/domains/kansir.com/public_html/wordpress/wp-blog-header.php) [function.copy]: failed to open stream: Permission denied in /home/kansirneta/domains/kansir.com/public_html/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 122

    Warning: copy(/home/kansirneta/domains/kansir.com/public_html/wordpress/wp-blog-header.php) [function.copy]: failed to open stream: Permission denied in /home/kansirneta/domains/kansir.com/public_html/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 122

    Could not copy file: /home/kansirneta/domains/kansir.com/public_html/wordpress/wp-blog-header.php

    Installation Failed
    ******************************

    How to fix it ?

  4. netbloke
    Member
    Posted 5 years ago #

    No stvwlf I did not. If it helps I also cannot use the install new plugin feature either.

  5. MarkDalton
    Member
    Posted 5 years ago #

    Same issue here!

  6. netbloke
    Member
    Posted 5 years ago #

    I worked out out thanks to this post

    Here is the solution in a nutshell.

    I went to wp-admin/options.php

    Changed the db version to the last version I had installed (8204)

    It then forced a database upgrade and fixed the problem!

    Simple solution to a pain in the butt problem!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags