WordPress.org

Ready to get started?Download WordPress

Forums

Automatic Upgrade for 2.7.1 (8 posts)

  1. NativePages
    Member
    Posted 5 years ago #

    I keep getting the same error on the auto upgrade:

    Fatal error: Cannot redeclare pclziputilpathreduction() (previously declared in /home/XXXX/public_html/XXXX/wp-content/plugins/wordpress-automatic-upgrade/lib/pclzip.lib.php:5421) in /home/XXXX/public_html/XXXX/wp-admin/includes/class-pclzip.php on line 5498

    I'm not a developer. What do I need to do to fix this without having to do a manual install?

  2. freakmaster
    Member
    Posted 5 years ago #

    I, and it appears, many others are getting the same type of error message and even doing the following suggestion locked me out of my WP install altogether:

    Question: How do I upgrade automatically from WordPress 2.7 to the newer versions coming out (ie: 2.7.1)?

    Answer: Upgrades are built in starting with 2.7 and up. Tools->Upgrade.

    Make sure you Create the /wp-content/upgrade directory (it was not present), set permissions to 777, then update the permissions in wp-content/plugins to 777 as well. Finally, I emptied /wp-content/cache - and plugins are now updating successfully.

    Well, I tried all of that and every time I did I was unable to get back into WP so I changed the permissions back and things were normal again, although upgrading automatically seems an impossibility at this point.

    Why is this such a kludge? I long for an update to Keith's fabulous automatic update plug-in.

  3. whooami
    Member
    Posted 5 years ago #

    that error message is caused by the upgrade plugin still being there -- its not needed, and needs to be deleted.

  4. freakmaster
    Member
    Posted 5 years ago #

    Thanks whooami...that did the trick and the upgrade functioned properly. I suppose I should have thought of that but up until today I still thought that Keith Dsouza's plug-in was still functional in the 2.7 releases. So many people have that plug-in sitting there that the 'powers that be' may want to post a little note on the 'auto upgrade' reminding folks to deactivate that older plug-in.

    Again, thanks...

  5. whooami
    Member
    Posted 5 years ago #

    well its been stickied for 5 days now on this forum.

    http://wordpress.org/support/view/all-topics

    2nd thread.

  6. freakmaster
    Member
    Posted 5 years ago #

    That only attests to the fact that I check in here so seldom because WP tends to run so well. I'll have to make more visits in the future. Then I'm unlikely to miss the sticky notes, eh?

  7. msolution
    Member
    Posted 5 years ago #

    ooops!
    i did the automatic upgrade,.... and im missing my dashboard!!!
    theres nothing there!!!

    what to do!!

    M.
    PS: tell me how to undo this, so i can upgrade the old good manual way!

  8. msolution
    Member
    Posted 5 years ago #

    ummm... seems all well now .... sorry!

    (deleted the index.php file in the plugin dir)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.