WordPress.org

Ready to get started?Download WordPress

Forums

Automatic Upgrade fails - can't unzip (10 posts)

  1. waterhead37
    Member
    Posted 5 years ago #

    This only happens with WordPress.org files. Other plugin zips are OK.

    When I try to upgrade WordPress or Akismet automatically, I get a message that says the upgrade fails and I then have to do it manually. The message also notes this error:-

    Incompatible archive: PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

  2. MichaelH
    Member
    Posted 5 years ago #

    What version of WordPress?

  3. CharlesClarkson
    Member
    Posted 5 years ago #

    WordPress 2.7.0 Running on a windows server (2003 I think). Same error pops up for a plugin update. Can't remember which plugin.

  4. CharlesClarkson
    Member
    Posted 5 years ago #

    This works fine on a unix host with the same host company. I suspect a php setup problem.

  5. CharlesClarkson
    Member
    Posted 5 years ago #

    According to the PclZip web site:

    "
    Q2 : I can not open with WinZip a zip archive created by PclZip !

    WinZip 6.0 (and earlier) is not able to open zip archives created by PclZip. However last version of WinZip (v8.0) is working correctly with PclZip generated archives. Please note also that archives created by PclZip can be read by WinZip 6.0.
    "

    I'll check with my web host to see which version of WinZip they are using.

  6. CharlesClarkson
    Member
    Posted 5 years ago #

    WinZip is okay. It was a only a shot in the dark anyway.

  7. CharlesClarkson
    Member
    Posted 5 years ago #

    Moderator:

    Please close this thread. I moved the account to another host and the problem is resolved. I guess I'll never know why this didn't work.

  8. jolenemacinjax
    Member
    Posted 5 years ago #

    Incompatible archive PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

    I just upgraded to wordpress 2.8 and everything was find yesterday but today I cannot automatically upgrade any of the plug-ins from the admin panel??? I am on a unix server

  9. mkirkwag
    Member
    Posted 5 years ago #

    There is a thread about this in Plugins and Hacks - no one has posted a solution yet, but it's happening with every plug in I try and that seems to be the case for others.

  10. mkirkwag
    Member
    Posted 5 years ago #

    Found a fix in this thread http://wordpress.org/support/topic/278487?replies=26
    You need to load a new version of http.php to your wp-includes folder. It's a simple download from that post

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags