WordPress.org

Ready to get started?Download WordPress

Forums

Automatic Update to 3.4.2 Failing (13 posts)

  1. Gazoo432
    Member
    Posted 1 year ago #

    So call me lazy but I used the MS Web Platform Installer to install WP 3.4/PHP/MySQL and everything works fine except I can not get the automatic update to 3.4.2 to complete. I enter the information for my ftp/web server (I am running my own win 2k8 box) and then get a "could not copy files" error (entire error included below). If I watch the FTP process on the server I see a successful login followed by a STACK OVERFLOW error but no data flow commands (no copy/extract/etc...) and the stack overflow worries me. I have tried logging in as both a specific 'wpupdate' user and 'Administrator' so it should not be a permissions error. I am using IIS 7.5 w/ the FTP add-on in user isolation mode, any clues on what is going wrong or at least where to start tracking this down.

    **Begin Output**
    Downloading update from http://wordpress.org/wordpress-3.4.2-partial-0.zip…
    Unpacking the update…
    Could not copy files.
    Installation Failed
    **End Output**

    --Kevin

  2. Karun
    Member
    Posted 1 year ago #

    It seems that the permissions are creating the problem. May be you should go for manual update or check the permission of your folders.

  3. WPProHelp
    Member
    Posted 1 year ago #

    Go for a manual upgrade of WordPress. Follow the below procedure:

    1. Download the latest version of WordPress from here

    2. Make a backup of all your WordPress files and MySQL database

    3. Delete the directories wp-admin and wp-includes.

    4. Delete all files from the root of your website starting with "wp-" except the wp-config.php file.

    5. Extract the downloaded version of WordPress and upload all files and directories except the wp-content directory and the wp-config.php file.

    That should do the trick.

  4. ricardusexa
    Member
    Posted 1 year ago #

  5. Karun
    Member
    Posted 1 year ago #

    How to manually upgrade WordPress:

    1. Perform a complete backup of both your database and directory structure (in case something goes wrong)
    2. Login to your WordPress administration panel and deactivate all active plugins
    3. Download and extract the latest STABLE WordPresss version to a folder on your computer
    4. Upload the extracted files to your WordPress server directory with the exception of the following:
      • wp-content folder and it's content
      • wp-includes/languages if you are using a custom language file
    5. To perform the upgrade, navigate to http://yoursitename/wp-admin/upgrade.php and follow the on screen steps
    6. Login to the administration panel and reactivate your plugins one by one to ensure that they still work with the new version of WordPress
  6. Gazoo432
    Member
    Posted 1 year ago #

    Ok, so being a Windows Admin I had to figure out why it was not working so here ya go just in case there is someone out there that is lazy like me (though I can't be too lazy since I worked harder to fix the auto-update than it would have been to just manually update :\ )...

    It was user permissions after all...I had given both 'Administrator' and a specific FTP user I called 'wpupdate' full access to the entire wwwroot structure but it was still failing. Upon further researching resulting permissions I discovered that the group '<Domain>/Users' had read only access. I added write permissions to the '<Domain>/Users' group to wwwroot and all sub-directories and it worked like a charm. This is not my ideal security setup and I am going to have to play with it a little to see what the minimum permission set I can use will be and will post it here if I find a more secure setting. As another semi-related question, who maintains the Web Platform Installer since it appears that it is setting incorrect permissions?

  7. WPProHelp
    Member
    Posted 1 year ago #

    I do not think it is an issue with the WordPress update services. Keep in mind that when doing an update via the dashboard the account under which the Web Services running is used to copy the files and not the FTP users.

    So you have to give permissions to this particular user and not the FTP user. It seems that the user is part of the domain/users. Are you running IIS?

  8. skybig
    Member
    Posted 1 year ago #

    maybe you don't have priviledege to write to that directory

  9. nigel.coombs@britishresidents.ch
    Member
    Posted 1 year ago #

    Thanks for the info - I have now managed a manual update. However I am still worried that I have an access problem. Recently I was unable to use phpMyadmin because the access restrictions were too permissive! I had to contact my host's people to find out which file it was, and they must have changed some accesses.
    Can anyone tell me exactly which folders and files the automatic update needs to access.

  10. nigel.coombs@britishresidents.ch
    Member
    Posted 1 year ago #

    I did look in the documentation but failed to find this info.

  11. ktsang
    Member
    Posted 1 year ago #

    assign the "write" permission to iis_users to the wordpress folder
    after updated, recommend to remove the permission

  12. Pattern Storm Designs
    Member
    Posted 11 months ago #

    Hello,

    Please can you help. I have selected automatic update in my wordpress panel, as it requested that I need to update wordpress. Then the instillation failed. =( When I wanted to go back to the dashboard I just got this message:

    Parse error: syntax error, unexpected $end in /home/patterns/public_html/wp-admin/includes/media.php on line 2437

    My website still seems to be fine? But now I can't access my wordpress dashboard at all! =( What do I need to do??

    Anyone's help is highly appreciated!

    Thanks

  13. WPyogi
    Volunteer Moderator
    Posted 11 months ago #

    @Pattern Storm Designs - please start your own thread - this one is long over and references updating 3.4.2. You can do so here:

    http://wordpress.org/support/forum/how-to-and-troubleshooting#postform

    Also see the standard troubleshooting steps here:

    http://wordpress.org/support/topic/troubleshooting-wordpress-36-master-list?replies=5

Topic Closed

This topic has been closed to new replies.

About this Topic