WordPress.org

Ready to get started?Download WordPress

Forums

Automatic Plugin Upgrade Not Working... It Used to! (7 posts)

  1. justinhartman
    Member
    Posted 6 years ago #

    Hi Guys

    I upgraded from WP 2.3.3 to 2.5 and tested the plugin automatic upgrade. The first one I tried was the Google XML Sitemap plugin and it upgraded perfectly.

    However, trying to upgrade the other outdated plugins no longer work. I enter the same FTP connection information as I did with the Google Sitemap plugin but every single time I just get an error saying

    Error: There was an error connecting to the server, Please verify the settings are correct.

    I can't figure out why it worked the first time and now not again... I've tried different settings to make sure I'm not losing my mind but alas nothing is working.

    Any ideas?

  2. apoorvkhatreja
    Member
    Posted 5 years ago #

    Same error here. It doesnt work.

  3. AndiC
    Member
    Posted 5 years ago #

    Seems to work with 2.5.1. However, I am finding a lot of other issues with this distribution.

    Andrew Crook

  4. needle189
    Member
    Posted 5 years ago #

    I haven't been able to upgrade from 2.5 to 2.5.1 it gets stuck in maintainence mode .Tried to contact the authors but no reply ..

  5. justinhartman
    Member
    Posted 5 years ago #

    Hi Guys - I figured out the issue from my side and on my server this all relates to permissions and users.

    1. I changed /wp-content/ (and all directories below that) to have full write permissions (i.e. 0777).

    2. I changed my owner and group permissions for the /plugins/ and /upgrade/ folders to the same as my apache owner and group. In my case my apache user is www-data and the group is also www-data.

    Once I changed these two things my upgrade functionality worked perfectly.

  6. CarltonBale
    Member
    Posted 5 years ago #

    See this bug report if you tried using FTP over SSL. You can't disable this setting once you try it.

    http://trac.wordpress.org/ticket/6986

    Basically, you add this line to your wp-config.php to get around it:
    define('FTP_SSL', false);

  7. justinhartman
    Member
    Posted 5 years ago #

    broken again in 2.5.1 and this time permissions and ownerships don't make a difference.... :(

Topic Closed

This topic has been closed to new replies.

About this Topic