WordPress.org

Ready to get started?Download WordPress

Forums

Automatic plugin upgrade not working - ftp problems (47 posts)

  1. cjessing
    Member
    Posted 6 years ago #

    No matter what I try I simply cannot get the new automatic plugin upgrade to work. I keep getting this error after specifying ftp info:

    Error: There was an error connecting to the server, Please verify the settings are correct.

    The ftp account I specify takes me to the root of my WP installation and works perfectly with an ftp client like FileZilla...

    Can anyone help?

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    The information you're giving it is incorrect in some way. That info may work for you to connect to the server, but maybe not for it to connect to itself. Especially if the server doesn't have DNS setup and working properly (surprisingly not uncommon).

    The short of it is that the automatic update stuff does not work on all systems and never will. WordPress cannot take every single server configuration into account.

  3. BigGauc
    Member
    Posted 6 years ago #

    My server DNS working properly. Buy I have same problem like cjessing and same error. Can you help me please?
    How to correctly setup hostname when my blog is on subdomain. Is this example correct: http://ftp.domain.com/subdomain/
    The subdomain is root for WP.

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    No, you don't have to tell it the subdirectory, just the hostname. It will look for the right subdirectory.

  5. BigGauc
    Member
    Posted 6 years ago #

    OK, I made special FTP account for subdirectory where WP is located. Bud answer from WP is "Unable to locate WordPress directory."
    What now?

    Thanx

  6. macgreiner
    Member
    Posted 6 years ago #

    Same for me. Works fine using a dedicated ftp program but I get the same error:
    Error: There was an error connecting to the server, Please verify the settings are correct.

  7. Covi
    Member
    Posted 6 years ago #

    BigGauc, don't use any rute on your new FTP account.

    Hope it works. Regards.

  8. araphel
    Member
    Posted 6 years ago #

    either your ftp, username or password is incorrect. Try manually typing it in instead of pasting. You may have an extra space in there or something.

  9. bcs_admin
    Member
    Posted 6 years ago #

    I found that I needed to use my server name as the ftp host, not the normal ftp host name I use with an external ftp program.
    Example: Normally I use an ftp program to connect to myhost.com, but because the plugin is operating from within the server I need to use the name of the server (i.e. "testbox") as the ftp host.

    I'm not quite good enough with setting up the server to understand exactly why it works. Perhaps I've done something that isn't considered "correct", but at least I figured out how to make the plugin work! ;-)

  10. CarltonBale
    Member
    Posted 6 years ago #

    If you tried FTP over SSL and it didn't work, that may be your problem. That feature will not deactivate even if you set it to "No" in the ftp config page. See this bug report:
    http://trac.wordpress.org/ticket/6986

  11. Joni
    Member
    Posted 6 years ago #

    I'm going to resurrect this thread. I've got a gazillion WP 2.5.1 installs scattered all over the internet. I haven't run into this problem until now. This is for a WP site that I host myself, a *.org, if that matters.

    None of the other sites on this server experience this problem, not even the other dot-org site. I went in and checked its settings and it's what I normally put into those fields:

    1. the server name
    2. the user id (which is the hosting account user id)
    2. the FTP/hosting account password
    3. Use SSL? No

    I then decided to set up an FTP account just for that purpose. Checked the settings. Tried again. No dice.

    Why would this one site, on the same server as all the other properly functioning WP sites, NOT work? It's giving that pink box error,

    Error: There was an error connecting to the server, Please verify the settings are correct.

  12. Joni
    Member
    Posted 6 years ago #

    Okay, here's more. After sitting there grinding away for like five minutes, I get this:

    Downloading update from http://downloads.wordpress.org/plugin/cforms.8.5.zip

    Unpacking the update

    Removing the old version of the plugin

    And then it spits out one of these for each file it's trying to process. Do you think it could be an issue with the upgrade to this plugin specifically??

    Warning: ftp_pwd() [function.ftp-pwd]: Deleted /public_html/wp-content/plugins/cforms//images/fade-butt-lightblue.png in /home/gnoics/public_html/wp-admin/includes/class-wp-filesystem-ftpext.php on line 188

    Because I see something that doesn't look right:
    .../plugins/cforms//images/...

  13. cjessing
    Member
    Posted 6 years ago #

    I'm still struggling... I tried following the advice from the bug report posted by CarltonBale and now I get:

    Downloading update from http://downloads.wordpress.org/plugin/akismet.zip

    Unpacking the update

    Warning: ftp_pwd() [function.ftp-pwd]: Opening BINARY mode data connection for /wp-content/upgrade/akismet/akismet/akismet.gif in /mounted-storage/home66a/sub001/sc35101-WCQM/[mysite]/wp-admin/includes/class-wp-filesystem-ftpext.php on line 188

    Could not copy file

    Then when I examine the upgrade dir I can see that the unpacked dirs are created with 755 and the files (it actually only tried to unpack akismet.gif) are 0 (zero) bytes. I have spoken with the nice people at Servage.net but they are out of ideas...

  14. ubergiant
    Member
    Posted 6 years ago #

    I'm trying to automatically upgrade sociable and get a similar error to others in this thread. Mine says:
    Warning: ftp_pwd() [function.ftp-pwd]: Deleted /public_html/.../wp-content/upgrade/sociable/sociable/images/n4g.gif in /home/.../public_html/.../wp-admin/includes/class-wp-filesystem-ftpext.php on line 122

    This has happened to other sociable versions and other wordpress blogs on the same server. I don't know whether it could be my new server though, because I did just move servers.

    If anyone has solved the problem, post it here please.

  15. norsted
    Member
    Posted 5 years ago #

    I've been struggling with this for a while, and i've pretty much given up finding a solution - i have the same problem:

    Warning: ftp_pwd() [function.ftp-pwd]: Transfer complete in /mounted-storage/home51b/xxxx/sc35444-DFZH/xxxxx/wp-admin/includes/class-wp-filesystem-ftpext.php on line 122
    
    Warning: ftp_pwd() [function.ftp-pwd]: CWD command successful in /mounted-storage/home51b/xxxxx/sc35444-DFZH/xxxxx/wp-admin/includes/class-wp-filesystem-ftpext.php on line 122
    
    Unable to locate WordPress Plugin directory.
    
    Installation Failed

    I'm starting to think it's related to the host (servage.net) because i have another blog running on another server - which can be upgraded effortless!

    In short..HELP!

  16. johncolumbo
    Member
    Posted 5 years ago #

    For anyone that may still be having this problem entering "localhost" into the ftp host box worked perfectly for me.

  17. Colleen78
    Member
    Posted 5 years ago #

    Hi everyone, I was just having trouble too, but putting the server IP for the hostname solved the problem.

  18. matjes
    Member
    Posted 5 years ago #

    I have my WordPress at Servage.net and found out today that for me Firefox is the problem. When using Safari I have no problems with WPAU at all.

  19. Mitchell Allen
    Member
    Posted 5 years ago #

    Thanks to johncolumbo's comment, I was able to log in with localhost.
    (I was also using the wrong password, so I'll never know if the "normal" ftp host name would have worked, since I changed both fields at once.)

    Cheers,

    Mitch

  20. chiahau
    Member
    Posted 5 years ago #

    Yup I agree with johncolumbo, anyone that may still be having this problem entering "localhost" into the ftp host box.

    Anyway that is how I corrected the problem at my site.

  21. CristianRa
    Member
    Posted 5 years ago #

    I had the same problem here and I've got to agree with chiahau, at least that's how I also corrected the problem over at my site.

    Just my 0.02.

    Cheers,
    Christian.

  22. ahpatel
    Member
    Posted 5 years ago #

    Here's a summary of the suggestions thus far:

    1. Use server name as the ftp host
    2. Use localhost
    3. Use the IP Address
    4. Use a different browser

    None of these worked for me (I'm using 000webhost for hosting my blog).

    Anyone have other suggestions!?

  23. dashnc
    Member
    Posted 5 years ago #

    I solved it!
    A friend of mine hadn't this issue at the same hoster. So we compared our settings and find a difference: He uses PHP5, I used PHP4.

    I changed it to PHP5 - et voilá ... no error.

    Change your PHP to version 5! (works for me...)

    Thanks for your help guys, anyway ;)

    http://wordpress.org/support/topic/225836?replies=8#post-927682

  24. radvanyi
    Member
    Posted 5 years ago #

    Hi All,

    I tried all the suggestions:

    • Use server name as the ftp host
    • Use localhost
    • Use the IP Address
    • Use a different browser

    and I'm still not able to delete or install plugins. "Unable to locate WordPress Plugin directory."

    Do you have any other idea?

    I'm afraid the WP auto upgrade might result similar issue when it's time to upgrade WP from 2.7.

  25. Saurus
    Member
    Posted 5 years ago #

    Ya know - instead of all this BSing around ... why the hell don't you people just forget the plugin and upload your stuff manually with FTP! You're using FTP anyway - so just do it right and move on.

  26. radvanyi
    Member
    Posted 5 years ago #

    You are right, I can manage the plugins and even a whole WP upgrade manually. It's just much easier with the built in automated functionality.

  27. aadel
    Member
    Posted 5 years ago #

    Surprisingly, using "localhost:21" as a Hostname worked for me. I had to define the port because when I didn't, it was giving me the error:

    Error: There was an error connecting to the server, Please verify the settings are correct.

  28. radvanyi
    Member
    Posted 5 years ago #

    Unfortunately even with the "localhost:21" I get the error message: "Plugin could not be deleted due to an error: Unable to locate WordPress Plugin directory."

    The only difference between my erroneous WP instance and an other one where this features works is that the problematic one is installed into a /blog/ directory. This might be the reason why WP is not able to find the proper plugin directory.

    Do you have any suggestions?

  29. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Try manually defining the correct constants for your FTP:
    http://codex.wordpress.org/Editing_wp-config.php#FTP_Constants

  30. radvanyi
    Member
    Posted 5 years ago #

    Otto,

    Thanks a lot for your reply. Unfortunately it did not work for me.

    I think I know what my absolute path and I even tried with the ABSPATH constant value.

    Any more ideas?

    Could you confirm that the WP auto upgrade is not working the same way as the plugin updater?

    Best regards,
    Tibor

Topic Closed

This topic has been closed to new replies.

About this Topic