WordPress.org

Ready to get started?Download WordPress

Forums

Automatic Plugin Update - please allow more FTP info (9 posts)

  1. erick_paper
    Member
    Posted 5 years ago #

    The automatic plugin update does not work because it only takes basic FTP info. My server disallows the usual port 21 for ftp, allowing only port 22 for sftp. In fact the port number is different too, for security. Please allow us to enter this information so that the plugin update mechanism works! Thanks.

  2. SteveSmith1983
    Member
    Posted 5 years ago #

    I'll add my vote to SFTP too, please! I use an updater plugin at the minute, because I don't want to use FTP

  3. dannychang
    Member
    Posted 5 years ago #

    I don't have FTP account for server in my graduate school.

    School only use SFTP, so please make it an option.

    Thanks

  4. jamesjm
    Member
    Posted 5 years ago #

    +1 Vote for SFTP (and non-default port!)

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Having extra information would not help, because there's no support there for SFTP. SFTP is more than just FTP on a different port.

    As for port numbers, it already has that. Use example.com:21 or similar to specify the port number.

  6. jamesjm
    Member
    Posted 5 years ago #

    @Otto42 Ah of course, it's not very clear you could input portnumbers in that manner in WP too.

    And apparently SFTP support hinges on PHP's SHH2 module being installed (see Trac ticket 5994). It'd be nice if that was made clear too :)

  7. DanDawson
    Member
    Posted 5 years ago #

    +1 for SFTP support, I can't use any of the "automatic upgrade" or "automatic installation" options either. Sure would be nice!

  8. kimmybakeo
    Member
    Posted 5 years ago #

    I also would like to add my vote for adding SFTP support. It makes life a lot easier to be able to update plugins automatically and not have the notification always appearing in the left column.

    Thanks!

  9. booyaa
    Member
    Posted 5 years ago #

    its been enabled, but has some pre-reqs like ssh support for php (via pecl) check this howto http://devioustree.co.uk/2009/02/21/auto-update-wordpress-with-sftp/

Topic Closed

This topic has been closed to new replies.

About this Topic