WordPress.org

Ready to get started?Download WordPress

Forums

Postie
[resolved] Automatic mail retrieval not working (6 posts)

  1. goodimp
    Member
    Posted 6 months ago #

    Hello

    I'm running v1.5.16 of Postie and it's setup and working perfectly when I click the run script button in the settings but I cannot get it to retrieve the posts automatically.

    I've checked the event schedule with WP Crontrol and it runs with no errors

    I've setup a schedule with SetCronJob. That also runs with no errors

    I've also setup a cron schedule on the linux server (heart internet). This too runs with no errors yet the emails don't load in the blog.

    Any thoughts?

    http://wordpress.org/plugins/postie/

  2. Wayne Allen
    Member
    Plugin Author

    Posted 6 months ago #

    That is very strange. Have you tried accessing the URL you set up for the cron job directly (i.e. through a browser?)

    You might also try disabling all your other plugin temporarily to see if something is getting in the way.

  3. goodimp
    Member
    Posted 6 months ago #

    Thanks for the quick responce.

    Yes, using the URL works fine. It returns a short log like the Postie Configuration Test but rather than saying their is 1 email waiting it says 'Mail fetch complete, 1 emails'

    I'll try disabling the plugins.

  4. goodimp
    Member
    Posted 6 months ago #

    Disabling all plugins other than Postie hasn't worked.

    It looks as though it's trying to do it as when I refresh the blog page ?doing_wp_cron=1380881344.0438389778137207031250 appears in the address after the domain/page.

  5. Wayne Allen
    Member
    Plugin Author

    Posted 6 months ago #

    Since using the URL works we know that the problem must be somewhere else.

    Some hosts don't allow PHP to access localhost which is what WP Cron does in order to work. Bluehost specifically has this issue.

    What is the exact command in your cron?

    Also please post the results of the Postie test.

  6. goodimp
    Member
    Posted 6 months ago #

    I found out my ISP only allows scheduled tasks to run every hour and I had it reduced to 10 minutes while testing. I also changed to a php script to run the cron and it's loading automatically just fine now.

    If anyone else is having issues with wget this is the php alternative I used (make sure you include the space).

    /usr/bin/php5 /home/sites/yourdomain.co.uk/public_html/wp-content/plugins/postie/get_mail.php

    Thanks again.

Reply

You must log in to post.

About this Plugin

About this Topic