WordPress.org

Ready to get started?Download WordPress

Forums

Automatic image url linking and size proposal in 2.9 (19 posts)

  1. lujk
    Member
    Posted 4 years ago #

    Does anyone know, if the feature of automatically linking to the image source (link url) can be turned off somewhere?

    During the upload od image files, I don't want them to automatically link, and since I need to upload dozens of images, it absolutely pisses me off, when I need to click one additional button every time, to explicitely tell wordpress NOT to link to the source file as URL.

    Then I found out, that based on the pixel size of the image, wordpress automatically choses the option of ANOTHER SIZE (scaled) so I explicitely have to click back to "Original" which means another click.

    I have in fact, 2 more steps with WordPress 2.9, doing a routine job.

    Does anyone know, how to eliminate them?

  2. workingroup
    Member
    Posted 4 years ago #

    I have a similar issue.

    When I upload it puts the source of the image file on my server as the automatic link.

    But if I remove it and want to put a url to an offsite source, say the source where I copied the image from, when I press update the file, WP returns the original automatic link and erases my edit of the off site url...

    This worked fine in 2.8.6...why an update has to move us backwards, I don't understand...

  3. lionc
    Member
    Posted 4 years ago #

    auto linking is gone after i go to Settings->Media and click Save Change
    you can try

  4. lujk
    Member
    Posted 4 years ago #

    sorry, this didn't work in my case :(

  5. jonnymoon
    Member
    Posted 4 years ago #

    @lionc: Your solution worked perfectly, thanks!

    I've been struggling with this image problem since the release of 2.9, and I'm surprised that not too many people have said anything. I'm dealing with a WordPress site where a majority of the 10+ authors use the WYSIWYG editor--and never touch the HTML--so it became more and more frustrating to correct every single image posted.

  6. StalkerB
    Member
    Posted 4 years ago #

    Worked for me too!

  7. here
    Member
    Posted 4 years ago #

    This has not worked for me. Are there any changes made in the Media -> Settings window , or just "Save Changes" without changing anything?

    Here are some related trac links, though I can't find the referenced functions in media.php in 2.9.1:
    function image_link_input_fields($post, $url_type = '') {

    http://core.trac.wordpress.org/ticket/11148
    http://core.trac.wordpress.org/changeset/12188

  8. Mike S.
    Member
    Posted 4 years ago #

    Still no luck. All goes wrong whenever I click update. It was working fine earlier today because some of the posts I updated earlier are fine, but others have erased my new image URLs. I don't get it.

  9. niddler.wordpress
    Member
    Posted 4 years ago #

    Having the same problem here - running WP2.9.1, can't get the link URL to work.

    I don't know if it makes a difference, but I'm trying to apply it to the post-thumbnail - introduced in WP2.9 - not to an image inserted into the post.

  10. esmi
    Forum Moderator
    Posted 4 years ago #

    Sorry? What are you trying to do with the post_thumbnail?

  11. darthead
    Member
    Posted 4 years ago #

    I'm having the same problem.

    'Add Media' -> 'Gallery' -> *media_item* -> 'Link URL' -> 'Save all changes'
    - always defaults to either the file or post URL; I cannot save a custom URL in this field when trying to use the WP gallery feature to link my gallery thumbnails to external pages.

    I have updated wp-admin/includes/media.php to the latest trac version but no luck. Anybody have an idea as to what's happening?

  12. webgrafia
    Member
    Posted 4 years ago #

    The solution proposed didn't worked for me... any ideas??

  13. Michael Eisenwasser
    Member
    Posted 4 years ago #

    I have had the same problem on 2 blogs using WP 2.9. I fixed it by going into Settings > Media and unchecking "Attempt to automatically embed all plain text URLs". For whatever reason this worked. Seems like a bug to me.

  14. broofa
    Member
    Posted 4 years ago #

    I've filed a bug about this issue here:

    http://core.trac.wordpress.org/ticket/12315

    The workaround (until this fixed) is to go into the HTML source, and remove the 'rel="attachment ..."' attribute that you'll find on the link tag.

  15. Arlo
    Member
    Posted 4 years ago #

    Broofa- Unfortunately that workaround only works on images placed in posts. It doesn't fix the issue of the link URL changing within the media library itself.

  16. grandp
    Member
    Posted 4 years ago #

    This is a problem for me to i want to use the new gallery function but i can not change the url as then revert right back no matter what i do.

    This is a big mess now as i have been doing this for every post and now it is not working.

  17. Arlo
    Member
    Posted 4 years ago #

    grandp -
    This is my exact issue too; with the gallery, you can't edit those links.

  18. bigmoose
    Member
    Posted 4 years ago #

    I've got the same issues

    Client site going live in a few hours and I need to remove all the Link Rel information, and for some reason the images are opening in a new window too, the checkbox in Advanced Settings has been checked

  19. circuitor
    Member
    Posted 4 years ago #

    We've got the exact same issue on 2 separate WordPress installations.
    This bug is reported in this thread as well, but as Arlo notes, there is no workaround when it is affecting the gallery because the HTML cannot be edited.

    No solution found yet.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags