WordPress.org

Ready to get started?Download WordPress

Forums

*AUTOMATED* Comment Spam?! (8 posts)

  1. Anonymous
    Unregistered
    Posted 9 years ago #

    This is really strange... I have a small WordPress blog that I recently added to my website. I don't think anyone but me has seen it, it hasn't even hit Google yet, but I'm getting a comment spam for a site called http://www.free-casino-games-000.com/ with a random quote every time I post an article! Literally... as soon as I post and the post shows up, there it is, automatically.
    The weirdness continues when you realize that not only is my blog practically invisible, but comments are also turned off and I have the word "casino" filtered out in the comment spam filter. I'm not using any third-party plugins or anything... at one point I had one of the bundled ones installed but I disabled it. Even then the automatic spam kept coming.
    This is really weird... can anyone shine some light on why this is happening? TIA.

  2. Would you please care to search before posting. Here's a summary of what you have found. The spammers found you because Update Services are automatically enabled. If you want more info, search for "Update Services and Spam". For anti-spam techniques, see: http://www.tamba2.org.uk/wordpress/spam/

  3. Anonymous
    Unregistered
    Posted 9 years ago #

    Thank you for the link!
    I attempted to Google for a solution but couldn't find one.

  4. Brak
    Member
    Posted 9 years ago #

    The issue is comments are already in the database, assigned to future posts. When a post with the future id is posted... the comment appears. There's a whole section in the codex on it, and it basically entails going into the database and deleting all of the offending comments.

  5. Beel
    Member
    Posted 9 years ago #

    Actually if you perform a search on spam and update services it will get results if you hit the google link, which usually returns more relevant posts anyhoo: http://www.google.com/search?q=site%3Awordpress.org%20update+services+spam
    Always google if the wp search function doesn't provide an answer.

  6. Anonymous
    Unregistered
    Posted 9 years ago #

    I did Google, but it found me several solutions that didn't work, most of them being "disable update services." Apparently that's where the comment spammers find links to blogs.
    But it seems that it doesn't matter if you turn them off if the spammer found your blog once. As Brak pointed out, the problem seems to be in that comments can be assigned for future posts and will sit in the database until said post is posted.
    Clearing the comments in my blog's SQL database solved the problem.

  7. Me, I proved a link in my second post. If you would have followed it, you would have found:
    TG's Code: http://www.tamba2.org.uk/wordpress/spam/#seven
    "It may happen that as soon as you make a post, there is a spam comment. The spammers have inserted a comment with a post ID that did not exist at the time they did it, but your post matches the ID, so the spam instantly shows up. TechGnome has produced this code which will stop that happening in the future.
    You will need to edit the file wp-comments-post.php"
    And this: http://www.tamba2.org.uk/wordpress/spam/#imm
    Illustrated instructions for deleting the existing auto-spam.

  8. Anonymous
    Unregistered
    Posted 9 years ago #

    Yep, that's the link I did follow to find out where the comments are in the MySQL DB. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.