WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Autoblog posts not triggering subscribe2 email (2 posts)

  1. waitek
    Member
    Posted 1 year ago #

    We're hoping to use autoblog and subscribe2 together. Currently subscribe2 sends out emails fine when we post content directly/manually to a blog, but when content is posted by autoblog to the same category, no emails are being sent out. I have confirmed that no emails are being received at server level (mail queue). Wondering if anyone knows whether the autoblog plug-in is posting in a way that may be bypassing a subscribe2 hook?

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @waitek,

    From what you describe above Autoblog is almost certainly not firing the code WordPress hooks needed by Subscribe2.

    Subscribe2 uses post transition hooks so that any post the is moved from any status (like draft, pending, new etc) to the published status the code is fired.

    I cannot view the Autoblog source code as it is a purchased plugin but I suspect, looking at the screen shots at WPMUDev for it, that it inserted the new content as published immediately and does not call any transition hooks.

    It would be easy enough to add a line into the source code that did this but you'd nee to raise that with the WPMUDev team.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic