WordPress.org

Ready to get started?Download WordPress

Forums

Auto-upgrade of plugins and wp, (11 posts)

  1. arminv
    Member
    Posted 5 years ago #

    I get this same error every time I try to automatically install something through wordpress. I'm not sure if it's directly related to 2.7 or not...

    Fatal error: Cannot unset string offsets in /home/..../blog/wp-admin/includes/file.php on line 682

    Appreciate any help.

  2. arminv
    Member
    Posted 5 years ago #

    Figured out the answer...

    I guess it didn't like the login credentials that I had supplied in the past.
    I manually cleared the credentials from the wp-options table and it prompted me to give them again.

    It didn't work using my domain name as the FTP server, but was okay with using localhost as the FTP server.

    Hopefully this will help someone else in the future...

  3. koorb
    Member
    Posted 5 years ago #

    Spot on perfect, thank you. You just saved me a lot of time :D

  4. nyfael
    Member
    Posted 5 years ago #

    Awesome! Worked for me as well.

    In case anyone is wondering, the "option_name" in the wp_options table to clear is "ftp_credentials"

    Thanks again!

  5. Anna99
    Member
    Posted 5 years ago #

    okay i found the ftp_credentials in the wp_options, and see a long string of words. what do i do? please help!

  6. blogjunkie
    Member
    Posted 5 years ago #

    hi, this didn't work for me. i deleted the options table. a friend says that PHP is being too uptight. any suggestions? thanks

  7. Anna99
    Member
    Posted 5 years ago #

    @ blogjunkie - u deleted the entire options table?

  8. blogjunkie
    Member
    Posted 5 years ago #

    no, not the entire table. i meant i deleted the ftp_credentials row in the options table.

  9. truetrev
    Member
    Posted 5 years ago #

    I don't have an FTP_Credentials in my _options table that's probably why mine isnt working how do I fix this?

  10. Naveeddil
    Member
    Posted 5 years ago #

    @ Dear Anna99

    Just Click Edit infront of it and your there will be a line called option_value have a long text
    just delete it and it will work

  11. David Radovanovic
    Member
    Posted 4 years ago #

    This is amazing. I knew it was an internal ftp issue though I never got any errors just a empty page. I downloaded http://gaarai.com/wordpress-plugins/wp-developer-assistant/ and it spit out the error that pointed me here. Thanks!!

Topic Closed

This topic has been closed to new replies.

About this Topic