WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Auto Upgrade Fix for 1and1 users (35 posts)

  1. laurenceo
    Member
    Posted 5 years ago #

    If you are a 1and1.com user and are having problems getting the auto upgrade to work (for both the core and plugins), here's the fix.

    Add the following line to your .htaccess file (in the root directory of your WP install):

    AddType x-mapp-php5 .php

    References:

  2. leadiv
    Member
    Posted 4 years ago #

    Thanks for the info. It worked perfectly for me!

  3. pompo
    Member
    Posted 4 years ago #

    where should I add that anywhere in particular (top, bottom?)

    Thanks I 'm having probs upgarding on 1 and 1 too!

  4. pompo
    Member
    Posted 4 years ago #

    it worked woooot tytytyty:)

  5. zride17
    Member
    Posted 4 years ago #

    Why on earth can't I find the .htaccess file? I feel like I've looked everywhere!

  6. pompo
    Member
    Posted 4 years ago #

    can't you find it where? If you drag it from the server to the desktop and you are on a Mac you won't see it because the "." before the htaccess name makes it invisible.

    What I do is delete the dot while the file is on the server, drag to desktop so I can see it, I modify it, delete the previous on the server and upload the new one and add the dot in front of htaccess file again and that's it.

    So if you are on a mac thats why you don't see it on the desktop or anywhere once downloaded. If you are on Windows sorry I have no idea.

  7. zride17
    Member
    Posted 4 years ago #

    Thanks! I am on a Mac actually. I am using Filezilla, and I can't find it on the server either. Maybe that's the reason for some of my other problems on WordPress. How do you access the file from your server?

  8. pompo
    Member
    Posted 4 years ago #

    you should see it on the server where the wp files are

  9. pompo
    Member
    Posted 4 years ago #

    I use fetch to get on my server...there is a free demo I think:

    http://fetchsoftworks.com/

  10. zride17
    Member
    Posted 4 years ago #

    I just created a new file, but I'm not sure what needs to be in it. Do you edit yours in some sort of text editor?

  11. pompo
    Member
    Posted 4 years ago #

    I thinkwordpress should create itw own when you install it..not sure.
    Yeah I edit with a text editor

  12. zride17
    Member
    Posted 4 years ago #

    Thanks man. I'm looking around to find out the best way to make this happen. I appreciate your help on this. You are cool.

  13. whizzybizzy
    Member
    Posted 4 years ago #

    Simple thread subject. Thankyou.

  14. swthomas55
    Member
    Posted 4 years ago #

    Yes, thank you! I was baffled.

  15. swsamurai
    Member
    Posted 4 years ago #

    Does this address those of us who do not see the option to Auto upgrade our 2.7.1?

    I have seen a few questions regarding this but no answers. I have 2.7.1, but there is no option for auto upgrade, yet up to 2.7.1 I have seen the option and used it each time.

    Thanks for any input and I am sorry if this is considered to be the wrong place for this question.

  16. bonjove
    Member
    Posted 4 years ago #

    WHere exactly do I add the code?

    This is how my .htaccess file looks like.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ./index .php [L]
    </IfModule>
    
    # END WordPress
  17. bonjove
    Member
    Posted 4 years ago #

    I tried to put it like this,

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ./index .php [L]
    </IfModule>
    
    AddType x-mapp-php5 .php
    
    # END WordPress

    but then my website turns out blank. Showing nothing.

  18. tdempsey
    Member
    Posted 4 years ago #

    Excellent - this has been giving me grief for months. The fix works!!!

  19. pompo
    Member
    Posted 4 years ago #

    same chit from 2.8.2 to 2.8.3 I re edited the .htaccess file and the upgrade automatically worked!

  20. pompo
    Member
    Posted 4 years ago #

    @bonjove

    dunno what's wrong...sorry I did it eaxctly like your file there and it worked for me..do you have the DOT in front of HTACCESS file name?

  21. ciaoalexisb
    Member
    Posted 4 years ago #

    It worked for me. Thanks a lot!

    Alex

  22. oliverregelmann
    Member
    Posted 4 years ago #

    Thank you, worked for me too with 2.8.4.

    How stupid is that? The requirements say PHP 4.3 is necessary so it should work with 4.4.9 what 1and1 uses.

  23. hmcnally
    Member
    Posted 4 years ago #

    NICE.

  24. likoma
    Member
    Posted 4 years ago #

    Thank you so much for posting! 1und1 / 1and1 is a nightmare.

  25. andrenext
    Member
    Posted 4 years ago #

    unfortunately my problem persist.
    trying to upgrade from 2.6.2 to 2.8.4

    i'm using awardspace.com

    I still can see the normal site but, when I try to login, i receive the following message:

    [pixnix.awardspace.com] [Thu Sep 10 17:51:00 2009] [error] [client 189.82.176.81] Premature end of script headers: index.php, referer: http://pixnix.awardspace.com/wp-login.php
    Error 500: Script Execution Failure

  26. RunicMourning
    Member
    Posted 4 years ago #

    Ya know, I had this problem, but I thought it was my server. :P I did everything I could to get it to work. I am such a moron. I used to have this in an .htaccess in the root of my hosting. But it broke some software I used so I removed it... I just realized, upgrading of WordPress broke at about the same time as I removed it.

  27. loomis1010
    Member
    Posted 4 years ago #

    The .htaccess file is an 'invisible' file. Using an FTP program such as Transmit, you can go to the View > Show Invisible Files option, then open the file with a text editor.

    Also, place the new line of code just before the </IfModule> line.

    Thanks to everyone that worked on this fix - it's been a pain for months, and now it works perfectly!

  28. greasetender
    Member
    Posted 4 years ago #

    Although this thread is [resolved], I still want to add my 2 cents.

    Did not see this thread until AFTER struggling to auto install upgrade, then struggling with manually installing upgrade, which was truly a struggle since I have a fair amount of customization in place. The end of the sad story is that somewhere in the process of replacing files I received an error message from 1and1 (web host) and all my directories disappeared... Now I am waiting to see if they will be able to retrieve basically my entire web space. Other sites unassociated with WordPress are just up and gone.

    This is quite discouraging. Is it really worth all this, for a few measly blogs?

    "They've just been waiting in a mountain for the right moment... to take over."

    - Bjork, "The Modern Things"

  29. greasetender
    Member
    Posted 4 years ago #

    I'm back in business--thanks to this valuable piece of code. Thank you!

    "They've just been waiting in a mountain for the right moment... to take over."

    - Bjork, "The Modern Things"

  30. Chris
    Member
    Posted 4 years ago #

    this worked perfectly - THANK YOU!!!

Topic Closed

This topic has been closed to new replies.

About this Topic