WordPress.org

Ready to get started?Download WordPress

Forums

Auto upgrade 2.8.2 to 2.8.3 "Installation Failed" (43 posts)

  1. paulandrew
    Member
    Posted 4 years ago #

    Just installed 2.8.2 fresh yesterday, and now today am trying to do Tools-Upgrade to go to 2.8.3.

    The FTP log-in goes just fine, but then I get a very zen "Installation Failed" message right away, with no other detail.

    Am running PHP5.

    Any ideas?

    thanks,

    Paul.

  2. paulandrew
    Member
    Posted 4 years ago #

    One other thing--I did deactivate all of the plug-ins.

  3. Zulfikar Nore
    Member
    Posted 4 years ago #

    No known issues yet - I've just upgraded one of my blogs with no problem.
    Give it a little time and try again later.

  4. Trevor Jacques
    Member
    Posted 4 years ago #

    Same problem here. Mac OS X Server 10.5.7:

    Downloading update from http://wordpress.org/wordpress-2.8.3.zip.

    Unpacking the update.

    Warning: ftp_mkdir() [function.ftp-mkdir]: "/" is current directory. in /Library/WebServer/domainfolder/wp-admin/includes/class-wp-filesystem-ftpext.php on line 240
    Could not create directory: /domainfolder/wp-content/upgrade/wordpress-2.8.3/wordpress/wp-includes/js/tinymce/plugins/wpgallery/img

    Installation Failed

  5. Zulfikar Nore
    Member
    Posted 4 years ago #

    Did you deactivate all the plugins?

  6. pazazllc
    Member
    Posted 4 years ago #

    Downloading update from http://wordpress.org/wordpress-2.8.3.zip.

    Unpacking the update.

    Could not copy file: /public_html/wp-content/upgrade/wordpress-2.8.3/wordpress/wp-comments-post.php

    Installation Failed

    Okay, what am I doing wrong here.

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    Automatic upgrade doesn't work on all hosting systems. Nor will it ever, there's too many ways that systems can be configured.

    If you have a failure, upgrade manually.
    Upgrading WordPress

    If you administer your own dedicated hosting system, then the easiest way to make auto-upgrades work is:
    a) Use PHP 5.
    b) Use mod_suphp with Apache.
    c) Ensure that permissions are correct on all the files, and that they are owned by the user who is supposed to own them (and not the webserver user).

    The rest of the system config doesn't much matter at that point.

  8. pazazllc
    Member
    Posted 4 years ago #

    I've always been able to do an automatic upgrade.....this is the first time it has failed.

  9. mrmist
    Forum Janitor
    Posted 4 years ago #

    Potentially permissions, but it could be any number of things. Do a manual upgrade for this one.

  10. pazazllc
    Member
    Posted 4 years ago #

    Okay will try. Thanks

  11. hpguru
    Member
    Posted 4 years ago #

    Same here. Upgrade manually.

  12. shsh1345
    Member
    Posted 4 years ago #

    I've tried to auto update and got the following error:
    Downloading update from http://wordpress.org/wordpress-2.8.3.zip.

    Fatal error: Allowed memory size of "x" bytes exhausted (tried to allocate "y" bytes) in long adress/wp-includes/http.php on line "z"

    can someone please help?

    my site http://www.superenlightme.com

  13. Zulfikar Nore
    Member
    Posted 4 years ago #

    @shsh1345 - add this to your config.php and try again
    define('WP_MEMORY_LIMIT', '64M');

  14. shsh1345
    Member
    Posted 4 years ago #

    Thank you ZGani that worked great.

  15. jimsky7
    Member
    Posted 4 years ago #

    @paulandrew - did you get it worked out? I currently am using 75M max memory both for PHP5 and for WP and I get the same thing - no message other than "Installation failed" - it doesn't even try to download the WP file. On this particular server I was auto-upgrading until 2.8.2 failed. I had to manually load the files.

    I successfully auto-upgrade on many servers, even versions 2.8.2 and 2.8.3, but on some servers it just fails like this without any other error message.

    Plugins correctly upgrade on this (the failing) server. Same log-in info, and using SFTP in all cases. The plug-in upgrades are also very fast and always succeed. The full WP upgrade still fails.

    As a test I chmod'd files to a+rw and it still didn't help.

  16. Zulfikar Nore
    Member
    Posted 4 years ago #

    @shsh1345 you are welcome.

    @jimsky - are all the plugins deactivated? If you have the wp auto-update plugin installed you will need to delete it, its know to fail upgrades even though its deactivated.

    You might also want to switch to the default theme first then try upgrading.

  17. harabanar
    Member
    Posted 4 years ago #

    I have the same problem for different sites on same server. Same configuration. I Updated one site that had all plugins enabled, no problem. While other sites show me nothing more then "Installation Failed".

    Is there no solution for fixing this?

  18. harabanar
    Member
    Posted 4 years ago #

    I found out that the find_folder function in the WP_Filesystem_Base class does not return a value when the root folder of the FTP path is the root location of the site. Therefor the error returned is "fs_no_folder".

    I fixed this my adding a folder within the root FTP location and moving the root location of the web. Then it all worked out.

    I think this is a bug that must have come when I upgraded to 2.8.2.

    plz fix this in future releases.

  19. jimsky7
    Member
    Posted 4 years ago #

    I don't have the wp auto-update plugin and my plugins were all deactivated and also moved to another directory so the plugins directory was empty when I upgraded. Same failure - instant "Installation failed"

    I have traced through the code that performs the auto-upgrade and for reasons not yet known to me it checks to see if the directory "/" exists (it's checking for ABSPATH and WP_CONTENT_DIR before it begins upgrading) and the check fails ... so my upgrade stops. No error message is being returned from fs_connect() [in file wp-upgrader.php] which is the routine that is called to check for existence of various directories before an upgrade can begin. I don't see why there's no error message generated (yet) in fs_connect(). I modified the code so it would skip checking if the directory name is "/" and my upgrade to 2.8.3 was performed just fine - took about 60 seconds. (It would be pretty goofy if the filesystem was OK and "/" didn't exist, wouldn't it?)

    I'll file a bug report.

  20. jimsky7
    Member
    Posted 4 years ago #

    Hey @harabanar - you found essentially the same thing! I didn't see your response because I was on my other computer debugging this process. I don't have the option of moving my docroot, sorry, because I have about 25 WP instances that are affected by this bug. I'll just hack the code in fs_connect() for now.

  21. ABCDiamond
    Member
    Posted 4 years ago #

    I did the : config.php : change
    define('WP_MEMORY_LIMIT', '64M');

    and it worked on 5 sites that I have WP on.

    I was puzzled as two of my sites are VERY new: 4 pages, 2 posts and 1 comment ! and yet still had memory problem ???

    Even my largest site, using WP, is still small: 14 pages, 38 posts and 1 comment.

    I only recently started with WP, and do now have some concerns, although hopefully this is a one of malfunction...

  22. jimsky7
    Member
    Posted 4 years ago #

    This is a really nasty deep-down bug...we sometimes see some feature added to WP that later on fails, but it doesn't happen very often. WP is a very cool system with a dedicated maintenance and development crew. The auto-upgrade feature saves me hours every time a new WP is released, so I particularly wanted it to work. It's not clear why it works on some of my 25 blogs and not on others, however.

    Anyone know how to report this bug so it gets fixed in the future?

  23. paulandrew
    Member
    Posted 4 years ago #

    I got itchy and ended up doing a hand upgrade and it worked fine. Because it's a new site, it didn't take too long. Nice to know I'm not alone though. :)

  24. lilatovcocktail
    Member
    Posted 4 years ago #

    I auto-upgraded about 3 minutes ago and got this error when I refreshed my site (http://theagnonschool.org).

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'order ASC' at line 1]
    SELECT t.*, tt.* FROM wp_terms AS t INNER JOIN wp_term_taxonomy AS tt ON t.term_id = tt.term_id WHERE tt.taxonomy IN ('category') AND ( t.term_id <> 1 AND t.term_id <> 9 AND t.term_id <> 46 AND t.term_id <> 48 ) ORDER BY order ASC

    And, OK, I was an idiot. Because every other upgrade I've done has gone super smoothly, for some reason I thought it would be OK not to back up (although I do have autobackups from yesterday). So I didn't back up. Now what do I do? Is there an easy way to go back to 2.8.2?

  25. whooami
    Member
    Posted 4 years ago #

    i see this:
    Warning: require(/home/shem/public_html/wp-includes/compat.php) [function.require]: failed to open stream: Permission denied in /home/shem/public_html/wp-settings.php on line 246

    which looks youre reinstalling.

    i would have tried the default theme first, and disbaling your plugins.

  26. ANappyGirl
    Member
    Posted 4 years ago #

    I just hit the "Auto upgrade" button, and it upgraded without a hitch. I didn't do anything prior, except backup my WP.

  27. SauloB
    Member
    Posted 4 years ago #

    My error:

    Downloading update from http://wordpress.org/wordpress-2.8.3.zip.
    
    Unpacking the update.
    
    Could not copy file: /var/www/avwordpress/wp-content/upgrade/wordpress-2.8.3/wordpress/wp-includes/js/codepress/engines/khtml.js
    
    Installation Failed

    All plugins off. I use a SSH connection.

  28. lilatovcocktail
    Member
    Posted 4 years ago #

    Whooami, thanks for the reply.

    That's right, I reinstalled the earlier the previous version of WP. Still got the error message. I restored my database to a version from a couple days before the upgrade. Still got error message. I repaired my database from cPanel. Still got error message. I tried again to upgrade to 2.8.3. Still got error message.

    I don't know anything about MySQL, so I did sent a support ticket to my host, Hostgator. Do you have any ideas about what went wrong or suggestions about what I should do?

  29. lilatovcocktail
    Member
    Posted 4 years ago #

    Okay, wait, I just checked again -- about an hour after I tried the initial upgrade -- and the problem is gone, and I have an email from Hostgator saying:

    Greetings and Salutations!

    Looks like this was caused by the my-category-order plugin. I moved the directory (/home/shem/public_html/wp-content/plugins/my-category-order/ to /home/shem/public_html/wp-content/plugins/my-category-order.old) and this resolved the error at the top of the screen. I went and downloaded the newest version of WordPress but was still getting this error. It seems this part of the query "ORDER BY order ASC" is incorrect (where oder ASC needs to be tt_order ASC or something similar).

    In the mean time, the website is no longer displaying any errors, but you may want to get a hold of the plugin author to resolve this issue. Youc an more information here:

    http://wordpress.org/extend/plugins/my-category-order/

    Hope this helps! Please do not hesitate to contact us if you are in need of further assistance.

    Have a wonderful day!

    Thanks for trying to help. I've learned my lesson about upgrades, backups and plug=ins. :-)

  30. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    Anyone know how to report this bug so it gets fixed in the future?

    If you have technical details on the bug, you can go to trac.wordpress.org and file the bug report there. Use your wp.org login and password.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags