WordPress.org

Ready to get started?Download WordPress

Forums

Auto Updater Issue - Strange behavior & Errors (3 posts)

  1. kiwiot
    Member
    Posted 1 year ago #

    Before I get started here are my system detials.

    Running WordPress 3.5
    Server Version: Apache/2.2.23 (Unix) mod_ssl/2.2.23 OpenSSL/0.9.8e-fips-rhel5 mod_bwlimited/1.4 PHP/5.3.20

    OK, so auto updates have stopped working and I'm not sure why.

    First error: If I go to add a new plugin everything runs smoothly with output

    Downloading install package from http://downloads.wordpress.org/plugin/new-googleplusone.zip…
    Unpacking the package…
    Installing the plugin…
    Successfully installed the plugin New GooglePlusOne 1.4.

    If I click activate I get the error

    The plugin does not have a valid header.

    If I click go back to plugin directory the plugin does not exist.

    I have checked the file directory on my server and the files never install. I have checked this both as a user from a ftp client and logged in as root on my server.

    Now if I were to go and try and install the same plugin again using a new error appears

    Downloading install package from http://downloads.wordpress.org/plugin/new-googleplusone.zip…
    Unpacking the package…
    Installing the plugin…
    Destination folder already exists. /home/ktrunner/public_html/wp-content/plugins/new-googleplusone/
    Plugin install failed.

    Saying that the folder exists which is false. It does no exist anywhere on the server. I have looked through the database and wp-files to try and figure out where this is being referenced and am stumped.

    user/group permissions are being set to my ftp user, and my upgrade dir has 755 permissions

    I have tried deactivation all the current plugins and then adding a new - same issue.

    Thought it might be something to do with _transient data in the db so I cleared all that out too. Cleared my computer cache as well.

    Have tried two browsers firefox and chromium.

    And now I'm stumped. How can the installer think it's installed when there is not a folder there?

    I also tried changing the ftp method using

    define ('FS_METHOD', 'direct');

    but get the following result

    Downloading install package from http://downloads.wordpress.org/plugin/new-googleplusone.zip…

    Unpacking the package…

    Could not create directory. /home/ktrunner/public_html/wp-content/upgrade/new-googleplusone.tmp

    This method tries to install using chown nobody:nobody and therefore has permission issues.

    Anyone? Why the sudden change? This is also happeneing on one other of my wp installs, but not on others? The only thing that seems to be a constant is that I installed woothemes - and then the issues started, however I removed it, deleted the files, but the problem remains.

    Are ftp settings being stored somewhere that I am not aware of?

  2. cjgrasso
    Member
    Posted 1 year ago #

    Did you ever find a resolution to this? Im having nearly the same issue... Im getting folder already exists errors, even though I can't see the folder on through filezilla. Also, when I try to update an existing plug in, it tells me it was successfully downloaded and reactivated, but then it still shows the old version that needs to be updated....

  3. cjgrasso
    Member
    Posted 1 year ago #

    I am running wp 3.5.1 on apache, and recently just migrated the blog from subdomain to root.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.