WordPress.org

Ready to get started?Download WordPress

Forums

Auto update to 3.04 issue with wp super cache plugin (11 posts)

  1. onnoysomoy
    Member
    Posted 3 years ago #

    Hi,
    After auto updating I couldn't login to my admin panel. Tried several times to renaming plugin folder but when I activate wp super cache plugin i failed to login to admin panel.

    Anyone having problem like this? currently I am delete wp super cache plugin using cpanel file manager.

    Hope plugin developer will look at this.

  2. bh_WP_fan
    Member
    Posted 3 years ago #

    I am also using wp-super-cache and did not have the same problem. Perhaps the plugin cached a page which had actually failed, or caused a failure, due to something else?

  3. Can you manually delete the cache files?

  4. onnoysomoy
    Member
    Posted 3 years ago #

    yes , I delete cache plugin manually.

  5. No, not the cache plugin, the cache FILES... There's usually a folder where wp-super-cache stores everything cached. The problem is that wp-super-cache isn't as simple as deactivating to uninstall. There's some cleanup to do...

  6. Donncha O Caoimh
    Member
    Posted 3 years ago #

    Can you login when you disable the plugin? Are there any php errors? Supercache shouldn't stop you logging in. It doesn't even cache the login page or admin pages. Check you wp-config.php - perhaps something's amiss there?

  7. onnoysomoy
    Member
    Posted 3 years ago #

    I deleted whole super cache plugin folder. I tried first with deactivating but it not works. Than I delete folder from hosting control panel using file manager.

  8. MarkPine
    Member
    Posted 3 years ago #

    I get stuck with this plugin insisting that I use permalinks for it to work. But when I've tried that in the past, my pages do not load in the browser. Consequently, don't use permalinks. Is there a way around this problem.

  9. peterjanes
    Member
    Posted 3 years ago #

    I found that I had a wp-super-cache/plugins/rebuild-if-links-updated.php file, apparently from an old install, which causes the admin pages to die with a 500 on its add_filter() call. (WP reports that that method doesn't exist when WP_DEBUG is enabled, but it's silent otherwise.) Could be the issue that's causing the recent reports.

  10. Donncha O Caoimh
    Member
    Posted 3 years ago #

    Mark - unfortunately not. You have to use permalinks. Check this site for other caching plugins that might suit your site.

    Peter - that isn't a file that was ever included in Supercache. That might be something you were messing with a long time ago?

  11. peterjanes
    Member
    Posted 3 years ago #

    Donncha - must be, given that I don't remember writing or adding it! The bad plugin does kill the site exactly as described above, though---as soon as WP_CACHE is enabled the entire admin section goes to 500, with no browser output and (on DreamHost at least) no messages to the error log.

Topic Closed

This topic has been closed to new replies.

About this Topic