WordPress.org

Ready to get started?Download WordPress

Forums

Auto Draft (17 posts)

  1. dalewood
    Member
    Posted 3 years ago #

    Hi

    I am getting posts titled AUTO DRAFT, even when published and now articles in pages are being titled AUTO DRAFT.

    Please can someone sort this, it is serious, my sanity is in question!

    Phil

  2. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    - increasing the available memory?
    http://wordpress.org/extend/plugins/memory-bump/
    http://wordpress.org/support/topic/253495#post-1017842

  3. khalladay
    Member
    Posted 3 years ago #

    Are you using the postMash plugin, and did you recently upgrade to WP 3? Just today I found the same problem with one of my blogs, after moving to WP 3 last week, and deactivating postMash SEEMS to have helped.

  4. mitchellk
    Member
    Posted 3 years ago #

    Esmi .... this is a known bug .. it has nothing to do with plugins or anything else, it's a wordpress 3.0 bug and a very messy one I might add. For SEO this is an absolute nightmare because pages called "Auto Draft" keep appearing in the "default" wordpress random pages widget and Search engines keep getting 404 errors when calling those pages.

    I'd like to see a REAL solution this very REAL problem without hacking core and template files.

    http://core.trac.wordpress.org/ticket/11889

  5. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Since my original post, I've learnt that it appears to be an issue with the Atahualpa theme:
    http://forum.bytesforall.com/

  6. mitchellk
    Member
    Posted 3 years ago #

    Hi esmi, I've seen posts about that too but I don't use that theme at all. I did however find a plugin which disables the autosave and revisions feature altogether. I'm going with the plugin for now until this get resolved in a future update to 3.0.

    http://exper.3drecursions.com/2008/07/25/disable-revisions-and-autosave-plugin/

  7. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    If it's an issue in 1 theme, it could well be a problem in others.

  8. mitchellk
    Member
    Posted 3 years ago #

    I think I will have to dig into this a bit more. The above plugin does disable the autosave and revisions functions but it does NOT stop WP creating Auto Draft pages. I'll dig into the template code tomorrow and see if I can find a similarity between it and atahualpa.

  9. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    If you do find something, please let us know so we can pass a possible solution onto to others.

  10. mitchellk
    Member
    Posted 3 years ago #

    I will certainly do that :)

  11. Anthony Butler
    Member
    Posted 3 years ago #

    To delete these pages you need to use a MySQL front end, go to the posts table, sort on post_status and all the auto-drafts will come to the top for ease of deletion. Seems to be a WP core problem - every time I login or switch to the dashboard page an auto draft is created unless there is one in the posts table already. Search Unleashed finds them, which is a further embarrassment, and duplicates can be created.

  12. Anthony Butler
    Member
    Posted 3 years ago #

    If a plugin or theme does not handle these auto draft pages correctly, you need to do some PHP coding. Here is the filter I have added to the Misty Look theme's search.php module to get rid of auto draft and trash items that Search Unleashed returns incorrectly:

    <?php $p_status = get_post_status( $post );
           if ($p_status != 'trash' and $p_status != 'auto-draft') : ?>

    Followed later on by:

    <?php else: echo 'One irrelevant ',$p_status,' item not shown here.';
           endif; ?>

    This sort of change is very easily done if you use the 'child theme' facilities of WordPress.

  13. funorang
    Member
    Posted 3 years ago #

    Yes I solve this problem.. go to wordpress permalink option and change your cuntom permalink structure to %postname% to %post_id% this will solve your problem.

  14. nativemainer
    Member
    Posted 3 years ago #

    For those of you running Postmash, this appears to be a fairly simple fix. Change the following line(s) of code in postMash.php:

    //get pages from database
            $pageposts = $wpdb->get_results("SELECT * FROM $wpdb->posts WHERE post_type = 'post' ORDER BY menu_order");

    to this:

    //get pages from database
            $pageposts = $wpdb->get_results("SELECT * FROM $wpdb->posts WHERE post_type = 'post' and post_status NOT LIKE 'auto-draft' AND post_title NOT LIKE 'Auto Draft' ORDER BY menu_order");

    This will prevent postMash from finding any auto-draft entries in the wp_posts table (including those already eroneously published). If you already have published "Auto Draft" posts, either return them to draft status or delete them.

    Oh, and if you actually want to use postMash with a post titled 'Auto Draft' you can ommit "AND post_title NOT LIKE 'Auto Draft'"
    --Chillin' in Portland

  15. rstritmatter
    Member
    Posted 3 years ago #

    I'm having the problem with "Lunatic Fringe"

    http://www.Shake-speares-bible.com

    It seems to be connected to postmash -- every time I use postmash the system generates a new auto save. Or something like that.

    I'll try Nativemainer's fix and report back.

  16. rstritmatter
    Member
    Posted 3 years ago #

    So far so good -- it looks like nativemainer's fix is a good.

    This maybe obvious but for newbies like me, the postmash.php file is in content--plugins--postmash file.

    Thanks!

  17. marshallhouse
    Member
    Posted 3 years ago #

    I commented out line 379 in wordpress/wp-admin/includes/post.php and i don't have that problem anymore.

Topic Closed

This topic has been closed to new replies.

About this Topic