WordPress.org

Ready to get started?Download WordPress

Forums

Authors not notified of new comments (16 posts)

  1. azmatt
    Member
    Posted 7 years ago #

    I recently upgraded to the new version of wordpress (2.07) and now the authors are no longer recieving notification of comments. I was wondering if this problem is existing for everyone. I uploaded all of the wp-includes, and the ones in the wp-admin files that were mentioned as needing to be uploaded. It was working fine before the update.

  2. drmike
    Member
    Posted 7 years ago #

    Have you checked your server's mail logs?

  3. azmatt
    Member
    Posted 7 years ago #

    Notification for all of the other wordpress installments (old versions) work just fine that are on the same server, and it would take a while before the person with permission to the logs could go through it.

  4. Wes
    Member
    Posted 7 years ago #

    I'm definitely having this problem too, although I'm certain that I received <i>some</i> e-mails using 2.07 before WordPress stopped working for me. According to my mail logs, I'm now getting this error:

    smtp server didn't accept RCPT To: command, replied "550 mail from 74.208.16.2 rejected: administrative prohibition".

    Now, I'm almost sure that this is because of something my host changed during the past couple of days -- incidentally, one of my WordPress blogs went down this morning (and is still down) because the database server is now inaccessible (except, for some reason, from phpMyAdmin) :( -- but is there anything that I can do to get around the e-mail problem? Any assistance will be greatly appreciated.

  5. jennmiller
    Member
    Posted 7 years ago #

    I'm having the same error as Wes. I have two different "packages" with my host which have three different 2.1 installations on them. The package with one one install (which is emailing notifications properly) has perl support while the package with the other two (not emailing properly) does not offer perl support.

    Is perl the reason email notifications stopped with the upgrade to 2.1 even though WP doesn't use perl (according to the Codex)?

  6. Wes
    Member
    Posted 7 years ago #

    Figured I'd mention this here as well -- if you're getting the same error that I was, here's a potential way around it. Since apparently the problem has something to do with the smtp server rejecting messages, try using the WordPress Swift SMTP Plugin and configuring it to send through the server via authenticated means. (I have an ultra-cheap webhost that offers like 4000 e-mail accounts and I was only using a forwarding one, so I set up a new private account for the plugin to use.) The reply-to section of the received e-mail messages is a bit odd in that it includes both the sender (wordpress@whatever.com) and the commenter's e-mail addresses, but at least it's functional (in my case, anyway).

    It's also worth noting that when I enabled it, configured it, and tried the built-in test e-mail function, the test e-mail did NOT send (although it said it did). I still receive comment notifications, though. Weird.

  7. candicehoeflinger
    Member
    Posted 7 years ago #

    I just installed the same pluging you did Wes, get the error message when I try doing the text email, AND DO NOT get emails notifications still.
    any suggestions?

  8. Wes
    Member
    Posted 7 years ago #

    What are you using for the port? Despite reading in my host's configuration options that I should be using 587, I could only get the plugin to work by setting the port to the default value of 25. If your setup is like mine, you should *not* get an error when you try the test e-mail, but you won't necessarily get anything else either. I received no test e-mail, but the comment notifications are okay.

    Also, I should note that (perhaps obviously) this doesn't fix the greater problem with being unable to receive e-mails from WordPress. I still remain unable to e-mail myself backups of the database, for example, and I'm not sure what the overall problem is.

  9. gruntdoc
    Member
    Posted 7 years ago #

    I'm having the same problem as azmatt, who opened this thread. Other people's comments to any author's thread are emailing perfectly well, but when an author comments on their own post it's not getting emailed.

    I suspect there's a bit of code that's suppressing emailing post author's comments to the post author, rightly believing 'they know that, they wrote it', but it's screwing up comment notification for everyone else.

    So, there's two problems in this thread: one is (I'm guessing) comments being suppressed, and another is the emailing functionality from various web hosts.

  10. Wes
    Member
    Posted 7 years ago #

    Is that what azmatt meant? I have never received e-mail notification regarding my own comments -- at least when I commented while still logged in -- in any version of WordPress that I can remember. Have your authors try commenting when they're logged out and see what happens.

  11. gruntdoc
    Member
    Posted 7 years ago #

    That would seem to defeat the "Users must be registered and logged in to comment" function, but yes it works perfectly well if the commenters are logged out.

    So, how do I fix it so that logged-in comments from the post author mail-out?

  12. Wes
    Member
    Posted 7 years ago #

    I have no clue -- I was under the impression that this thread had to do with authors and administrators not receiving comment notifications at all.

    However, if you look at comment.php in the wp-includes folder, you'll see a note that clearly marks the line that prevents authors from being notified of their own comments:

    $post = &get_post($commentdata['comment_post_ID']); // Don't notify if it's your own comment

    So maybe try disabling that line?

  13. gruntdoc
    Member
    Posted 7 years ago #

    Wes, I apologize if I got the thread wrong, but thanks for the fix! Disabling that line worked perfectly.

  14. Wes
    Member
    Posted 7 years ago #

    Oh, no problem! Glad I could be of service concerning that matter.

  15. Wes
    Member
    Posted 7 years ago #

    Not sure how you all are doing with this issue, but I just encountered a pleasant spot of weirdness. While upgrading one of my blogs to WP 2.1.1, I decided to try leaving the WordPress Swift SMTP Plugin deactivated to see if perhaps something had been changed to fix the problem -- and lo and behold, comment notification was working again.

    The weird part, however, is that when I decided to try the other blog <i>before</i> upgrading to WP 2.1.1, the commenting was also back up. WP is even e-mailing me backups, where before that failed.

    So I'm guessing it was a server issue on my end. Have anyone else's problems miraculously fixed themselves?

  16. ssetd
    Member
    Posted 6 years ago #

    My problem was solved, thanks to a post from "foolswisdom" (I believe that's the moniker) on another one of the several threads on this issue.

    All I had to do was add an email address to my domain: wordpress@(mydomain). Foolswisdom also gave an alternate way to fix this, via code. If I can ever find that thread again, I'll leave a thank you note. Mine is working again, thanks to that little fix.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags