WordPress.org

Ready to get started?Download WordPress

Forums

Authors Can Not Embed Video??? (18 posts)

  1. nickaster
    Member
    Posted 5 years ago #

    It seems that every time an Author tries to paste embed code (for a youtube video, for example) the code magically disappears when they save a post.

    What the heck is going on? This problem does not seem to affect editors and administrators who can post you tube videos in posts with no problem.

    Is this normal or maybe related to a plugin?

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    What tab are they using? HTML or Visual?

  3. nickaster
    Member
    Posted 5 years ago #

    The HTML Tab. I haven't been running WP long enough to know if it ever worked for them. With editor/admin privileges I've never seen a problem with this. But I've definitely been able to reproduce the problem by creating a new author and trying to include emded code - bam, it just disappears the second you save a post.

    This may be related to the "role scoper" plugin I installed, but I've since disabled it and the problem is still there.

  4. esmi
    Forum Moderator
    Posted 5 years ago #

    Try deleting that plugin.

  5. nickaster
    Member
    Posted 5 years ago #

    yeah, I did. Dang problem still persists. it's totally bizarre. Can you think of anything that might fight with the editor like that? I know, for example, that it strips out iframe code if I try to use that, could something have triggered whatever that filter is to go haywire?

    Did a second set of tests with new Author, bunch of different browsers. It's definitely a consistent problem.

  6. nickaster
    Member
    Posted 5 years ago #

    this is a serious drag. I've seen crazy stuff like this before in drupal. What is the name of the wysiwyg software that WP uses? Is it TinyMCE? Could that be malfunctioning even though I'm in the HTML tab?

    Here's a clue - there's an option here to allow "unfiltered html" for some uesrs -

    http://codex.wordpress.org/Roles_and_Capabilities#Capabilities

    According to that page "unfiltered HTML" is not allowed by Authors, so maybe this is actually a normal thing. I'm kind of surprised.

    Is there a way to give all Authors this capability without a plugin?

  7. nickaster
    Member
    Posted 5 years ago #

    Crapalicious... so it looks like Role Manager is not supported by 2.8x and the alternative is a hack. I'm wary of reinstalling role scoper. anyone got other ideas?

  8. droiddog
    Member
    Posted 4 years ago #

    Role Scoper seems like waaaaaay too much plugin just to solve this little problem. I'd love to see a solution here.

  9. elbati
    Member
    Posted 4 years ago #

    Same problem here, never installed Role Manager.
    I'm using WordPress 2.9.1.
    When an author tries to embed youtube video, the code disappears after saving.
    This happens with both HTML and Visual editors.

    Does anybody know why?

    Thanks,
    LB

  10. asfodel
    Member
    Posted 4 years ago #

    Authors have never been able to embed video on my site. I use the EasyTube plugin and it works fine (at least I think so, I can't remember the last time an author tried to post a YouTube video).
    http://www.paulbain.com/uk-wordpress-developer/wordpress-plugin-development/easytube/

  11. gallamine
    Member
    Posted 4 years ago #

    Any results on this? I'm having this issue too with my Author roles. Seems like a significant problem.

  12. cerebraldiva
    Member
    Posted 4 years ago #

    I am trying to upload videos from VH1 and other channels and using the html tab doesn't work...it disappears after I save it.

  13. zer0ruth
    Member
    Posted 4 years ago #

    I had the same exact problem: admin tries to embed video, no problem. Author tries to embed same video (same exact code) and it shows up as a link instead.

    This is because wordpress has the Author user role defined as someone who can only write and edit their own posts AND cannot post javascript or complicated html.

    to change this you have to modify the default user capability. Thankfully, this is easy to do.

    Open up the functions.php file in your theme folder. At the top of this file add the following code:

    // get the "author" role object
    $role = get_role( 'author' );
    
    // add "organize_gallery" to this role object
    $role->add_cap( 'unfiltered_html' );

    Basically, you are just giving the author user role access to post any kind of code they want by adding the 'unfiltered_html' capability. Just make sure that you can trust all of your authors before adding this, because without html filtering, a user could do considerable harm to your site if they decided to post some nasty javascript.

  14. vitabile
    Member
    Posted 4 years ago #

    It'd be nice if the unfiltered_html capability were something you could set, per user, on that user's Edit page.

    Tony

  15. Michael Dance
    Member
    Posted 4 years ago #

    Justin Tadlock's "Members" plugin should let you manipulate it pretty easily:

    http://wordpress.org/extend/plugins/members/

  16. qcait
    Member
    Posted 4 years ago #

    I installed the plugin User Role Editor - http://wordpress.org/extend/plugins/user-role-editor/ - that is pretty simple to use. It lists the default WordPress roles and has checkboxes next to all of the actions available (with the default permissions check). You can add or remove permissions by simply clicking or unclicking actions and hitting "Update."

    Go to Author (or whichever role is having issue) and check the box "unfiltered_html" and update - and voila.

    Thanks!

  17. timothly
    Member
    Posted 4 years ago #

    @qcait This worked PERFECTLY, thank you so much!

  18. tommcgee
    Member
    Posted 4 years ago #

    Grr. not working at all. object tag code disappears without a trace. I'd been using Capabilities Manager, but deleted it and the roles it had created, then started building fresh with this. But it doesn't do it either.

    Users are also having trouble changing some widget options, Twitter Tools for one.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.