WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Widget Pro
[resolved] Authorize New Account does not redirect (26 posts)

  1. atorreno
    Member
    Posted 1 year ago #

    I've read every other support thread that describes a similar problem, but none of them resolves my issue.

    I have:
    - logged into dev.twitter.com
    - created a new application
    - filled in name, description, website, and callback url
    - agreed to rules, filled in captcha
    - copied consumer key and consumer secret to plugin settings page
    - clicked update options
    - clicked 'authorize new account'

    Instead of being redirected to Twitter, the page refreshes, and I'm still in WordPress admin, on the Twitter Widget Pro settings page.

    I have tried the following, based on other threads:
    - Disabled other plugins
    - Ensured that I have entered my WP site domain in the twitter app callback url field
    - Adding random site domains to the callback url field

    My setup
    - WordPress 3.5.1
    - IIS 7
    - PHP 5.4.0

    A few extra notes
    - on dev.twitter.com, my access token wasn't created, but there was a button allowing me to create one, so I did that.
    - my blog domain starts with 'blog', so my callback url is http://blog.my blog name].com
    - I can use the advanced rest client in Chrome to make API calls, and get successful responses

    What else could I be missing?

    http://wordpress.org/extend/plugins/twitter-widget-pro/

  2. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    This was with v2.5.2 that was released earlier today? I actually don't have any IIS servers to test it with, but I HAVE tested it on WordPress 3.5.1 and PHP 5.4

  3. atorreno
    Member
    Posted 1 year ago #

    Sorry, I forgot to mention that, v2.5.2

  4. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    Unfortunately, I can't reproduce this one. I'll see if I can spin up a Windows machine to test, but that will probably take more time than I'll have for the next several days at least.

  5. franciscanheart
    Member
    Posted 1 year ago #

    I'm having the same issue.

  6. atorreno
    Member
    Posted 1 year ago #

    Digging into your code I see this
    $token = $this->_wp_twitter_oauth->getRequestToken( $auth_redirect );

    which generates this error
    SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

  7. atorreno
    Member
    Posted 1 year ago #

    This looks promising: I will try it once I get home

  8. atorreno
    Member
    Posted 1 year ago #

  9. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    The only thing between clicking the link and getting redirected is a request to Twitter to get the request token. If this fails the redirect wouldn't happen. I added some code to the dev version of the plugin over on GitHub that will display the error if one occurs. Can you try using that version and tell me what errors you're getting?
    https://github.com/OpenRange/twitter-widget-pro/archive/master.zip

    Thanks.

  10. atorreno
    Member
    Posted 1 year ago #

    I get the same thing that I got by tinkering with your code

    SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

    According to this:
    http://richardwarrender.com/2007/05/the-secret-to-curl-in-php-on-windows/

    I have a few extra steps in Windows before I can make the remote call to Twitter.

    I'm too far down the rabbit hole at this point. Is your code eventually using cURL? Can you point me in the right direction as to where I insert the fix mentioned in the Richard Warrender blog post?

  11. atorreno
    Member
    Posted 1 year ago #

    k, figured it out.

    Apparently, wp_remote_get() doesn't have up-to-date certificate authorities, or perhaps doesn't have any at all, so it can't verify ssl certificates. I suppose this is Windows-specific? Not sure.

    This article talks about it
    http://wordpress.stackexchange.com/questions/21749/what-is-the-relationship-between-curl-wordpress-and-cacert-pem

    So the two options are to install certificate authorities, which I couldn't figure out, or to turn off ssl verification

    in twitter-widget-pro/lib/wp-twitter.php
    find this
    $resp = wp_remote_get($request_url);
    and change to this
    $resp = wp_remote_get($request_url, array('sslverify'=>false));

    just in case I also changed this
    $resp = wp_remote_request($request_url, array( 'method'=>$method, 'body'=>$parameters));
    to this
    $resp = wp_remote_request($request_url, array( 'method'=>$method, 'body'=>$parameters, 'sslverify'=>false));

  12. joernesdohr
    Member
    Posted 1 year ago #

    I had the same issue. Your suggested changes in wp-twitter.php fixed it, thanks atorreno for your work! Also, thank you Aaron for this great plugin :)

  13. Lizzan
    Member
    Posted 1 year ago #

    Hi,

    I'm having the same problem, using Apache 2.2.11, PHP 5.2.9-2, WP 3.5.0 and Twitter Widget Pro 2.5.2 on Windows Server. When trying the dev version I get the error message "There are no HTTP transports available which can complete the requested request."

    When trying to "Authorize New Account" on my developer machine (Mac OS 10.8.2, Apache, PHP 5.2.17, same wordpress and plugin versions) I get
    "Could not recognize the response from Twitter"

    atorrenos suggested fixes make no difference.

    Any suggestions?

  14. Lizzan
    Member
    Posted 1 year ago #

    Well, it seems to work on my Mac now, I had apparently managed to remove the callback url even though it looked like it was still there before. Still no luck on the Windows Server installation.

  15. Lizzan
    Member
    Posted 1 year ago #

    Problem solved on the Windows server as well - needed to activate cURL in php.ini.

  16. hash73
    Member
    Posted 1 year ago #

    Having exactly the same issue...Apache server and tried the amends above but no joy. Can the author shed any light?

  17. Sarah78
    Member
    Posted 1 year ago #

    I'm having the same problem here and just like Lizzan said, atorrenos fixes didn't do anything.

  18. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    atorreno: The certificate authorities issue is actually server-related not WordPress-related, but you are correct that bad CA was causing problems. Version 2.5.2 that was released about 4 days ago to fix this, but I see that it didn't completely fix the issue. I'll release a new version soon to fix it completely.

    Everyone else: If you're problem is NOT the SSL (the fixes above don't work for you) then it is most likely a plugin conflict. Please disable all other plugins and see if it works. Enable your plugins one at a time to see which one was causing the issue. Then open a new support thread since your problem is not related to this one.

  19. alive
    Member
    Posted 1 year ago #

    I'm having the same issue. After creating the application and saving the consumer key/secret I get the error message "Could not recognize the response from Twitter" when clicking the Authorize new account button.

    I tried disabling all other plugins but still the same error. Running WP 3.5.1 and TWP 2.5.3.

  20. nikoza
    Member
    Posted 1 year ago #

    Facing the same issue in Apache.

    I have copied the Consumer key and the Secret Key.
    I have not set up a callback URL.

    When I try to do the Authenticate New Account I stay in the same page and I get an error: connect() timed out!

    Is this related with this above?
    Is anybody facing the same issue?

    Thank you all for your great support and the even better plugin.

    Regards,
    n.

  21. zbartrout
    Member
    Posted 1 year ago #

    I just upgraded the plug-in and I am now getting the same issue as Alive above. How can I resolve this? Why did I loose all my setup codes, just by auto upgrading?

  22. zbartrout
    Member
    Posted 1 year ago #

    See screen
    Click to view
    This used to work.

  23. zbartrout
    Member
    Posted 1 year ago #

    This was resolved for me by adding the callback URL even though Twitter stated it was optional.

  24. holmpage
    Member
    Posted 1 year ago #

    I'm having the same problem, and have tried atorreno's fixes and some other things but no luck. I have to give up for today. I'll watch for updates and other options. :(

  25. avdruten
    Member
    Posted 1 year ago #

    Hi, I had the same problem (Could not recognize the response from Twitter) and encountered your topic. None of the above resolved my issues. It turned out I had to change settings at dev.twitter.com. Under Settings-tab I set [Application type] to "Read and write" and updated it.
    Just as zbastrout said I also entered in a [Callback url] (which annoyingly cannot be a localhost-address, which is the first place a developer wants to test, I filled in my customers url instead). Though I'm not sure if that step was really necessary.
    It may take some minutes before Twitter responds positively on reauthorizing.
    The PHP-fix by atorreno also didn't work for me, so don't forget to restore the code to the original state if that didn't help!
    Thanks for leading me in the right direction, guys!

  26. sbroways
    Member
    Posted 1 year ago #

    I used the edits explained here:
    http://wordpress.org/support/topic/plugin-twitter-widget-pro-no-tweets-available

    The issue was with the api url being https instead of http. Once I changed that, the redirect worked immediately.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.