WordPress.org

Ready to get started?Download WordPress

Forums

oAuth Twitter Feed for Developers
Authorization Error (5 posts)

  1. dannywilson
    Member
    Posted 7 months ago #

    I updated the plugin today to the newest version (2.1.2) and I am now not receiving any tweets through, it says I have an authorization error. However it was working before the update. I'm not sure if this is an isolated incident or an easily replicated issue.
    I am using twenty thirteen theme and only have two other plugins installed; edge suite and ACF.

    Any advice you can give me would be greatly appreciated.

    Thanks,
    Danny Wilson

    http://wordpress.org/plugins/oauth-twitter-feed-for-developers/

  2. Liam Gladdy
    Member
    Plugin Contributor

    Posted 7 months ago #

    Hey Danny,

    If you're getting a message about authorization, that has to be from twitter directly, so the update shouldn't be the cause of it. Could you make sure all your keys are set correctly in the admin?

    Thanks,
    Liam

  3. dannywilson
    Member
    Posted 7 months ago #

    Hi Liam,

    thanks for the response! I have double checked all the app settings and nothing has changed they are all still active. The feed was coming through before the update so wasn't sure if some of the information wasn't being sent or maybe they've changed something. Either way I'm still getting the errors so will have to dig around a little more.

    Thanks,
    Danny

  4. dannywilson
    Member
    Posted 7 months ago #

    Hi Liam,

    I've worked it out!

    get_tweets(10);
    doesn't automatically load the username specified in the options page which it did before the update.

    Changing it to
    get_tweets('user_name', 10);
    fixed the issue.

    Just in case anyone else has this issue.

    Thanks,
    Danny

  5. Liam Gladdy
    Member
    Plugin Contributor

    Posted 7 months ago #

    Ah, dammit!

    I forgot we used to support that in the early versions!

    This is fixed in 2.1.3 - but you should still keep the new syntax!

    Thanks for your report :)

Reply

You must log in to post.

About this Plugin

About this Topic