WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Author permalink only works for admin (6 posts)

  1. Sivar
    Member
    Posted 7 years ago #

    Hello,

    I'm having a strange problem. My author permalinks lead to 404 instead of being directed to the author.php (or index.php), except for one admin. There are 2 other admins, but it doesn't work for them, either.

    Since wp_list_authors() and the_author_posts_link() output the permalinks, I really need to get them to work. I looked up "Using Permalinks", but don't have a clue as to how (or if) the .htaccess has to be modified. Or can my problem be solved using options->permalinks in the admin panel? Right now, it's set to create permalinks based on date and postname (and hasn't been changed recently).

    However, the default query strings (like /?author_name=x) work, but then the loop in author.php won't output any of the author's posts.

    I know, there are several (unresolved) threads with a similar question/problem, but please help me on this... THX! :)

    Links:
    http://hidden-area.de/author/admin/ -> author.php
    http://hidden-area.de/author/doedel/ -> 404.php
    http://hidden-area.de/?author_name=doedel -> author.php, but without posts being displayed

  2. Sivar
    Member
    Posted 7 years ago #

    Update:
    It's getting even stranger (from my newbie point of view, that is *g*)... now the link above /author/doedel works, as well as SOME other permanent links for authors do.

    Some examples (everyone of them has at least one posting):
    http://hidden-area.de/author/feli-c/ (admin) -> author.php
    http://hidden-area.de/author/doedel/ (user) -> author.php
    http://hidden-area.de/author/orion/ (user) -> 404.php
    http://hidden-area.de/author/basti-jansen/ (user) -> 404.php

    All I did was to play (deactivate/activate) with some plugins and to mess around with the .htaccess. But I reverted everything I changed to as it was before my first post here, I swear! The only difference is, that some more author permalinks work now.

    Any ideas? THX in advance!

  3. Sivar
    Member
    Posted 7 years ago #

    I don't want to be annoying, but I'm starting to wonder, if the solution to my problem is so simple and obvious, that noone would bother to answer... please? :)

  4. moshu
    Member
    Posted 7 years ago #

    Not so obvious. Most helpers here are "lonely bloggers" - so they never bothered to look into this multi-author issue. Sorry.

  5. Sivar
    Member
    Posted 7 years ago #

    Thx for your reply... that's understandable.... though I'm not sure if my problem just occurs with many users, so it might not be a multi-author issue. I suspect, some plugin might have "disturbed" the usual rewrite-rules (in connection with permalinks set to date and name perhaps?).

    Since wordpress uses internal rewrite rules, plugins should at least have the possibility to do that, but somehow I doubt, deactivating the plugin (if one is the cause for this misbehaviour) would also reset the rewrite rules to as they were before. Does someone have experience with that?

  6. Sivar
    Member
    Posted 7 years ago #

    Just for other people with the same nasty problem... I have a solution... well, kind of.

    It was indeed a plugin which caused all my trouble: Sideblog Plugin 3.8. When I deactivated it, I had access to all of my author pages/archives using the author permalinks like /author/%author%/. When I reactivated it, the links miraculously still worked, but just until I created new category-sideblogs with it. So my solution is to get rid of that plugin :).

    Of course, some sidebars are going to be quite empty soon (until I have an idea how to fill the extra space) *g*...

Topic Closed

This topic has been closed to new replies.

About this Topic