WordPress.org

Ready to get started?Download WordPress

Forums

Author Not Correct (31 posts)

  1. Uzma
    Member
    Posted 5 years ago #

    Hello,
    Here: http://saanamsmind.com when I (admin) make a post it says "Author: Saanj" when it's really me and not Saanj. I'm logged in as admin but it still says Saanj's name as the author when I post. Can someone tell me why that's happening?

    Thanks a bunch!

  2. hotkee
    Member
    Posted 5 years ago #

    Check your user settings in Admin->Users, probably your nickname is set to Saanj or something.

  3. Anonymous
    Unregistered
    Posted 5 years ago #

    I have exactly the same problem.
    My username doesn't appear when writing a new post/article in the dropdown. I had to "downgrade" the other two admins to have my username appear on who has written the post. My Nickname isn't set to any other name though, I checked after finding your post, hotkee.

    Other option is to edit the database myself to have it show the correct author.

    I don't know if it's caused by any plugins I'm using, but I disabled ALL and I still have the problem.. even switched back to English thinking the german language file might have to do something with it, but nada.

    Any ideas would be greatly appreciated, because it's a bit weird to write a post and someone else' name appears *grin*

    thanks!
    Nicole

  4. hotkee
    Member
    Posted 5 years ago #

    I would not recommend downgrading.

    What exactly does appear under the Settings->Users

    and what appears in the post when it is published?

    What exactly is the conflict?

  5. Anonymous
    Unregistered
    Posted 5 years ago #

    Thanks for answering, hotkey :)!

    What exactly does appear under the Settings->Users

    When I click on settings, I have no options for users.... but when I click on users directly (Settings | Plugins | Users) I see a list of my 3 administrators, no other users yet as the site isn't open yet for our other friends. I'm the admin with user ID 1.

    and what appears in the post when it is published?

    The Post I wrote and it says
    Gepostet am July 14th, 2008 von Aresaran <- Note: my username is Nicole on my blog ;)

    What exactly is the conflict?

    I write a new site/article. There is an option called "Post Author" as dropdown menu where I can choose the authors. But only 2 authors appear in the dropdown menu, Aresaran and my other friend's name. My username is not listed in the dropdown menu. When I publish the page/post, it's not written by me but by Aresaran, because the name is selected. When I edit it, I can't choose my own name as well.
    I can only change the "written by: Aresaran" by removing the rights from my 2 friends, then no dropdown appears, or I go and open the database and change the post_author directly in the wp_posts table to post_author id 1.

    It's like the admin is invisible or something...

    *edited to add: checked with different browsers, all the same as well. PHP and MySQL from my host meet the requirements as well.*

    thanks again,
    Nicole

  6. hotkee
    Member
    Posted 5 years ago #

    Ok well you said you had downgraded so I assume you have not got 2.5.1

    Check your Users screen again, edit your own details, there must be something in your options which reads "von Aresaran" - probably ur nickname.

  7. Anonymous
    Unregistered
    Posted 5 years ago #

    Sorry for the confusing, didn't downgrad at all, this is a wp 2.5.1. What I meant was I had been downgrading the other 2 users from admin to normal user ;).
    Wordpress is up to date as all plugins are too. "von" is german and stands for "by". Aresaran is the other admin.

    I have made 2 screenshots, maybe this is better *g*

    http://anor-en-templa.de/wpusers.gif - where you can see the only 3 existing users

    http://anor-en-templa.de/myprof.gif - my userprofile

    http://anor-en-templa.de/probwp.gif - where you can see the dropdown menu, admin/Nicole isn't listed there. Which means I can't tell WP that I want to have my name as Author, it's always either Aresaran by default or Irimaelen. I can only change it to Nicole by editing the database.

    Btw, I have just been informed by Irimaelen, to her it doesn't happen, nor Aresaran. When she is making a new article her name is set correctly right away. So it's only happening to me, the admin.

    Thanks for helping though :),
    Nicole

  8. Anonymous
    Unregistered
    Posted 5 years ago #

    I don't know if it's me, but I can't see my own last posting. In case it got it eaten up I'll post again, if it turns up twice, I'm sorry.

    Hotkee,
    I'm truly sorry for confusing you, I had to "downgrade" the 2 admins to normal users to be able to post under my username. WP is up to date, it's a 2.5.1 install and all plugins are up to date as well.

    I have made 3 screenshots, this surely explains it a bit better :)

    Here is my user profile - no matter if I change the name or Nickname, it doesn't solve my problem

    these are the users the only 3 and all are admins

    this is the problem - my username doesn't show up here at all

    I just heard from my other friends that they don't have these problems. When logging in and attempting to write an article/page, their username is choosen correctly, so it's only happening to me.

    Thanks for helping :),
    Nicole

  9. recordinghacks
    Member
    Posted 5 years ago #

    My WordPress installation has the same problem. I had been using the admin account for posting. I set up a 'flickr' account to test posting via Flickr.com, and this worked fine, but when logged in as 'admin' I was not able to change the author of the items posted from Flickr. The admin account did not appear in the "post author" pulldown menu.

    Tonight I renamed the admin user (via SQL, directly in the database), and this made the problem worse. As described above, now every post I create is attributed to the Flickr user.

    There is *no* overlap in name or nickname here.

    The problem appears to be in the wp_usermeta table. At least in my case, user_id 1 (the former admin user) has no row for meta-key='wp_user_level'.

    The code that draws the Post Author pull-down calls a function get_editable_user_ids(), which runs this query:
    SELECT user_id FROM wp_usermeta WHERE meta_key = 'wp_user_level' AND meta_value != '0'

    My user ID does not appear in the results set, because it has no wp_user_level row.

    Probably the only fix is for me to create a new admin user and migrate all my posts to it, and simply abandon the current admin user. What a pain.

    Theoretically I could add a row for user_id 1 to give it a wp_user_level in this table, but I don't know what appropriate values for the rest of the columns are.

  10. recordinghacks
    Member
    Posted 5 years ago #

    Well, I must be getting tired. The query is actually simple, so I've just tried it:
    insert into wp_usermeta values (null, 1, 'wp_user_level', 10);

    This creates the missing 'wp_user_level' row for the admin user (user_id 1).

    This definitely fixes the immediate problem of the admin user not appearing the Post Author drop-down. Whether it has long-term consequences is another question.

  11. simontol
    Member
    Posted 5 years ago #

    Confirmed here.
    recordinghacks' fix seems to solve the problem for me.

  12. brownmp
    Member
    Posted 5 years ago #

    I had exactly the same problem after I added a new user. There must be something about the admin user that doesn't create that row. The sql insert worked perfectly. (It must have something to do with the Admin being able to choose anyone at that author line. While authors will only see themsleves.

    Anyway, thanks for the spot on comments.

  13. jtpratt
    Member
    Posted 5 years ago #

    Yep, I had the EXACT same problem on my WP 2.6 blog. As soon as I used recordinghack's fix - all is well now and "admin" appears in the dropdown names for "page authors".

    This is definitely a WordPress bug and should be reported!

  14. omgitztrey
    Member
    Posted 5 years ago #

    Did the fix quoted above and it worked for me too.

  15. creativepart
    Member
    Posted 5 years ago #

    I had the exact same problem and this fixed it for me as well.

    Thanks.
    PS. Has anyone posted this bug?

  16. brianjames
    Member
    Posted 5 years ago #

    Where do we make this edit? Or where do I find wp_usermeta?

  17. omgitztrey
    Member
    Posted 5 years ago #

    You do thing from a sql command either through mysql administrator, phpmyadmin (or whatever it's called).

  18. brianjames
    Member
    Posted 5 years ago #

    what file am i editing though?

  19. omgitztrey
    Member
    Posted 5 years ago #

    You're not editing any specific files. You're running a command to insert some text into the database

    insert into wp_usermeta values (null, 1, 'wp_user_level', 10);

  20. brianjames
    Member
    Posted 5 years ago #

    Ran the command but it didn't fix the problem... below is the query:

    INSERT INTO db41285_wordpress.wp_usermeta (
    umeta_id ,
    user_id ,
    meta_key ,
    meta_value
    )
    VALUES (
    NULL , '0', NULL , '(null, 1, ''wp_user_level'', 10);'
    );

    Did I do this right?

  21. Ripose
    Member
    Posted 5 years ago #

    Actually this "Fix" is completely unnecessary.

    In your users menu is the name you wish to publish under classified as an Author or higher? Does the Name Field have an entry? the Nickname? the Username (which you can't change)? Are they all the same/different?

    USERS MAIN SCREEN (example)
    Username: Ripose (registered username)
    Name: Ripose (displayed under Name on Users screen)
    E-mail: ripose@mymail.com (the Registered e-mail address)
    Role: Author (must be author or above)
    Posts: 2 (number of posts written by this person)

    CLICK on Username > Click on Role > Select Author
    Enter ALL names in the RIGHT places
    Click on Update User
    Click on Display Name Publicly As
    Select the appropriate name
    Click on Update User

    Also whatever name you login with will be the default Author.
    But the name that is displayed can be different from the author/username/nickname depending on the names you entered above.

    Yeah I know, I gotta get my screen capture working.

    Have a great day!

  22. neil456
    Member
    Posted 5 years ago #

    I had the same problem that was fixed by recordinghacks suggested SQL. No amount of editing data through WordPress would fix the problem.

  23. onegame
    Member
    Posted 5 years ago #

    Thanks for the posts. I'm using 2.61 and I also ran into this problem after set up the flickr blog.

    I've since logged onto phpMYadmin and confirmed that there was no user level defined for the admin id 1 so I tried to add it using

    wp_usermeta values (null, 1, 'wp_user_level', 10);

    but when I use the command in manager I get an error saying, "You probably tried to upload too large file. Please refer to documentation for ways to workaround this limit."

    Any ideas am I using the wrong synatx?

    I tried using phpmyadmin's GUI 'insert' option but I can't add the line that way either because it proxies through my hosts server and not directly with my db.

    I don't have access to sql server so I can't access the tables directly any ideas?

  24. onegame
    Member
    Posted 5 years ago #

    ok, figured it out. I was able to resolve the 3rd party hosting phpmyadmin proxy issue and access my tables directly by downloading this WP-Plugin.

    I wasn't sure it was going to work with 2.61 since it stats that its only supported up version 2.1 but it ended working like a charm.

    Thanks again for recordinghacks and everyone for the post.

  25. robllewellynuk
    Member
    Posted 5 years ago #

    I'm on wordpress 2.6.2, added in a new user at Author level and lost the admin account in the drop down.

    Applied sql fix above and it has successfully fixed the issue for me. For now.

    Has anyone recorded this as a bug?

  26. onegame
    Member
    Posted 5 years ago #

    Definitely a bug. I recently upgraded to 2.6.2 and I encountered the same problem again. The SQL fix above worked again.

  27. cowboyecosse
    Member
    Posted 5 years ago #

    Thanks for this. I was having the same issue which was driving me mental. The SQL fix worked like a charm!

  28. ntharp
    Member
    Posted 5 years ago #

    I won't say that this "Fix" is "completely unnecessary", but I do think that I found another workaround for this issue. I have WordPress 2.7 installed on a GoDaddy hosting account (installed by GoDaddy's one-click install service) and I'm not completely comfortable running database commands.

    I had been creating pages without incident using the original admin (1) account that has Administrator level access. Once I created three additional accounts (2) with Editor level access, I no longer had the ability to create or edit a page so that the author of the page was the admin (1) user.

    I checked to make sure that the users did not have any duplicate profile information, aside from them all having the same Website.

    To fix this, while logged in as the admin (1) user, I changed one of the editor accounts (2) to give it Administrator level access.

    I then logged in on another browser as the editor (2). Next I changed the admin (1) account to just Editor level access (press the Update Profile button) and then changed the admin (1) account back to Administrator level access.

    I was now able to change the author of any page to the admin (1) user. The last step I had to take was to login as the admin (1) user and change the editor (2) account back to Editor level access.

    I think this is confusing so hopefully the (1) and (2)s will help make it clear which user profile I'm referring to.

    I have reported this as a bug, since it didn't appear that anyone else had.

  29. pkoury
    Member
    Posted 5 years ago #

    Thanks "recordinghacks"

    Worked like a charm.

  30. c0mrade
    Member
    Posted 5 years ago #

    I have the same problem, one thing i'll add is that when you login as admin and do a quick post instead of using "add new" the post, wp gets the correct author.

Topic Closed

This topic has been closed to new replies.

About this Topic