WordPress.org

Ready to get started?Download WordPress

Forums

Author Archive 404 (17 posts)

  1. Stefanie
    Member
    Posted 6 years ago #

    Here is the code I have:

    All Posts by <?php the_author_posts_link('namefl'); ?>

    It shows the author name correctly, and it's linking to the author page, supposedly (/author/username), but when I click the link, I get a 404. Is it because I have a space in my username and permalinks set to load the name (vs. ?author=1, for example)? I don't see why this should be causing a problem...

  2. Stefanie
    Member
    Posted 6 years ago #

    Anyone? Is anyone ever going to help me out on this forum?

  3. vijayrajesh
    Member
    Posted 6 years ago #

    I am having the same problem with my site. Anyone to help on it?

  4. Stefanie
    Member
    Posted 6 years ago #

    Of course not. Why would anyone ever help anyone on a support forum? Ludicrous.

  5. riquard
    Member
    Posted 6 years ago #

    I'm having the same problem. There is only one author that works, the rest of the authors give an 404 page.

    Spaces or no spaces in the name don't matter.
    I deleted authors, made new ones, but that didn't help. (although it did work for another user, check: http://wprocks.com/forums/comments.php?DiscussionID=762)
    I tested it with the standard permalink structure( /?author=1): didn't work.

    For another user with this problem it helped getting rid of sideblog plugin 3.8 see:
    http://wordpress.org/support/topic/123433?replies=6

    I don't have plugins activated and only author 2 is working.

  6. riquard
    Member
    Posted 6 years ago #

    Sorry, I didn't pay attention, I have the problem with wordpress 2.5.1 not 2.3.3

  7. riquard
    Member
    Posted 6 years ago #

    Ok, here is something that might help (at least it did for me, working with for wp 2.5.1)

    This is the situation:

    /author/riquard/ gives a 404 page

    /?author=6 or /index.php?author=6 does get redirected to /author/riquard/ and gives a 404 page

    (/?author_name=riquard isn't being redirected to /author/riquard/ and does work)

    After trying a lot of things, I figured out that the author needs to have a post in his name and it has to be a post, not a page! authors with no posts get a 404..

    I am going to leave it like this for now, but the thread about showing all users (not just authors) you can find here:
    http://wordpress.org/support/topic/181170

  8. Stefanie
    Member
    Posted 6 years ago #

    The author I am testing with has quite a few posts, and still the 404. I did try as you said worked, /?author_name=authorname, which didn't return a 404, but redirected only to the front page of the website.

  9. Stefanie
    Member
    Posted 6 years ago #

    So with the thought that it might be some sort of plugin interference, I deactivated each plugin one by one and kept checking, continuously getting the 404. I updated each plugin that had updates, still getting the 404. I created a new administrator with a one word name, wrote a test post, and tried loading the test admin's author page, still getting the 404.

    I'm about to rip my hair out and I am very dissatisfied with WordPress right now, and the lack of help (except for riquard's attempt, which I thank you for) is not making me feel much better.

  10. riquard
    Member
    Posted 6 years ago #

    From another thread, moshu explains why there is not much help: "Most helpers here are "lonely bloggers" - so they never bothered to look into this multi-author issue."

    One more thing: Did you try to disable all plugins at the same time? Maybe two or more are giving trouble..

    Else I would try to setup an empty blog and try it from there, so you know whether it's a problem in your setup or a problem with your wordpress version.

    Then I guess someone who can read the wordpress core, can understand what wordpress is doing when it tries to fetch the author page and could help you. or if the problem is in your setup you can one by one add your stuff to see when the problem starts occuring.. I know, not the answer you are hoping for.. sorry for that :)

  11. Stefanie
    Member
    Posted 6 years ago #

    I was trying to avoid deactivating all the plugins, but I decided to give it a shot... no help. Still getting the 404...

    By setting up an empty blog, do you mean another fresh install on the same domain?

  12. riquard
    Member
    Posted 6 years ago #

    Yes, that's what I mean.

    I don't think the domain matters much though, but I think it could matter to use the same host. so I suggest a fresh install on a subdomain if you can do that.

    Just so you know.. I don't know the code of wordpress myself.. I only suggest you narrow down the problem area, so it is more likely that someone can help you or that you will find threads about the problem.

  13. Stefanie
    Member
    Posted 5 years ago #

    So I FINALLY got around to installing an empty blog on the same domain to test this issue. I set the permalinks the same way I have them on the main site, and the author page works fine.

    Now I know it's an issue with my install or something, but it's making no sense. I uninstalled WP on my main site and reinstalled everything fresh with a backup of the database, and am still having the problem.

  14. Stefanie
    Member
    Posted 5 years ago #

    It's something to do with permalinks. If I change to default permalinks, the author archive loads fine, but with my custom permalinks ( /%postname%/ ), it won't load. This doesn't make sense to me, as the custom permalinks works fine on the test blog.

    EDIT >> So I edited my user_nicename under wp_users to a username with no space, and the author archive works again. That shouldn't have been a problem. Any idea why it was?

  15. angelic007
    Member
    Posted 5 years ago #

    I'm having problems with author pages since version 2.1 ...
    Very annoying issue, can't fix it.

    I also tried user_nicename directly on DB, some of them were fixed, but not all of them.

    I still have problems with authors having more than 1 regular post and no spaces in the nickname.

    I'm quite satisfied of WordPress, but this is REALLY an obnoxious problem mainly because it's difficult to debug. Even on my local WP install I wasn't able to figure it out.

  16. powtac
    Member
    Posted 5 years ago #

    Hi riquard,
    I created a plugin which prevents the 404 at the authors page when no posts where written by this author:

    http://wordpress.org/extend/plugins/show-authors-without-posts/

    Can you please test if it works also for your installation? For me it fixed the problem with the 404s.

  17. aptdesignonline
    Member
    Posted 5 years ago #

    I was having this problem too, with an author that had posts. The name originally was created with spaces in it.

    I edited the user_nicename using this tutorial and it works now!

Topic Closed

This topic has been closed to new replies.

About this Topic