WordPress.org

Ready to get started?Download WordPress

Forums

AuthImage - Warning: Unknown modifier (37 posts)

  1. davincim
    Member
    Posted 9 years ago #

    I've been trying to install "AuthImage". After making the adjustments as instructed, I decided to add a comment to my blog for testing purposes to see how it worked. Once I submitted it, I go this in the next window:

    "Warning: Unknown modifier 'b' in /hsphere/local/home/galen5/familywebwatch.com/blog/wp-content/plugins/blacklist.php on line 188

    Warning: Unknown modifier 'b' in /hsphere/local/home/galen5/familywebwatch.com/blog/wp-content/plugins/blacklist.php on line 196

    Warning: Unknown modifier 'b' in /hsphere/local/home/galen5/familywebwatch.com/blog/wp-content/plugins/blacklist.php on line 204

    Warning: Unknown modifier 'a' in /hsphere/local/home/galen5/familywebwatch.com/blog/wp-content/plugins/blacklist.php on line 188........and lots more"

    It also said at the bottom of this list, "Cannot modify header information - headers..."

    I hadn't tested sending a comment in a while and since I had made updates to SpamKarma and Blacklist, so I replaced the the files I modified to the ones I had before. Still got the same error messages.

    Now, even though I replaced the modified files per AuthImage's instructions, I didn't deactivate it, which may be part of the issue.

    One more thing about this AuthImage plugin: it said to upload all the files into my plugins directory. I did, but when I went to my Plugins panel, there were THREE plugins for it including one that was blank -- just an "Activate" in the far right hand column.

    Anybody know what's going on with this?

  2. davincim
    Member
    Posted 9 years ago #

    Maybe it would help if I gave you my blog address: http://www.familywebwatch.com/blog

  3. Replace the modified files, but deactivate the plugins first this time. As for proper AuthImage installation, read the instructions that came with the package.

  4. davincim
    Member
    Posted 9 years ago #

    Thanks for the prompt response, macmanx!

    It's probably not apparent, but I did read the instructions. In fact, I found the instructions somewhat lacking as there was no reference to the fact there would be three plug-ins in the plug-in panel, nor did it say there would be one blank one. And from my interpretation, it seems that not all the files are necessary, like the authimage-alt.php file. So my faith in the instructions was slightly affected by all of that, hence my coming here.

    However, I will deactivate it this time and re-do.

  5. By "read the instructions that came with the package", I meant: http://dev.wp-plugins.org/file/authimage/trunk/README.txt

  6. marzar00
    Member
    Posted 9 years ago #

    Form what I can see the blacklist thingy seems to be the problem

  7. Mark (podz)
    Support Maven
    Posted 9 years ago #

    It's a blank line or a single character on the blacklist of words.

  8. davincim
    Member
    Posted 9 years ago #

    macmanx,

    yes that's the file I was referring to as well. If the answer is in there, then perhaps it revolves around the GDlib as a requirement. I don't understand the part about how to check it on my server. If you could explain that part or know where I need to go to get that explanation, it would be most helpful. :)

    marzaroo and pods,

    I exported my blacklist to make sure I had the latest information, I did find a blank line at the end of the list and removed it. I imported it back, but still got the same error message. In the past I have made changes to files that affect WP and they didn't work immediately, only when a little more time had passed. did they work, so maybe this is one of those times. But just in case, if it wasn't that blank line, what other special characters should I look for?

    Thanks everyone!!!

  9. davincim
    Member
    Posted 9 years ago #

    macmanx,
    "...If you could explain that part or know where I need to go to get that explanation, it would be most helpful. :)"

    marzaroo and podz,
    "...But just in case, if it wasn't that blank line, what other special characters should I look for?"

    Sorry everyone, but I wanted to bump this one up to see if I could get a response to the two items posted above.

  10. Joshua Sigar
    Member
    Posted 9 years ago #

    Would you post those offending lines on the following site

    http://paste.uni.cc/

  11. davincim
    Member
    Posted 9 years ago #

    That's a cool service, alphaoide. Thanks for the reply. :)

    Here's the linkk to the error messages: http://paste.uni.cc/6635

  12. Joshua Sigar
    Member
    Posted 9 years ago #

    *Not* the error message that I want.
    I want the blacklist.php

  13. davincim
    Member
    Posted 9 years ago #

    Oh, sorry about that. When I went back to paste the list, it told me to "Go away!" That's no joke, that's what it said.

    However, try this: http://www.familywebwatch.com/blog/blacklist.txt

  14. davincim
    Member
    Posted 9 years ago #

    And btw, I assumed you were asking for the text file because there is no blacklist.php file.

  15. Joshua Sigar
    Member
    Posted 9 years ago #

    No blacklist.php? That is weird. The error messages refer to that php file in plugins folder. Otherwise, I don't see anything obvious right now.

  16. If you don't have a blacklist.php file at familywebwatch.com/blog/wp-content/plugins/blacklist.php, then you shouldn't be seeing those errors.

  17. davincim
    Member
    Posted 9 years ago #

    This just isn't my day. I only looked at the blog directory and no further. When the text file was all that I saw, I figured that's what you meant.

    Now that the path has been outlined, I found the file you're looking for and posted here: http://paste.uni.cc/6636

    Sorry for the confusion and thanks for your patience.

  18. Joshua Sigar
    Member
    Posted 9 years ago #

    I gotta go to my classes, if you're expecting my reply.I will look into it later, if nobody has solved it.

    Good luck.

  19. davincim
    Member
    Posted 9 years ago #

    Okay, unless someone else solves it, I look forward to your response when you have no class. LOL!

    ( Sorry, I couldn't resist a little Rodney Daingerfield humor. :) )

    Thanks for your help thus far. You too macmanx!

  20. Joshua Sigar
    Member
    Posted 9 years ago #

    I guess I'm not good at regex. Can't see anything wrong with the blacklist.php. However, blacklist.php is used by another plugin (blacklist plugin?) and not AuthImage, is it not?

    Try deactivating blacklist plugin first, then active AuthImage. They might not work together.

  21. davincim
    Member
    Posted 9 years ago #

    Good call. I'll give it a try.

  22. davincim
    Member
    Posted 9 years ago #

    alphaoide,

    I think you may be onto something. I deactivated "blacklist" and reactivated "authimage". I didn't get the error messages, but I did get the index.php to display unexpectedly in the comments pop-up window.

    Huh?

    And to further confuse matters, my test comments are not waiting to be moderated, just posted automatically. That was screwy even before I did all this stuff with blacklist and authimage. Any ideas on that one?

  23. Joshua Sigar
    Member
    Posted 9 years ago #

    You mean when you click on comment link, a window pops up which contains index.php and the comments? If so, do the following

    1. Backup the current wp-comments-post.php and replace with the original/default wp-comments-post.php
    2. When you click on comment link, you should now get only the comments, without the index.php
    3. To not display comments in pop up window, refer to documentation.

    Okay, now the moderation process, itself
    1. If you want to moderate *all* comments, there's a setting for that in admin panel somewhere.
    But since you're gonna use AuthImage, you don't need to moderate any comments.

    2. Now, re-do the instruction for setting up AuthImage.

  24. davincim
    Member
    Posted 9 years ago #

    No, actually, when I click on "comments" the pop-up comes up. It's normal to that point. Once I enter the code from authimage and the other fields, that's when I get the index.php page to show up in the small window.

    Try it, please, and see if it does the same thing for you: http://familywebwatch.com/blog/

  25. davincim
    Member
    Posted 9 years ago #

    I got to thinking, is it possible that authimage is overriding the moderation? I mean, if the code is entered correctly, is it just ignoring the moderation checkbox in WP? But WP doesn't acknowledge that and notifies me anyway since I told it to?

    Confusing, but I feel we're honing in on the solution. :)

    I'll catch up with you tomorrow. Thanks for your help today.

  26. Joshua Sigar
    Member
    Posted 9 years ago #

    Can't test it 'cause my comment keeps on trashed by SpamKarma plugin?

    The following could be the fix for the index on pop up

    In bottom portion of your wp-comments-post.php find

    $location = get_permalink($comment_post_ID);

    replace with the following

    $location = (empty($_POST['redirect_to'])) ? $_SERVER["HTTP_REFERER"] : $_POST['redirect_to'];

  27. Joshua Sigar
    Member
    Posted 9 years ago #

    Anyhow if both of my comments were really rejected by SpamKarma plugin, did you get the log as to why they were rejected?

    I didn't put anything suspicious really, so the spam plugin was kinda aggresive. I don't like it.

  28. davincim
    Member
    Posted 9 years ago #

    I'm looking at the control panel for SpamKarma, and I see your IP banned and "wordpress.org" recently added to the blacklist. How the heck did that happen? Wasn't me, I swear!

    I'll implement your modification, but I have two questions:

    1) is wp-comments-post.php the only file that needs that change, or does it need to go into wp-comments-popup.php and wp-comments.php?

    2) I have made changes to the comments-related files before, but honestly I don't remember under what circumstances (a lot of stuff going on my world :) ). So is the change you're suggesting something that should have been there from the very start? It's not that I mind making the change, I'm just trying to figure this stuff out.

    As always, thanks for your help. :)

  29. davincim
    Member
    Posted 9 years ago #

    Okay, so I replaced the code as you instructed. For a minute there I thought something weird was going on when I clicked on "comments" because it would display the comments pop-up window. I clicked it again (after closing the window) and it worked. My comment was posted without a problem and it showed the comments instead of the index.php.

    BUT for grins I entered another comment, this time WITHOUT entering the code authimage displayed and it didn't challenge me--just posted the comment. Regarding this latest discovery, if I'm going outside of the confines of the support here because this is a plugin thing, please let me know. You've been very helpful so far and I don't want to abuse your help.

    BTW, I removed the ban on your IP and wordpress.org, so if you so desire, you can try it again.

  30. davincim
    Member
    Posted 9 years ago #

    alphaoide,

    I re-read my last post and thought the first part was a little confusing. It should have read:

    "Okay, so I replaced the code as you instructed. For a minute there I thought something weird was going on when I clicked on "comments" because it would NOT display the contents in the comments pop-up window. It would display just the window."

    Everything after that is fine.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.