WordPress.org

Ready to get started?Download WordPress

Forums

WP Mail SMTP
[closed] Authentication Issue (gmail smtp) (9 posts)

  1. Dustin Lammiman
    Member
    Posted 1 year ago #

    I had this plugin working great with my Google Apps email for about a week but it suddenly stopped working. Relevant errors when I try to send a test email:

    string(370) "SMTP Error: The following recipients failed: sampleemail@test.com
    SMTP server error: Please turn on SMTP Authentication in your mail client, or login to the
    550-IMAP/POP3 server before sending your message.  mydns.server.here
    550-(www.mydomain.com) [webshost.ip.here]:55411 is not permitted to relay
    550 through this server without authentication.
    SMTP -> ERROR: RCPT not accepted from server: 550-Please turn on SMTP Authentication in your mail client, or login to the
    550-IMAP/POP3 server before sending your message.  mydns.server.here
    550-(www.mydomain.com) [webshost.ip.here]:55411 is not permitted to relay
    550 through this server without authentication.

    SMTP Authentication is on in the plugin settings. Are there any particular settings I should check with my web host?

    http://wordpress.org/extend/plugins/wp-mail-smtp/

  2. inprojectcloud
    Member
    Posted 1 year ago #

    Same problem here.

    Gmail authentication is failing.

  3. srumery
    Member
    Posted 1 year ago #

    Dustin and inprojectcloud, are you using two-step authentication for your email system. Is so, you will need to get an application password otherwise, it won't work.

    Run a test email from the settings page and copy the result output here. I might be able to help out.

  4. inprojectcloud
    Member
    Posted 1 year ago #

    Hi!

    I'm not using two step authentication. This is the output:

    Test Message Sent

    The result was:

    bool(true)
    The full debugging output is shown below:

    object(PHPMailer)#1932 (58) {
    ["Priority"]=>
    int(3)
    ["CharSet"]=>
    string(5) "UTF-8"
    ["ContentType"]=>
    string(10) "text/plain"
    ["Encoding"]=>
    string(4) "8bit"
    ["ErrorInfo"]=>
    string(359) "SMTP Error: The following recipients failed: chetantripathy@gmail.com
    SMTP server error: Please turn on SMTP Authentication in your mail client, or login to the
    550-IMAP/POP3 server before sending your message. sin1.hostdime.in
    550-(projectcloud.info) [66.7.210.114]:26418 is not permitted to relay through
    550 this server without authentication.

    "
    ["From"]=>
    string(22) "yoda@projectcloud.info"
    ["FromName"]=>
    string(15) "Chetan Tripathy"
    ["Sender"]=>
    string(0) ""
    ["Subject"]=>
    string(51) "WP Mail SMTP: Test mail to chetantripathy@gmail.com"
    ["Body"]=>
    string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
    ["AltBody"]=>
    string(0) ""
    ["MIMEBody":protected]=>
    string(69) "This is a test email generated by the WP Mail SMTP WordPress plugin.
    "
    ["MIMEHeader":protected]=>
    string(468) "Date: Tue, 11 Dec 2012 15:49:41 +0000
    Return-Path: yoda@projectcloud.info
    To: chetantripathy@gmail.com
    From: Chetan Tripathy <yoda@projectcloud.info>
    Subject: WP Mail SMTP: Test mail to chetantripathy@gmail.com
    Message-ID: <7390d859c3d5df2de13d5743d@projectcloud.info<455aff2>
    X-Priority: 3
    X-Mailer: PHPMailer 5.2.1 (http://code.google.com/a/apache-extras.org/p/phpmailer/)
    MIME-Version: 1.0
    Content-Transfer-Encoding: 8bit
    Content-Type: text/plain; charset="UTF-8"

    "
    ["SentMIMEMessage":protected]=>
    string(541) "Date: Tue, 11 Dec 2012 15:49:41 +0000
    Return-Path: yoda@projectcloud.info
    To: chetantripathy@gmail.com
    From: Chetan Tripathy <yoda@projectcloud.info>
    Subject: WP Mail SMTP: Test mail to chetantripathy@gmail.com
    Message-ID: <455aff27390d859c3d5df2de13d5743d@projectcloud.info>
    X-Priority: 3
    X-Mailer: PHPMailer 5.2.1 (http://code.google.com/a/apache-extras.org/p/phpmailer/)
    MIME-Version: 1.0
    Content-Transfer-Encoding: 8bit
    Content-Type: text/plain; charset="UTF-8"

    This is a test email generated by the WP Mail SMTP WordPress plugin.
    "
    ["WordWrap"]=>
    int(0)
    ["Mailer"]=>
    string(4) "smtp"
    ["Sendmail"]=>
    string(18) "/usr/sbin/sendmail"
    ["PluginDir"]=>
    string(0) ""
    ["ConfirmReadingTo"]=>
    string(0) ""
    ["Hostname"]=>
    string(0) ""
    ["MessageID"]=>
    string(0) ""
    ["Host"]=>
    string(14) "smtp.gmail.com"
    ["Port"]=>
    string(3) "465"
    ["Helo"]=>
    string(0) ""
    ["SMTPSecure"]=>
    string(3) "ssl"
    ["SMTPAuth"]=>
    bool(true)
    ["Username"]=>
    string(22) "yoda@projectcloud.info"
    ["Password"]=>
    string(11) "The Password"
    ["Timeout"]=>
    int(10)
    ["SMTPDebug"]=>
    int(2)
    ["SMTPKeepAlive"]=>
    bool(false)
    ["SingleTo"]=>
    bool(false)
    ["SingleToArray"]=>
    array(0) {
    }
    ["LE"]=>
    string(1) "
    "
    ["DKIM_selector"]=>
    string(9) "phpmailer"
    ["DKIM_identity"]=>
    string(0) ""
    ["DKIM_passphrase"]=>
    string(0) ""
    ["DKIM_domain"]=>
    string(0) ""
    ["DKIM_private"]=>
    string(0) ""
    ["action_function"]=>
    string(0) ""
    ["Version"]=>
    string(5) "5.2.1"
    ["XMailer"]=>
    string(0) ""
    ["smtp":protected]=>
    object(SMTP)#1931 (8) {
    ["SMTP_PORT"]=>
    int(25)
    ["CRLF"]=>
    string(2) "
    "
    ["do_debug"]=>
    int(2)
    ["do_verp"]=>
    bool(false)
    ["Version"]=>
    string(5) "5.2.1"
    ["smtp_conn":"SMTP":private]=>
    resource(555) of type (stream)
    ["error":"SMTP":private]=>
    array(3) {
    ["error"]=>
    string(29) "RCPT not accepted from server"
    ["smtp_code"]=>
    string(3) "550"
    ["smtp_msg"]=>
    string(263) "Please turn on SMTP Authentication in your mail client, or login to the
    550-IMAP/POP3 server before sending your message. sin1.hostdime.in
    550-(projectcloud.info) [66.7.210.114]:26418 is not permitted to relay through
    550 this server without authentication.
    "
    }
    ["helo_rply":"SMTP":private]=>
    string(141) "250-sin1.hostdime.in Hello sin1.hostdime.in [66.7.210.114]
    250-SIZE 52428800
    250-8BITMIME
    250-PIPELINING
    250-AUTH PLAIN LOGIN
    250 HELP
    "
    }
    ["to":protected]=>
    array(1) {
    [0]=>
    array(2) {
    [0]=>
    string(24) "chetantripathy@gmail.com"
    [1]=>
    string(0) ""
    }
    }
    ["cc":protected]=>
    array(0) {
    }
    ["bcc":protected]=>
    array(0) {
    }
    ["ReplyTo":protected]=>
    array(0) {
    }
    ["all_recipients":protected]=>
    array(1) {
    ["chetantripathy@gmail.com"]=>
    bool(true)
    }
    ["attachment":protected]=>
    array(0) {
    }
    ["CustomHeader":protected]=>
    array(0) {
    }
    ["message_type":protected]=>
    string(5) "plain"
    ["boundary":protected]=>
    array(3) {
    [1]=>
    string(35) "b1_455aff27390d859c3d5df2de13d5743d"
    [2]=>
    string(35) "b2_455aff27390d859c3d5df2de13d5743d"
    [3]=>
    string(35) "b3_455aff27390d859c3d5df2de13d5743d"
    }
    ["language":protected]=>
    array(17) {
    ["provide_address"]=>
    string(54) "You must provide at least one recipient email address."
    ["mailer_not_supported"]=>
    string(25) " mailer is not supported."
    ["execute"]=>
    string(19) "Could not execute: "
    ["instantiate"]=>
    string(36) "Could not instantiate mail function."
    ["authenticate"]=>
    string(35) "SMTP Error: Could not authenticate."
    ["from_failed"]=>
    string(35) "The following From address failed: "
    ["recipients_failed"]=>
    string(45) "SMTP Error: The following recipients failed: "
    ["data_not_accepted"]=>
    string(30) "SMTP Error: Data not accepted."
    ["connect_host"]=>
    string(43) "SMTP Error: Could not connect to SMTP host."
    ["file_access"]=>
    string(23) "Could not access file: "
    ["file_open"]=>
    string(33) "File Error: Could not open file: "
    ["encoding"]=>
    string(18) "Unknown encoding: "
    ["signing"]=>
    string(15) "Signing Error: "
    ["smtp_error"]=>
    string(19) "SMTP server error: "
    ["empty_message"]=>
    string(18) "Message body empty"
    ["invalid_address"]=>
    string(15) "Invalid address"
    ["variable_set"]=>
    string(30) "Cannot set or reset variable: "
    }
    ["error_count":protected]=>
    int(1)
    ["sign_cert_file":protected]=>
    string(0) ""
    ["sign_key_file":protected]=>
    string(0) ""
    ["sign_key_pass":protected]=>
    string(0) ""
    ["exceptions":protected]=>
    bool(false)
    }
    The SMTP debugging output is shown below:

    SMTP -> FROM SERVER:220-sin1.hostdime.in ESMTP Exim 4.80 #2 Tue, 11 Dec 2012 10:49:41 -0500
    220-We do not authorize the use of this system to transport unsolicited,
    220 and/or bulk e-mail.

    SMTP -> FROM SERVER: 250-sin1.hostdime.in Hello sin1.hostdime.in [66.7.210.114]
    250-SIZE 52428800
    250-8BITMIME
    250-PIPELINING
    250-AUTH PLAIN LOGIN
    250 HELP

    SMTP -> ERROR: Password not accepted from server: 535 Incorrect authentication data

    SMTP -> FROM SERVER:250 Reset OK

    SMTP -> FROM SERVER:250 OK

    SMTP -> FROM SERVER:550-Please turn on SMTP Authentication in your mail client, or login to the
    550-IMAP/POP3 server before sending your message. sin1.hostdime.in
    550-(projectcloud.info) [66.7.210.114]:26418 is not permitted to relay through
    550 this server without authentication.

    SMTP -> ERROR: RCPT not accepted from server: 550-Please turn on SMTP Authentication in your mail client, or login to the
    550-IMAP/POP3 server before sending your message. sin1.hostdime.in
    550-(projectcloud.info) [66.7.210.114]:26418 is not permitted to relay through
    550 this server without authentication.

    SMTP Error: The following recipients failed: chetantripathy@gmail.com

  5. inprojectcloud
    Member
    Posted 1 year ago #

    Also, wanted to inform you that I tried it with three different accounts. I'm suspecting an error with the server maybe. My host provider said they couldn't find anything.

    Let me know if you can throw some light. It was working perfectly until two weeks ago.

  6. shane7777
    Member
    Posted 1 year ago #

    Exact Same Issue, can anyone help?

  7. Dustin Lammiman
    Member
    Posted 1 year ago #

    I'm fairly positive this had something to do with a server. I couldn't get any external smtp server to work, but when I started using my host's smtp server everything works fine.

  8. srumery
    Member
    Posted 1 year ago #

    I thought it might be two-step authentication. That tripped me up for a few minutes before I realized what it was. Sorry, I wish I could be more helpful. A Google hangout or chat session might be the best way to tackle your issues.

    Maybe the plugin author will chime in and help.

  9. denizci88
    Member
    Posted 1 year ago #

    I have same problem. Any solutions? :(

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.