WordPress.org

Ready to get started?Download WordPress

Forums

Audio Player Not Appearing - and it used to appear (12 posts)

  1. l.comnes
    Member
    Posted 4 years ago #

    I have used Audio Player since I found it earlier this year, and I love it! Never had any problems.

    Unfortunately as of last week, the player stopped appearing on the front of my page in every internet browser/system i check. This started before and continued after my recent upgrade to WP 2.9.1. So none of my code has changed, but now my Audio player plugin is not been working. I know I have correctly used the code and plugin because it used to work fine and I have changed nothing. Any suggestions?

    Thanks!

  2. doryphores
    Member
    Posted 4 years ago #

    First, check that you have the latest version of Audio Player (2.0.4.1). Then check that your theme's footer.php file includes the wp_footer() line as explained here: http://wpaudioplayer.com/support/troubleshooting

    This is almost certainly why the players have disappeared.

    Martin

  3. NotDrugs
    Member
    Posted 4 years ago #

    Hey Martin,

    I'm having a similar problem.

    I'm using the Scarlett theme by Jinsona, on v2.9.1.

    I've checked, and the header snippet is in place. My footer.php has a disclaimer about it being illegal to alter it...and the entire file is encrypted. I tried adding the footer snippet to the bottom and top of the file. But that didn't change anything.

    I'm 90% sure it has to do with the 2.9.1 release.

    Any suggestions?

    Thanks,

    Winn
    NotDrugs.com

  4. billdancourtney
    Member
    Posted 4 years ago #

    My Audio Shows but no new files will play. Files I had on in my Audio Folder before upgrading to the new player (v. 2.0.4.1) and 2.9.1 play fine but nothing new will play. I get a file not found message. Even if I take an old file that works now and re-upload it to my audio folder it will not longer play and I get a file not found message. For now this means all previously existing audio files will play but I cannot add anything new to the site and i do a podcast. Great. I had to remove my podcasts plugins becasue of some whacky malware virus that kept finding vulnerabilities in them. The 1 Pixel Audio Player was so straight forward and simple. What is up?

    Bill

  5. doryphores
    Member
    Posted 4 years ago #

    @billdancourtney and NotDrugs:

    Can you post a URL to a page where this is happening?

    Martin

  6. NotDrugs
    Member
    Posted 4 years ago #

    Hey Martin,

    I'm at NotDrugs.com.

    Here is a direct link to a post with non-working audio players: Who's not done with 2009?

  7. doryphores
    Member
    Posted 4 years ago #

    @NotDrugs

    Looks like something is broken in your sidebar and is preventing the footer to be included. Look at your site, there is no footer. And when you look at the end of your page source, you find this php error message:

    Parse error: syntax error, unexpected $end in /home/content/j/u/n/juniorgreen85/html/wp-content/themes/scarlett/scarlett/sidebar2.php on line 10

    If you fix the sidebar problem, the players should work.

    I also noticed that your page HEAD section is messed up. Looks like your theme includes the wp_head call three times!

    Martin

  8. msdeadlines
    Member
    Posted 4 years ago #

    i experienced similar problem [2 installations of manifest theme, one with wp 2.7.1 and audio player 1.2.3 worked fine. the other with wp 2.9.2 and latest audio player 2.0.1] snippet in place both header and footer. reverted to v1.2.3 on wp 2.9.2 and worked. BUT when switched theme to default [or several others] v2.0.1 worked fine on wp 2.9.2 installation ... was testing on mac and did not confirm when it wasn't working on pc [did confirm that it was working with v1.2.3]

    wp 2.9.2 installation here

    any thoughts? :)

  9. doryphores
    Member
    Posted 4 years ago #

    @msdeadlines

    It looks like your theme is not including the footer properly. You need to make sure that your theme's templates also include this line on the last line:

    <?php get_footer(); ?>

    Theme files that should include this line: 404.php, archive.php, archives.php, images.php, index.php, links.php, page.php, search.php and single.php

    Martin

  10. devarah
    Member
    Posted 4 years ago #

    I have followed all the advice in the above posts and am still getting "file not found". Please anyone, have a look here:

    Hoping to launch in 2 days... comments appreciated :)

  11. devarah
    Member
    Posted 4 years ago #

    I found I had another podcasting plugin that was activated and conflicting with the audio player. When I deactivated it, it magically works!!!!! I found this out by switching to the default theme, and the problem still existed, which led me in another direction of thinking. Hopefully this will help someone else!

  12. Betsy
    Member
    Posted 4 years ago #

    I am using Audio Player and the embedded player was working well. I mistakenly installed Apture, and suddenly I get a message saying 'file not found', even though the custom file location is accurate. I disabled and uninstalled Apture, and disabled, deleted and then installed a fresh version of Audio Player.

    I've checked through the troubleshooting tips and everything seems fine, except this - when viewing these two files using the editor in the WP admin panel, I see (inactive) next to the filenames:
    audio-player/php/options-panel.php
    audio-player/php/check-audio-folder.php

    My site is redoingmedia.com. Any idea what's up here?

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic