WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Audio Embed Shortcode Not working with Jetpack 2.2.1 (27 posts)

  1. SARed
    Member
    Posted 1 year ago #

    I'm not sure if someone else has had the same problem, but ever since updating to Jetpack 2.2.1, All the embedded Audio on my site has stopped working.

    It either gives a blank box (Chrome) or an unknown error when played in explorer 10 or nothing happens after pressing play button in Firefox or Safari

    Is there a way to correct this please?

    My website is http://predestination.co.za

    http://wordpress.org/extend/plugins/jetpack/

  2. mattshepherd
    Member
    Posted 1 year ago #

    Audio embed shortcode displays nothing on my blog at all -- there's just a blank space where the audio player should be.

  3. SARed
    Member
    Posted 1 year ago #

    Thanks for the feedback. What browser are you using? Google chrome?

  4. latentexistence
    Member
    Posted 1 year ago #

    I am having this problem, and it's particularly frustrating because I've uploaded several topical interviews in the last day and people are struggling to access them.

    In Chrome it loads the flash player instead of the html5 player and then says "Movie not loaded..." Some people have reported this in Internet Explorer too. In Firefox on my computer I got only a download link instead of a player.

    My website is http://www.latentexistence.me.uk/ but I have dropped in a different audio player plugin for now so you won't see the problem. That seems to be flash only so it still isn't a solution though.

  5. Virendra
    Member
    Posted 1 year ago #

    I am having the same issue. I am using Chrome.

    Why I check the Chrome developer console, I saw the following file didn't exist:

    http://s0.wp.com/wp-content/plugins/audio-player/player.swf

    I think this might be an issue causing the audio player not working.

  6. SARed
    Member
    Posted 1 year ago #

    Thanks for All the feedback. Good to know my problem is not unique and that the update is causing it.

    Hopefully one of the developers can provide a fix for us as it is a critical feature of my site?

  7. renatorm
    Member
    Posted 1 year ago #

  8. SARed
    Member
    Posted 1 year ago #

    Thanks, Does that apply for WordPress sites hosted om private servers as well?

    Also I don't get a download link instead of the play button, I just get a blank space or non functioning player.

    Probably same cause though?

    I just find it strange that it happened right after updating to New Jetpack version

  9. renatorm
    Member
    Posted 1 year ago #

    I have Jetpack installed on self-hosted wordpress site and no play button, but a donwload link instead.
    Best regards,
    Illuminato

  10. SARed
    Member
    Posted 1 year ago #

    Thanks for feedback - Probably my theme that makes it appear differently

    BTW I restored my old version of Jetpack via backup and the problem still remains, so we have to wait for the Flash Player to be enabled again to solve this problem

    Thanks to All for the feedback and confirmation of problem

  11. hornbet
    Member
    Posted 1 year ago #

    I have same problem it was working fine then stopped working in Safari, Firefox shows download link, chrome shows nothing (like Safari). I think problem began after install of jatpack update.

  12. two7s_clash
    Member
    Posted 1 year ago #

    Yeah, the flash fallback is dead in the water. Jetpack is trying to load http://s0.wp.com/wp-content/plugins/audio-player/player.swf which is returning a 404, at least for me. This could well be related to our geography or server load.

  13. two7s_clash
    Member
    Posted 1 year ago #

  14. two7s_clash
    Member
    Posted 1 year ago #

    Here is a temporary fix:

    Grab this old plugin (what Jetpack's audio support is based from) http://wordpress.org/extend/plugins/audio-player/developers/. Don't install it though. Find the "player.swf" file inside "\audio-player.2.0.4.6\audio-player\assets" Place this somewhere on your site, a good place is in your plugin directory.
    Then go to "/wp-content/plugins/jetpack/modules/shortcodes" on your ftp, and edit "audio.php" Change line 237 to your local copy of "player.swf"

  15. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thank you all for the reports! We're working on a fix and we will release a new version of Jetpack to solve the issue as soon as possible.

    Related Trac ticket: #1679

  16. SARed
    Member
    Posted 1 year ago #

    @two7s_clash Thanks. Your fix works perfectly for Chrome, IE 10, Firefox and Safari.

    @Jeremy Herve Thanks for the feedback. I will look out for the update

  17. hornbet
    Member
    Posted 1 year ago #

    @two7s_clash Thank you. The fix worked for me too in Chrome, Firefox and Safari.
    When they do the new update will it be necessary to change any thing in your fix? or just leave it like it is?

    Thnx again

  18. two7s_clash
    Member
    Posted 1 year ago #

    For anyone using my fix, you'll need to revert back to the original url of "player.swf". See my original comment.

  19. neville
    Member
    Posted 1 year ago #

    Saw this morning that all instances of the audio shortcode on my blog (http://www.nevillehobson.com) no longer work, ie, only blank spaces.

    Then I found this thread. So not going crazy after all ;) Thanks, WP guys, hope to see that Jetpack fix asap.

  20. Han-earl Park
    Member
    Posted 1 year ago #

    It appears to be working now. player.swf is back and accessible.

  21. SARed
    Member
    Posted 1 year ago #

    Yes it is working - Thanks for letting us know Han-earl.

    I have taken two7s_clash's fix out and pointed the file at the original player.swf file and it works

  22. neville
    Member
    Posted 1 year ago #

    Just saw 2.2.2 pushed out. Updated the plugin - and audio now working properly.

    Thanks!

  23. SARed
    Member
    Posted 1 year ago #

    My update to 2.2.2 is not working. Please see this thread

    http://wordpress.org/support/topic/audio-embed-shortcode-not-working-ver-222

  24. dsmhome
    Member
    Posted 1 year ago #

    I'm using Firefox 20.0.1 and the flash player fallback seems to work on en.support.wordpress.com/audio/ but not on my site. Is there a reason for this? Is WordPress.com using a new/different JetPack and Flash player fallback?

    I'm using JetPack 2.2.2, WordPress 3.5.1

    http://davidmeharey.com/blog/coding/html5-audio-with-fallback-in-wordpress/

  25. dsmhome
    Member
    Posted 1 year ago #

    The 404 issue is resolved but other items mention in this topic aren't.

  26. esmi
    Forum Moderator
    Posted 1 year ago #

    This is not your topic. As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem - despite any similarity in symptoms - is likely to be completely different.

  27. dsmhome
    Member
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic