WordPress.org

Ready to get started?Download WordPress

Forums

Attempt to fix "minor" error leads to bigger problems (6 posts)

  1. loneplacebo
    Member
    Posted 4 years ago #

    I was attempting to fix the fatal error allowed memory size of XXX exceeded problem I kept getting on my WP dashboard and when I tried accessing some of my plugins. I edited the wp-setting.php file to increase the memory from 32 mb to 64 mb.

    if ( !defined('WP_MEMORY_LIMIT') )
    	define('WP_MEMORY_LIMIT', '32M');
    if ( !defined('WP_MEMORY_LIMIT') )
    	define('WP_MEMORY_LIMIT', '64M');

    After uploading it to the server via FTP, I could no longer access my WP dashboard and launching my website(http://loneplacebo.com) is also impossible. I get this message every time: Fatal error: Call to undefined function is_admin() in /home/loneplac/public_html/wp-includes/vars.php on line 16

    I contacted my web host for advice, and they told me to install a default php.ini file and edit the memory limits there. I did as told, changing the memory to 128mb.
    memory_limit = 32M ; Maximum amount of memory a script may consume (32MB)
    memory_limit = 128M ; Maximum amount of memory a script may consume (128MB)
    Nothing changed. I tried 64 mb. Nothing still. Then I contacted them again, and they told me to change the php configuration to php5(single php.ini). Nothing changed again.

    Please help me. This is really stressing me out.

  2. Len
    Member
    Posted 4 years ago #

    Call to undefined function... is almost always caused by missing or corrupt files. A shot in the dark, have you recently used the automatic upgrade feature to upgrade to 2.9? I ask this because I have heard a few problems related to it resulting in this particular error message. (calling is_admin in /wp-includes/var.php L16)

    First, undo whatever it is you did. Then try a manual upgrade.
    http://codex.wordpress.org/Upgrading_WordPress_Extended

  3. loneplacebo
    Member
    Posted 4 years ago #

    Yes, I did use the automatic upgrade to 2.9 recently. In fact, the fatal error memory limit problem was already present on my dashboard prior to the upgrade. Only when I edited the wp-setting.php did the WP dashboard and site become inaccessible.

    How come when I change the wp-settings.php back to its original form, things that not revert back to normal?

  4. Len
    Member
    Posted 4 years ago #

    Like I said, the auto-upgrade may have borked something. I've seen this error message in conjunction with auto-upgrade a couple of times. The only thing I can think of recommending at this point is a manual upgrade (well not really a manual upgrade, more of a re-install) as per the directions in the link I gave you.

    Basically...

    1. Delete wp-admin and wp-includes folder
    2. Leave the wp-contents folder alone
    3. Delete the files that live at root EXCEPT for the wp-config.php file
    4. If you have added any custom rules to your htaccess file you might want to live that alone as well
    5. Upload new files

    It's important to note: delete and upload as opposed to overwriting.

    With respect to the memory errors your host will probably have to sort that out.

  5. loneplacebo
    Member
    Posted 4 years ago #

    Thanks for the advice, LenK. I've been trying to contact my web host about restoring the site from a saved backup less than a week ago, but apparently there is something called a "holiday break." So much for, 24/7 service.

    Anyways, I'll look into the method you presented. Hope things will improve.

  6. loneplacebo
    Member
    Posted 4 years ago #

    Sorry for the late response but things returned to normal after I manually "reupgraded" to WordPress 2.9. Also, it seems that overwriting files with an edited version produces a bunch of errors. I instead delete and then upload the new document via FTP. Thanks again, LenK!

Topic Closed

This topic has been closed to new replies.

About this Topic