WordPress.org

Ready to get started?Download WordPress

Forums

WP User Frontend
[resolved] Attachments do not work in IE8 (5 posts)

  1. Runamok81
    Member
    Posted 1 year ago #

    Great plugin, but only works in chrome and FF.

    The issues I am seeing is that attachments do not show in IE8, and the "Add another" button doesn't trigger a file open dialog. Instead, it shifts focus to the submit button.

    Can anyone verify that they have success using the attachments portion of this plugin on IE?

    http://wordpress.org/extend/plugins/wp-user-frontend/

  2. Runamok81
    Member
    Posted 1 year ago #

    Also tested not working on a different IE9 machine. Same symptoms.

  3. Runamok81
    Member
    Posted 1 year ago #

    Disabled all other plugins, symptoms persist.

    Anyone have this working in IE?

  4. Runamok81
    Member
    Posted 1 year ago #

    Success! This plugin is wired to detect and user silverlight for plupload. That is the source of the IE issues!

    I have stipped out all reference to silverlight on lines 45 and 52 of wp-user-frontend\lib\attachment.php.

    Here is my new attachment.php

    I hope the author sees this and issues a patch!
    Hope this helps someone else!

  5. Runamok81
    Member
    Posted 1 year ago #

    The root cause of my issues above was that my webserver (IIS6) does not have the silverlight mimetypes registered. No need to strip silverlight. After registering the silverlight mimetypes on IIS6, I used the original code and everything works! Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic