WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
Attachments and File Uploads not working in Contact Form 7 (26 posts)

  1. rehtaeh
    Member
    Posted 2 years ago #

    Hello

    I'm running a mac OSX 10.6.8, using firefox, chrome, safari

    I have configured the contact form 7 in my wordpress site with 2 file upload attachment options. One is to upload a jpg and the other is an MP3.

    I have done many tests on the form, but whenever I select files to be attached in the form, it completely stalls when I hit the "send" button. It just stays in the "processing" mode. No error message or anything like that. Just complete stall when I hit 'send'. The forms works fine when I don't attach any files, all the other fields come through fine, but the attachments seems to be causing a problem. Not sure why?

    In the "attachments" box in the form settings I have put
    [image] [audio]

    Here is the code I'm using, can someone please help me?

    Thanks

    [Code moderated as per the Forum Rules. Please use the pastebin]

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Janasworld
    Member
    Posted 2 years ago #

    I have since yesterday with the new update the same problem. I hope that the bug will be fixed soon because I need the forms.

  3. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

  4. Janasworld
    Member
    Posted 2 years ago #

    The answer does not help! Sorry! I've set the plugin to 3.0 and now it's back again.

  5. rehtaeh
    Member
    Posted 2 years ago #

    Thanks for your posts :)

    Does this answer mean that Contact From 7 only works (with attachments/uploads etc) if it is the only plugin being used at any one time?

    From FAQ:
    The spinning arrow icon shows up once I submit a form, but then nothing happens.


    This is most probably due to a conflict between plugins/theme. Try deactivating all other plugins and switching to the default theme.

    I need the other plugins I'm using.
    I'm running Headway Themes. Maybe Contact Form 7 Doesn't like Headway!?

    Janasworld...
    >> I've set the plugin to 3.0 and now it's back again.

    Do you mean the Contact Form 7 plugin you've set back to 3.0? or...

    Many thanks

  6. Evan Jacobs
    Member
    Posted 2 years ago #

    I'd like to weigh in on this as well:

    I'm having similar problems... the plugin itself seems to be working for forms without file attachments, but the attachment is causing jQuery errors and breaking the process...

    "Uncaught RangeError: Maximum call stack size exceeded" - Takayuki you can see this if you go to http://castleford.com.au/test-career-page and try to submit the form with a debug console running.

    Any ideas on how to fix this are appreciated!

  7. Evan Jacobs
    Member
    Posted 2 years ago #

    Note: This works with Javascript turned off. So it's *definitely* a JS issue.

    I'm running jQuery 1.7.1 on my website and also tested it with 1.6 - got the same results... endlessly spinning arrow with no emails and the error listed above.

  8. Litso
    Member
    Posted 2 years ago #

    Hey,

    I'm running into the same problem, so I've been fiddling around with the scripts that the plugin uses.

    I've determined that the problem exists in the scripts.js in the Contact Form 7 plugin folder. If you comment out the first big function (rule 10 through 63) the uploads work fine.

    I have no idea what exactly I disabled by doing so, so if you use this hack please do test your plugin extensively to see if it still does all it's supposed to. Hope this helps anyone, and especially hope the plugin author will fix this!

  9. Evan Jacobs
    Member
    Posted 2 years ago #

    Any ideas Takayuki? Your JS is a little outside my realm or I'd offer to help :-/

  10. rehtaeh
    Member
    Posted 2 years ago #

    I'm a beginner at code and so I'm not sure how to do what Litso has suggested?

    I've determined that the problem exists in the scripts.js in the Contact Form 7 plugin folder. If you comment out the first big function (rule 10 through 63) the uploads work fine.

    Would love some help if possible.

    For now I've started with another form using visual-form-builder.1.8 which attached files perfectly, but the downside is that it doesn't have captcha.

  11. Behelden
    Member
    Posted 2 years ago #

    If the current version causes so many conflicts with other plugins and themes, maybe reverting back to the prior version is the best course.

    I don't suppose there's a straightforward way to acquire the older version of the plugin?

  12. Janasworld
    Member
    Posted 2 years ago #

    Janasworld...
    >> I've set the plugin to 3.0 and now it's back again.

    rehtaeh...
    Do you mean the Contact Form 7 plugin you've set back to 3.0? or...

    Yes, its right!

  13. rehtaeh
    Member
    Posted 2 years ago #

    thanks Janasworld
    How do I get a download of the older 3 version?

  14. Janasworld
    Member
    Posted 2 years ago #

  15. janellv
    Member
    Posted 2 years ago #

    I have been having this same problem too. Thanks for the info, Janasworld, I went back to 3.0 as well and it works great. I don't have time at the moment to go through and test all of my plugins to figure out what is going wrong.... If we had any more information than "it's a plugin conflict" that would be great....

  16. rehtaeh
    Member
    Posted 2 years ago #

    Thanks for the download link Janasworld :)
    I'll download 3.0 and try it out!

    I don't have time at the moment to go through and test all of my plugins to figure out what is going wrong.... If we had any more information than "it's a plugin conflict" that would be great....

    Same here!! :)

  17. svalle
    Member
    Posted 2 years ago #

    Thanks for the download link Janasworld :)
    I'll download 3.0 and try it out!

    I don't have time at the moment to go through and test all of my plugins to figure out what is going wrong.... If we had any more information than "it's a plugin conflict" that would be great....

    Same here!! :)

    Downgrading to CF7 version 3.0 also made it work for me, i.e., it must be an internal CF7 problem... :(

  18. TXC
    Member
    Posted 2 years ago #

    Hi!

    I had the same issue. But when I downgraded jquery.form.js from 2.94 to 2.87 my issues had gone.

    It's just new version of jQuery plugin fault.

    To resolve this issue you can download "Contact Form 7" plugin, version 3.0.1 and just replace existing jquery.form.js with this old one.

    Have a fun! Happy New Year!

  19. jamblo
    Member
    Posted 2 years ago #

    Nice one chaps, was stuck until I found this thread!

    All hail the jquery.form.js file from v.3.0.1!

  20. shotbyadam
    Member
    Posted 2 years ago #

    How do you replace the .js file? Sorry, I'm really new at this. I've tried downgrading my version to 3.0 and that didn't work so any other ideas or assistance is greatly appreciated. Thanks!

  21. jamblo
    Member
    Posted 2 years ago #

    Download the zip linked above my post and overwrite the jquery.form.js in your CF7 folder.

  22. wpp4me
    Member
    Posted 2 years ago #

    Hi!

    I had the same issue. But when I downgraded jquery.form.js from 2.94 to 2.87 my issues had gone.

    It's just new version of jQuery plugin fault.

    To resolve this issue you can download "Contact Form 7" plugin, version 3.0.1 and just replace existing jquery.form.js with this old one.

    Have a fun! Happy New Year!

    This worked like a charm! Thanks so much!

  23. WebDi
    Member
    Posted 2 years ago #

    Thanks so much @TXC. Your solution worked for me.

  24. pavlosli
    Member
    Posted 2 years ago #

    It worked for me too, so I'm confirming that replacing your jquery.form.js file with its 2.87 version solves the problem.

    thanx TXC :)

  25. mattritter
    Member
    Posted 2 years ago #

    Thanks TXC. It now works swimmingly!

    Just FYI, the "jquery.form.js" file has moved to the "js" folder in the plugin files.

  26. hubet
    Member
    Posted 1 year ago #

    @wpp4me, so can i use the last version of CF7 and just replace existing jquery.form.js?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic