WordPress.org

Ready to get started?Download WordPress

Forums

Atom 0.3 in 2.1!?!?!?!? (12 posts)

  1. shelleyp
    Member
    Posted 7 years ago #

    I was astonished to see a deprecated, invalid feed syndication format in WordPress 2.1. After people busted their butts to try and get a patch in that met "Matt's standards", this is how WordPress serves the community?

    What's the excuse now for continuing to put a Atom 0.3 feed in?

  2. spencerp
    Member
    Posted 7 years ago #

    Will this guy's blog post help maybe? I'm not great with the FEEDS so, maybe someone else can help you better? Good luck Shelley!

    spencerp

  3. shelleyp
    Member
    Posted 7 years ago #

    No that has to do with autodiscovery. I have my own hacked version of Atom 1.0 for WordPress, but I had hoped I wouldn't have to continue using it.

  4. spencerp
    Member
    Posted 7 years ago #

    Ahhh, okay. :) Hmm, I'm not sure then, but hopefully someone that might *know* will swing by soon though.. :);)

    spencerp

  5. Chris_K
    Member
    Posted 7 years ago #

    You may have a better chance of getting Developers' attention on the wp-hackers list.

  6. shelleyp
    Member
    Posted 7 years ago #

    No way. This is one that needs to be discussed right up front, for all the WP users to see and appreciate.

    There have been patches for this, and people have installed Atom 1.0 patches, but they never get rolled out. The developers are aware of this.

  7. Chris_K
    Member
    Posted 7 years ago #

    You probably noticed how often the developers hang out here. (hint: not often).

  8. spencerp
    Member
    Posted 7 years ago #

    You probably noticed how often the developers hang out here. (hint: not often).

    Hahaha.. That's true though! They are hardly ever in here sigh. You still might want to try here though.. ;)
    http://lists.automattic.com/mailman/listinfo/wp-hackers

    spencerp

  9. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    ATOM itself is a pretty dead format. Why use it at all?

    I just edited my theme to hide the ATOM and RSSv1 feeds and never looked back. Why support several syndication formats that all do more or less the same thing anyway? It just confuses your users.

  10. Brian Layman
    Member
    Posted 7 years ago #

    This is a question directly to the direction of WordPress development. If you have strong feelings about where WordPress development is going, WP-Hackers IS the place created for that discussion. That's why it exists.

  11. Mark Jaquith
    WordPress Lead Dev
    Posted 7 years ago #

    Atom 1.0 will be in WP 2.2 -- Matt checked in some patches already. And patches have gone in for APP support as well.

    A decision was made early on about the inclusion of Atom 1.0 in WP 2.1 (namely: that it wouldn't be). It made sense at the time, but as the release date slipped (and slipped, and slipped), the decision wasn't revisited, and the people who were pushing it in early 2006 didn't really speak up until after 2.1 was released.

    2.1's development cycle was far from ideal, and it's something we're trying to fix for 2.2 with a defined release date and easy ways for end users to voice feature suggestions. Because the development cycle will be so much shorter, there is less of a chance that early decisions will look outdated at the end of the cycle.

    The above is just my take on it, and my level of influence on the project was much lower in early 2006 than it is now, so I'll ping Matt on this and he can give you his take.

  12. Matt Mullenweg
    Troublemaker
    Posted 7 years ago #

    You can vote for the inclusion of Atom API support here:

    http://wordpress.org/extend/ideas/topic.php?id=2

    And Atom syndication support here:

    http://wordpress.org/extend/ideas/topic.php?id=286

    We were one of the first to include 0.3 support, mostly because of pressure from the very same people who criticize 2.1 for not having 1.0 support. Around the time of 0.3, they assured me that it was safe to include because the IETF process was just going to be a rubber stamp, only take a few months, and the spec that came out would be overwhelmingly similar to 0.3. That obviously didn't happen, and so I was very hesitant to change our Atom template before it was a ratified standard and had support in all the major aggregators (particularly Bloglines). Our users wouldn't care that the template was now more correct than it used to be, they'd just know that their feeds worked before they upgraded WordPress, and after they upgraded WP they broke.

    The point is moot though as none of those issues apply anymore and we now have validating Atom 1.0 support in trunk and it will be released as part of 2.2 on April 23rd.

Topic Closed

This topic has been closed to new replies.

About this Topic