WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Atahualpa theme: Need IE fix for placement of Logo and tagline (2 posts)

  1. fielddesign
    Member
    Posted 4 years ago #

    I need help with positioning a horizontal logo and the tagline within the header area of the Atahualpa theme. Using the theme options for Atahualpa in the WP dashboard, I am altering the CSS for the img tag of the logo so it has a negative top margin (-20px) and I then moved the tagline to position under the logo by altering the CSS on it's p tag so it has a top margin (50px) and a negative text-indent of -249px (so it left aligns with the logo).

    This works fine in Safari and Firefox, but in IE7 both the logo and tagline get clipped off at the point where they go into the negative area. Any CSS solutions/hacks are greatly appreciated.

    Here's a link to the test site: http://mirthless.com/b2bmemes/

    P.S. I know I can just make the tagline part of the logo graphic and then hide it's html version, but my client wants the option to edit/change the tagline.

  2. fielddesign
    Member
    Posted 4 years ago #

    I figured out a solution. In case anyone is wondering, I turned off the logo in the theme options of the dashboard and made it background image in the main container for the logo area (A table!--this is a table based layout... is that old-fashioned or is there a purpose for it?). Then I used CSS to position the background image and tagline...

    Anyway, to avoid IE hell, don't use negative settings on margins or text indent!

    Cheers

Topic Closed

This topic has been closed to new replies.

About this Topic