WordPress.org

Ready to get started?Download WordPress

Forums

Assistance moving entire site from hosting company to local PC. (3 posts)

  1. w1ze07513
    Member
    Posted 3 years ago #

    Hello everyone,
    I have a site at my hosting provider (godaddy). They use applications such as mySQL and wordpress which is associated with the site. I would like to be able to move my entire site to my local machine at home so I can continue to
    work on it versus working on it live at the hosting provider.

    Steps I have taken.
    1. Installed IIS7 on my local PC
    2. Installed WordPress 3.0.3 on my local PC
    3. Installed mySQL and PHP on my local PC + mySQL workbench.
    4. Used my local FTP client to connect to my hosting provider and copy all the files from the root of my site to my local PC.
    5. As I am currently working with a mySQL database with this site I require to move the database to my local PC as well to make it work.
    the hosting provider have an interface that allows the user to perform a backup of the database which exports it to the database name .sql extension. This database has a name called spi1019804395917.sql

    My issue begins with attempting to move this database and import it to my local PC so I can start browsing it locally on my PC and be able to access the wordpress Admin part to edit the pages and add new content.
    Included in this post are two screenshots I took. First is a folder view of what I currently have in IIS7 and then the next is the Error I come across when attempting to browse into the /wp-admin/ section of the site in order to view the content I moved over. It appears as if the page is still trying to access my hosting provider or I didn't not import right or am missing something.
    Are there specific steps that someone can point me to so I can try following to see what I am doing wrong? Please ask me anything that is unclear cause I am sure there is a lot of details I am leaving out but I simply do not know where to begin with this. Thank you.

    http://i1112.photobucket.com/albums/k496/w1ze07513/IIS7wordpress.png
    http://i1112.photobucket.com/albums/k496/w1ze07513/IIS7wordpress_BrowsingError.png

  2. misterpatrick67
    Member
    Posted 3 years ago #

    Do you have phpMyAdmin installed? Do that, it's free. Take a look at the table wp_options. Change the siteurl field one the first page and the home field on the second page. You can also do a database search for your old URL and see where else it's pointing to your old host. You have to change both of those fields to get things working. Hope that helps.

  3. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 3 years ago #

    Have you also edited the wp-config.php file to reflect the settings of the local MySQL db rather than the hosted one?

    Once you have changed the siteurl & home fields, resave your permalinks. I'm not sure not that pretty permalinks will work on IIS7 though, so you may need to set it to use default 'fugly' permalinks for the local install.

    Any path stored in the db, eg paths to images will need to be updated with a search & replace.

Topic Closed

This topic has been closed to new replies.

About this Topic