WordPress.org

Ready to get started?Download WordPress

Forums

Askapache Password Protect Plug In (6 posts)

  1. internationalhardman
    Member
    Posted 6 years ago #

    Hi folks

    I am trying to toughen up my blog against hacks etc. and have tried to install the above plugin as suggested by wordpress.

    I downloaded the .rar file, unzipped it, then uploaded it into wp-content/plugins .dir.

    When I hit activate to activate the plugin i get this message.

    Plugin could not be activated because it triggered a fatal error.

    Fatal error: Cannot redeclare aa_pp_options_setup1() (previously declared in /home/ladyboym/public_html/wp-content/plugins/askapache-password-protect/askapache-password-protect.php:51) in /home/ladyboym/public_html/wp-content/plugins/askapache-password-protect/askapache-password-protect.php on line 52

    Can anybody point out where I am going wrong?

  2. Michael Torbert
    WordPress Virtuoso
    Posted 6 years ago #

    I don't know, but someone else was having an unrelated problem with that plugin this morning (it locked him out completely of wp-admin).

    Try WP Security Scan

  3. internationalhardman
    Member
    Posted 6 years ago #

    Thanks a lot for your help mate... much appreciated

  4. tonicwater
    Member
    Posted 6 years ago #

    Hi Hall, strange, I'm facing this same issue you described. Once the plugin is activated, and new password submitted, entire wp-admin is locked out. Tried it on several new installs and over different hosting companies and am getting same result. Anyone any suggestion?

  5. ollythebuilder
    Member
    Posted 6 years ago #

    hmmn, same deal here...using 4.2.4, with 2.5.1, on Lunarpages.

    getting a 404, and locked out of admin.

    have scoured AA's site, and comments, tried everyone's workarounds, but it's the same problem.

    ...one thing, on clicking the config tab of teh AAPP plugin, i get two failures...

    Test for mod_security capability [ FAILED ]
    503 Response: 200 OK

    and

    Test for PLAIN encryption capability [ FAILED ]
    200 Response: 401 Unauthorized
    401 Response:: 401 Unauthorized

    ...which maybe means I shouldn't be trying to install the plugin anyway! I tried deleting wp's existing htaccess files to get around these errors but they're still there.

    I wonder, any other clues? or could it be lunarpages server?

  6. designsimply
    Member
    Posted 6 years ago #

    ollythebuilder, I'm sure you have resolved this by now, but you should delete the wp-admin/.htaccess file to deactivate the effects of the AskApache Password Plugin, not the .htaccess file created by WordPress in the main WordPress folder.

Topic Closed

This topic has been closed to new replies.

About this Topic