WordPress.org

Ready to get started?Download WordPress

Forums

Vixy YouTube Embed and Download
[resolved] Artiss youtube embed using headway framework (7 posts)

  1. Begin
    Member
    Posted 1 year ago #

    Hi! I use this great plugin in my regular theme and it works great!

    I use it like that:

    <?php /* Start the Loop */ ?>
    <?php while ( have_posts() ) : the_post(); ?>
    
    <span id="HomeVideoThumb" style="z-index: 10; background: white; display: block;"><?php youtube_video_embed( '' . get_post_meta($post->ID, 'image', true) . '' ); ?></span>
    
    <h1 class="entry-title"><a href="<?php the_permalink(); ?>" title="<?php echo esc_attr( sprintf( __( 'Permalink to %s', 'twentyeleven' ), the_title_attribute( 'echo=0' ) ) ); ?>" rel="bookmark"><?php the_title(); ?></a></h1>
    
    <span style="display: block; padding: 0px 7px; font-size: 13px;"><?php the_excerpt(); ?></span>
    
    <a href="<?php the_permalink(); ?>" title="<?php echo esc_attr( sprintf( __( 'Permalink to %s', 'twentyeleven' ), the_title_attribute( 'echo=0' ) ) ); ?>" rel="bookmark">Watch Video</a>
    
    <?php endwhile; ?>

    As you see, i am calling the video id from an custom field:
    <?php youtube_video_embed( '' . get_post_meta($post->ID, 'image', true) . '' ); ?>

    Now, as i said it works great on my regular theme, but when i am using it with the headway framework theme it gives me this error:

    January 24, 2013
    Artiss YouTube Embed: No video/playlist ID has been supplied

    I tried asking the headway people, but they didn't answer...

    Any Idea will help!

    Thanks!

    http://wordpress.org/extend/plugins/youtube-embed/

  2. Applian Technologies, Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    As the error is suggesting your code is not passing in a URL or video ID at this point.

    I'm guessing that where you've added it to your theme the information you're requesting is not available. For instance, in this theme, you may be requesting the post meta outside of "the loop".

    Applian

  3. Begin
    Member
    Posted 1 year ago #

    Now, as i said it works great on my regular theme

  4. Applian Technologies, Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    Which tells you that it's a theme problem - for whatever reason the code is not picking up a video ID and not passing it on.

    Applian

  5. Begin
    Member
    Posted 1 year ago #

    I know it's a theme problem, but what can it be?

  6. Applian Technologies, Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    I would suggest asking the question to the wider WordPress community - maybe in the theme forum...

    http://wordpress.org/support/forum/themes-and-templates

    It's not an issue with this plugin and I can't really advise on individual's theme modifications.

    Applian.

  7. Applian Technologies, Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    No further updates - resolving.

    Applian.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic