WordPress.org

Ready to get started?Download WordPress

Forums

Are there a fix for the image upload issue on WP 2.2.2 (12 posts)

  1. pangitster
    Member
    Posted 6 years ago #

    Hey guys, I've updated my WP 2.2.1 to 2.2.2 and since then I can't upload images through the admin area. When I click the upload button after choosing the image to upload, the page will just refresh and if you browse all the images, the image you want to upload isn't there. I've check the uploads folder through the ftp and it is not there. I think the image upload on WP 2.2.2 doesn't work. Or may be there's something wrong to this. Please help :(

    ---------------
    [advertisement moderated. Resist the urge]

  2. erika_conn
    Member
    Posted 6 years ago #

    I believe there is something seriously wrong with 2.2.2. I've created 2 new blogs using this update and I have the image issue on both.

    Let me know when you've found an answer.

  3. erika_conn
    Member
    Posted 6 years ago #

    I tried by uploading using ftp and placing the pictures into wp-content/uploads. Trouble is, when I get the url for a certain picture and place it in the post, nothing shows up.

    So, to repeat myself, when attempting to upload pictures in wp, the error reads:
    The uploaded file could not be moved to /home/cecon46/public_html/saycheese/wp-content.
    Warning: Cannot modify header information - headers already sent by (output started at /home/cecon46/public_html/saycheese/wp-admin/admin-functions.php:1986) in /home/cecon46/public_html/saycheese/wp-includes/functions.php on line 1357

    line 1986 says this:
    wp_die( printf( __('The uploaded file could not be moved to %s.' ), $uploads['path'] ));

    And line 1357 reads:
    $selected = " selected='selected'";

    Is that supposed to mean something to me?
    Man, I'm ready to spit nails

  4. erika_conn
    Member
    Posted 6 years ago #

    And to continue - I can upload using the img code. Trouble is, I have to resize the image and then there is no thumbnail that you can click to get a larger image. This is a royal pain.

  5. impress
    Member
    Posted 6 years ago #

    Recently I having a problem by using wordpress image upload ==> Write > post > upload , always returned an error said permission not set even the permission for the specific folder already set to "777". Finally my host help me to solve this problem by the following step:

    > OPTION
    > Miscellaneous

    uncheck the following line:
    >Organize my uploads into month- and year-based folders
    >update options

    it works after this action, but I have another hosting with the above line "checked" the image can be upload without any problem, so I would said this is not a final solution, but you can give a try.

  6. erika_conn
    Member
    Posted 6 years ago #

    So, I guess nobody can help us. :(

  7. thugparlay
    Member
    Posted 6 years ago #

    CHMOD all of the wp-content/uploads/2007/etc/etc folders to 777.

    if you do a search on this problem thats what most of the users are doing.

  8. erika_conn
    Member
    Posted 6 years ago #

    Thank you thugparlay and impress but I checked and all my uploads are 777. As well, the Organize my Uploads......... is left unchecked.

    I'm screaming out of sheer frustration. Can you hear me?
    Why are none of the moderators answering my call for help?

  9. Chris_K
    Member
    Posted 6 years ago #

    Why are none of the moderators answering my call for help?

    Because moderators are not all-knowing or omniscient. If we don't know, we can't answer.

    Fortunately, moderators aren't the only volunteer helpers here and perhaps someone else will have ideas.

  10. Jeremy Clark
    Moderator
    Posted 6 years ago #

    Don't have to be a moderator to know what your talking about as thugparlay has established the correct thinking would be to chmod your folders as he has said, apparently there is more going on with your hosting so maybe contacting them might help.

    I know you said that it stop working after the upgrade, but you didn't say what you upgraded from and therefore we can't say if maybe your host isn't within the minimum requirements for WP 2.2.2.

    I think your best course of action would be to have a chat with your host and maybe have a look of your logs and see if there is any error messages that might further help with your problem.

  11. tanyaiscrazy
    Member
    Posted 6 years ago #

    Thank you, thugparlay! You rock! :-D

  12. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    The uploaded file could not be moved to .../wp-content.

    For reference, this invariably means one of these three things:
    1. Your permissions are set wrong somewhere.
    2. You have ran out of disk space or quota or something.
    3. You need to talk to your host about it.

    Nobody else can solve these problems for you. If it's not #1 or #2, then we can't help you here, talk to your host.

Topic Closed

This topic has been closed to new replies.

About this Topic