WordPress.org

Ready to get started?Download WordPress

Forums

Are subdomains in a multisite setup virtual? (3 posts)

  1. djangeloni
    Member
    Posted 8 months ago #

    Im having issues getting the subdomains working. When I add a new site via the wordpress network administration the site gets created but there are no files associated with the install. So when i go to the dashboard or visit the webiste it doesnt exist.

    I setup the wildcard DNS settings and also setup a wildcard for the subdomains in plesk.

    I guess the ultimate question is does wordpress multisite setup virtual subdomains or are the phyiscal?

    If there phyiscal do i need to install a new version of wordpress and somehow tie in multisite to it for each subdomain? or should multisite be creating all the files for me

  2. Yes, the subdomains are virtual.

    So when i go to the dashboard or visit the webiste it doesnt exist.

    What's the 404 look like? If it's a plesk 404, then you did not set up wildcard subdomains correctly for your server. Sadly they're all a little different.

    What should happen, with a properly setup wildcard, is that anything.yourdomain.com will bring up something. If it's a real site, it'll load the site. if not, it'll tell you the site doesn't exist and let you make one OR tell you that you turned off site generation.

  3. djangeloni
    Member
    Posted 8 months ago #

    Was a plesk 404 error. I'm going to have my server team set up the wildcard subdomain. After reading your post and doing some research that definitely seems to be the issue.

    Thanks for the help!

Reply

You must log in to post.

About this Topic